Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Installing Samsung ML-1640 Drivers
footsore tramp
 Posted: Jun 7 2011, 12:08 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 17
Member No.: 247
Joined: 5-June 11









Hello,
I attempted to install the driver for a ML-1640from the cd because one website said that they had success. Unfortunately I didn't. I then found the Linux Foundation site and they had a driver and instructions up.
http://www.openprinting.org/printer/samsung/samsung-ml-1640 Drivers
http://www.linuxfoundation.org/collaborate/workgroups/openprinting/database/driverpackages Instructions

Their first set of instructions were:

"So before installing the first driver package install the "lsb" package with your distribution's package manager. Use the system's package management tool and search for the "lsb" package. Install it and accept also the installation of all packages which are needed by the "lsb" package (can be 20 or more packages).
To install by the command line, use for example
sudo apt-get install lsb
on Debian and Ubuntu and
yum install lsb
on Red Hat or Fedora."

so I typed in yum install lsb and I got this message:

Loaded plugins: refresh-packagekit
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/repo/6.0/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 : http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/repo/6.0/x86_64/repodata/repomd.xml
Trying other mirror.
http://wftp.tu-chemnitz.de/pub/linux/livna/repo/6.0/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 : http://wftp.tu-chemnitz.de/pub/linux/livna/repo/6.0/x86_64/repodata/repomd.xml
Trying other mirror.
http://rpm.livna.org/repo/6.0/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 : http://rpm.livna.org/repo/6.0/x86_64/repodata/repomd.xml
Trying other mirror.
ftp://mirrors.tummy.com/pub/rpm.livna.org/repo/6.0/x86_64/repodata/repomd.xml: [Errno 14] FTP Error 550 : ftp://mirrors.tummy.com/pub/rpm.livna.org/repo/6.0/x86_64/repodata/repomd.xml
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: livna. Please verify its path and try again

If I resolve the printer problem I should not be so bothersome to you all. I'll get to spend more playing (sensibly) with the shell and less time worrying about it.
Cheers.
PM
^
spoovy
 Posted: Jun 7 2011, 04:33 PM
Quote Post


SLF Moderator
****

Group: Moderators
Posts: 196
Member No.: 5
Joined: 8-April 11









Yum is not connecting to the livna repos for some reason. I have never used livna so I couldn't really comment, although a quick web search revealed that others are having similar problems - http://bit.ly/m0rrt8

You probably don't need it anyway, try "yum --disablerepo=livna install lsb"


--------------------
PM
^
U308
 Posted: Jun 7 2011, 05:14 PM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 484
Member No.: 32
Joined: 11-April 11









Anyone having problems with the rpmforge repo ?

Metadata file does not match checksum errors.

Have tried everything from yum clean all to yum makecache --disableplugin= fastestmirror

PM
^
footsore tramp
 Posted: Jun 8 2011, 02:07 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 17
Member No.: 247
Joined: 5-June 11









Thank you Spoovy. The line you suggested 'yum --disablerepo=livna install lsb' worked a treat.
I then followed the rest of the instructions and attempted to print. Unfortunately I am still unable to print. This time a trouble shooting program appeared and made an attempt to resolve the problem for me. I allowed it to debug and it gave me report. I won't paste it all here as it was very long and I'm not sure if it is good form or not. It starts off with this:

Page 1 (Scheduler not running?):
{'cups_connection_failure': False}
Page 2 (Choose printer):
{'cups_dest': <cups.Dest ML-1640-Series>,
'cups_instance': None,
'cups_queue': 'ML-1640-Series',
'cups_queue_listed': True}
Page 3 (Check printer sanity):
{'cups_device_uri_scheme': u'usb',
'cups_printer_dict': {'device-uri': u'usb://Samsung/ML-1640%20Series',
'printer-info': u'Samsung ML-1640 Series',
'printer-is-shared': True,
'printer-location': u'localhost.localdomain',
'printer-make-and-model': u'Samsung ML-1640 Series',
'printer-state': 3,
'printer-state-message': u'/usr/lib/cups/filter/rastertosamsungspl failed',
'printer-state-reasons': [u'none'],
'printer-type': 8392772,
'printer-uri-supported': u'ipp://localhost:631/printers/ML-1640-Series'},
'cups_printer_remote': False,
'is_cups_class': False,

That represents about one-tenth of the output. I can include the rest if it is needed.
Cheers,

PM
^
myhus
 Posted: Jan 2 2014, 08:34 AM
Quote Post


SLF Newbie


Group: Members
Posts: 1
Member No.: 2871
Joined: 2-January 14









PM
^
burakkucat
 Posted: Jan 2 2014, 01:46 PM
Quote Post


SLF Member
***

Group: Members
Posts: 93
Member No.: 14
Joined: 10-April 11









QUOTE (myhus @ Jan 2 2014, 08:34 AM)

installation and solution


No it is not.

Why do you think it necessary to post instructions, relating to installation on a BGW (Billy Gates Ware) system, in a Scientific Linux thread that is about 30 months old?


--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll