scientificlinuxforum.org QR code
Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Dell Precision Laptops: Turn On Suspend/hibernate
joutlan
 Posted: Apr 8 2011, 09:02 PM
Quote Post


SLF Founder
********

Group: Admins
Posts: 1180
Member No.: 1
Joined: 8-April 11









With my Dell Precision M6500 laptop, I cannot suspend or hibernate without the following boot option in /boot/grub/grub.conf as the LAST OPTION:


CODE
intel_iommu=on



This turns on dma remapping which is required for my machine. If you have a similar laptop, and suspend or hibernate doesn't follow through and wakes back up to the desktop, try this.

Thanks Damentz, maintainer of the Liquorix Kernel, for this tip.


--------------------
DΞLL Precision M6700: 17 inch NB//i7-quad w/USB 3.0, 16.0GB, Quadro K5000M 2.0GB DDR3, RGBLED //W8P64/Scientific Linux 6.4 x64
DΞLL Vostro 3350 Nirvana: 13 inch NB w/ IntelSSD// W8Px64 (Work;Games)
Nexus 4 //Android
PMEmail PosterUsers WebsiteIntegrity Messenger IM
^
ullysse
 Posted: Oct 31 2012, 07:11 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 19
Member No.: 1900
Joined: 3-October 12









Will the option be safe for Dell XPS 15Z?

Does it need to be added as is to grub.conf?


QUOTE (joutlan @ Apr 8 2011, 09:02 PM)
With my Dell Precision M6500 laptop, I cannot suspend or hibernate without the following boot option in /boot/grub/grub.conf as the LAST OPTION:


CODE
intel_iommu=on



This turns on dma remapping which is required for my machine. If you have a similar laptop, and suspend or hibernate doesn't follow through and wakes back up to the desktop, try this.

Thanks Damentz, maintainer of the Liquorix Kernel, for this tip.

PM
^
joutlan
 Posted: Dec 13 2012, 03:41 AM
Quote Post


SLF Founder
********

Group: Admins
Posts: 1180
Member No.: 1
Joined: 8-April 11









Wow...I feel ashamed replying this late, but sure, that can edited or added rather to grub at boot-time....sorry for missing this!! sad.gif


--------------------
DΞLL Precision M6700: 17 inch NB//i7-quad w/USB 3.0, 16.0GB, Quadro K5000M 2.0GB DDR3, RGBLED //W8P64/Scientific Linux 6.4 x64
DΞLL Vostro 3350 Nirvana: 13 inch NB w/ IntelSSD// W8Px64 (Work;Games)
Nexus 4 //Android
PMEmail PosterUsers WebsiteIntegrity Messenger IM
^
ullysse
 Posted: Mar 8 2013, 11:02 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 19
Member No.: 1900
Joined: 3-October 12









Hello Joutlan,

back to this unresolved issue. I have grub.conf in /etc/ as well.
Here is a copy of the paramters / variables value:


-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,2)
# kernel /vmlinuz-version ro root=/dev/mapper/VolGroup-lv_root
# initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Scientific Linux CERN SLC (2.6.32-358.0.1.el6.x86_64)
root (hd0,2)
kernel /vmlinuz-2.6.32-358.0.1.el6.x86_64 ro root=/dev/mapper/VolGroup-lv_root rd_NO_LUKS KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VolGroup/lv_swap acpi=off rd_LVM_LV=VolGroup/lv_root SYSFONT=latarcyrheb-sun16 rd_NO_DM rhgb quiet crashkernel=auto
initrd /initramfs-2.6.32-358.0.1.el6.x86_64.img

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

What I have tested in the past was to turn acpi=on. It didn't work. System got stuck and I had to log from another kernel to turn it off.

Would you recommend adding the option you have used above to the list which appears here?


Thank you















QUOTE (joutlan @ Dec 13 2012, 03:41 AM)
Wow...I feel ashamed replying this late, but sure, that can edited or added rather to grub at boot-time....sorry for missing this!!   sad.gif
PM
^
helikaon
 Posted: Mar 8 2013, 02:55 PM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 521
Member No.: 4
Joined: 8-April 11









QUOTE (ullysse @ Mar 8 2013, 11:02 AM)
Hello Joutlan,

back to this unresolved issue. I have grub.conf in /etc/ as well.
Here is a copy of the paramters / variables value:


-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,2)
#          kernel /vmlinuz-version ro root=/dev/mapper/VolGroup-lv_root
#          initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Scientific Linux CERN SLC (2.6.32-358.0.1.el6.x86_64)
root (hd0,2)
kernel /vmlinuz-2.6.32-358.0.1.el6.x86_64 ro root=/dev/mapper/VolGroup-lv_root rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VolGroup/lv_swap acpi=off rd_LVM_LV=VolGroup/lv_root SYSFONT=latarcyrheb-sun16 rd_NO_DM rhgb quiet crashkernel=auto
initrd /initramfs-2.6.32-358.0.1.el6.x86_64.img

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

What I have tested in the past was to turn acpi=on. It didn't  work. System got stuck and I had to log from another kernel to turn it off.

Would you recommend adding the option you have used above to the list which appears here?


Thank you


Yes,
the option Joutlan posted above should be added at the end of this line like this:
CODE

kernel /vmlinuz-2.6.32-358.0.1.el6.x86_64 ro root=/dev/mapper/VolGroup-lv_root rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VolGroup/lv_swap acpi=off rd_LVM_LV=VolGroup/lv_root SYSFONT=latarcyrheb-sun16 rd_NO_DM rhgb quiet intel_iommu=on





cheers,


--------------------
PMEmail Poster
^
ullysse
 Posted: Mar 11 2013, 12:32 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 19
Member No.: 1900
Joined: 3-October 12









Adding the command resulted in the following:

half-way hibernate mode

When I send system to hibernate via /system/shutwon/hibernate, the screen goes black. The power button remains lit however and the disk activity is maintained to the same level as normal operation.

I have to press the power button to effectively send the system to hibernate.













QUOTE (helikaon @ Mar 8 2013, 02:55 PM)
QUOTE (ullysse @ Mar 8 2013, 11:02 AM)
Hello Joutlan,

back to this unresolved issue. I have grub.conf in /etc/ as well.
Here is a copy of the paramters / variables value:


-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,2)
#          kernel /vmlinuz-version ro root=/dev/mapper/VolGroup-lv_root
#          initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Scientific Linux CERN SLC (2.6.32-358.0.1.el6.x86_64)
root (hd0,2)
kernel /vmlinuz-2.6.32-358.0.1.el6.x86_64 ro root=/dev/mapper/VolGroup-lv_root rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VolGroup/lv_swap acpi=off rd_LVM_LV=VolGroup/lv_root SYSFONT=latarcyrheb-sun16 rd_NO_DM rhgb quiet crashkernel=auto
initrd /initramfs-2.6.32-358.0.1.el6.x86_64.img

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

What I have tested in the past was to turn acpi=on. It didn't  work. System got stuck and I had to log from another kernel to turn it off.

Would you recommend adding the option you have used above to the list which appears here?


Thank you


Yes,
the option Joutlan posted above should be added at the end of this line like this:
CODE

kernel /vmlinuz-2.6.32-358.0.1.el6.x86_64 ro root=/dev/mapper/VolGroup-lv_root rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VolGroup/lv_swap acpi=off rd_LVM_LV=VolGroup/lv_root SYSFONT=latarcyrheb-sun16 rd_NO_DM rhgb quiet intel_iommu=on





cheers,

PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll