Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> NFS4+MPICH2+Abinit + firewall, no route to host if firewall is enabled
raul_l
 Posted: May 3 2012, 04:09 PM
Quote Post


SLF Newbie


Group: Members
Posts: 7
Member No.: 1490
Joined: 22-April 12









Hello
I'm trying to run Abinit (a physics package) parallel over two home computers. In the past I've suceeded using two Ubuntus and the mpi implementation MPICH2, but now Ubuntu is replaced with SL. I have managed to create a shared directory and mount it in the client computer (192.168.1.79). If I run
CODE
# mpirun -np 8 -machinefile ~/machines abinit < scf1.files >& log

from the server (192.168.1.65) the output is
CODE
[proxy:0:1@x220] HYDU_sock_connect (./utils/sock/sock.c:203): unable to connect from "x220" to "192.168.1.65" (No route to host)
[proxy:0:1@x220] main (./pm/pmiserv/pmip.c:209): unable to connect to server 192.168.1.65 at port 44754 (check for firewalls!)

If both firewalls are down everything works fine. I have
CODE
RQUOTAD_PORT=875
LOCKD_TCPPORT=32803
LOCKD_UDPPORT=32769
MOUNTD_PORT=892
STATD_PORT=662
STATD_OUTGOING_PORT=2020

in /etc/sysconfig/nfs and enabled NFS4 under Trusted Services in the firewall configuration. I have services rpcbind, nfs and nfslock running on both computers. I suspect I need to open some ports and add something to /etc/hosts.allow but I'm quite new to all this. Also, the port 44754 above is different each time (I've heard something about nfs using random ports but don't know what to do about it).

I'm so lost here. I'm not even sure if the problem is related to NFS (because I can see the shared directory from the client just fine).


--------------------
Raul Laasner
PhD canditate, Institute of Physics
University of Tartu
142 Riia, Tartu, 51014, Estonia
e-mail: raullaasner@gmail.com
PM
^
raul_l
 Posted: May 3 2012, 08:55 PM
Quote Post


SLF Newbie


Group: Members
Posts: 7
Member No.: 1490
Joined: 22-April 12









Well, as I suspected there was nothing wrong with my nfs4 configuration. Mpich2 (and, it appears, other mpi implementations) uses random ports. If anyone is facing the same problem you can decleare MPICH_PORT_RANGE=<beg>:<end> to set the range of ports available to mpi and enable the same range in the firewall configuration of the server and all the clients. Nothing else needs to be modified other than enable 2049 tcp on the server and use 'mount' with '-t nfs4' on the client side (at least in SL 6.2).
Sorry for the confusion. I had read about nfs using random ports and thought that's where the problem lay. Perhaps there are some experts on parallel computing who can explain to me what is the reason for mpi using random ports (just curious)?


--------------------
Raul Laasner
PhD canditate, Institute of Physics
University of Tartu
142 Riia, Tartu, 51014, Estonia
e-mail: raullaasner@gmail.com
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll