scientificlinuxforum.org QR code
Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Samba Server reverse?
satnn
 Posted: Apr 13 2012, 03:18 AM
Quote Post


SLF Junior
**

Group: Members
Posts: 30
Member No.: 1028
Joined: 13-November 11









Hi all,
my test.server.com has an ip 192.168.x.y. I have added this info in my /etc/hosts file.

samba server authentication worked when I set hosts allow = IP, like this:
CODE

[global]
group = mygroup
security = user
hosts allow = 192.168.x.y


But using hostname or domain did not work:
CODE

[global]
group = mygroup
security = user
hosts allow = .server.com    or   test.server.com

I would like to hosts deny/allow using hostname over ip address. So far, unsuccessfully.

The weird thing was when I change to:
CODE

hosts deny = .server.com

it allowed server.com to be able to mount this samba server. So basically, my samba server behave like this:
hosts deny = .server.com <= did not block server.com. It allowed server.com domain to mount.

When:
hosts allow = .server.com <= did not allow .server.com. It blocked server.com domain from mounting. ????? http://www.madjacksports.com/forum/images/smilies/facepalm.gif

btw, this happened only to my samba server. My vsftpd, nfs, httpd, and sshd have no issue with the hostname.

Could some1 please justify or shed some light on this?
Thanks
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll