Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Latest versions of GCC in SL?
wearetheborg
 Posted: Mar 14 2012, 12:18 AM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 352
Member No.: 18
Joined: 11-April 11









Are there SL packages for the latest versions of gcc (currently 4.6.3, soon 4.7)?


--------------------
PM
^
AndrewSerk
 Posted: Mar 14 2012, 12:52 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 518
Member No.: 54
Joined: 14-April 11









Not that I know of. I am sure you know that SL focuses on stability and reliability over the newest numbered packages. Fedora is a better choice for the "cutting edge but sometimes bleeding" packages . rolleyes.gif

CODE
[Master@SpaceTimeCompressor ~]$ yum info gcc
Available Packages
Name        : gcc
Arch        : i686
Version     : 4.4.6
Release     : 3.el6
Size        : 8.2 M
Repo        : sl
Summary     : Various compilers (C, C++, Objective-C, Java, ...)
URL         : http://gcc.gnu.org
License     : GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions
Description : The gcc package contains the GNU Compiler Collection version 4.4.
           : You'll need this package in order to compile C code.

PM
^
wearetheborg
 Posted: Mar 14 2012, 03:29 AM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 352
Member No.: 18
Joined: 11-April 11









QUOTE (AndrewSerk @ Mar 13 2012, 07:52 PM)
Not that I know of. I am sure you know that SL focuses on stability and reliability over the newest numbered packages.  Fedora is a better choice for the "cutting edge but sometimes bleeding" packages .  rolleyes.gif

CODE
[Master@SpaceTimeCompressor ~]$ yum info gcc
Available Packages
Name        : gcc
Arch        : i686
Version     : 4.4.6
Release     : 3.el6
Size        : 8.2 M
Repo        : sl
Summary     : Various compilers (C, C++, Objective-C, Java, ...)
URL         : http://gcc.gnu.org
License     : GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions
Description : The gcc package contains the GNU Compiler Collection version 4.4.
           : You'll need this package in order to compile C code.



I know, the reason I'm asking is that the C++11 standard was just approved last year, and compilers are working on implementing it...I would like to be able to program in the new standard.

Is it difficult to compile and install gcc from source? Can I use the older SL gcc to compile gcc 4.6.3?


--------------------
PM
^
AndrewSerk
 Posted: Mar 14 2012, 03:56 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 518
Member No.: 54
Joined: 14-April 11









I don't think it would be easy meeting the deps. I just did a little test from a stock SL 6.2 i686 install :


CODE
Downloading gcc-4.7.0-20120308.tar.bz2
 % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                Dload  Upload   Total   Spent    Left  Speed
100 66.3M  100 66.3M    0     0  1170k      0  0:00:58  0:00:58 --:--:-- 1217k
error: Failed build dependencies:
binutils >= 2.20.51.0.2-12 is needed by gcc-4.7.0-0.19.fc17.i686
glibc-static is needed by gcc-4.7.0-0.19.fc17.i686
zlib-devel is needed by gcc-4.7.0-0.19.fc17.i686
dejagnu is needed by gcc-4.7.0-0.19.fc17.i686
bison is needed by gcc-4.7.0-0.19.fc17.i686
flex is needed by gcc-4.7.0-0.19.fc17.i686
texinfo is needed by gcc-4.7.0-0.19.fc17.i686
sharutils is needed by gcc-4.7.0-0.19.fc17.i686
systemtap-sdt-devel >= 1.3 is needed by gcc-4.7.0-0.19.fc17.i686
/usr/share/java/eclipse-ecj.jar is needed by gcc-4.7.0-0.19.fc17.i686
gcc-java is needed by gcc-4.7.0-0.19.fc17.i686
libgcj is needed by gcc-4.7.0-0.19.fc17.i686
elfutils-devel >= 0.147 is needed by gcc-4.7.0-0.19.fc17.i686
elfutils-libelf-devel >= 0.147 is needed by gcc-4.7.0-0.19.fc17.i686
gcc-gnat >= 3.1 is needed by gcc-4.7.0-0.19.fc17.i686
libgnat >= 3.1 is needed by gcc-4.7.0-0.19.fc17.i686
ppl >= 0.11.2 is needed by gcc-4.7.0-0.19.fc17.i686
ppl-devel >= 0.11.2 is needed by gcc-4.7.0-0.19.fc17.i686
cloog-ppl-devel >= 0.15 is needed by gcc-4.7.0-0.19.fc17.i686
doxygen >= 1.7.1 is needed by gcc-4.7.0-0.19.fc17.i686
graphviz is needed by gcc-4.7.0-0.19.fc17.i686
gmp-devel >= 4.1.2-8 is needed by gcc-4.7.0-0.19.fc17.i686
mpfr-devel >= 2.2.1 is needed by gcc-4.7.0-0.19.fc17.i686
libmpc-devel >= 0.8.1 is needed by gcc-4.7.0-0.19.fc17.i686
gtk2-devel >= 2.4.0 is needed by gcc-4.7.0-0.19.fc17.i686
glib2-devel >= 2.4.0 is needed by gcc-4.7.0-0.19.fc17.i686
libart_lgpl-devel >= 2.1.0 is needed by gcc-4.7.0-0.19.fc17.i686
libXtst-devel is needed by gcc-4.7.0-0.19.fc17.i686
Could not execute local: Non zero exit
PM
^
redman
 Posted: Mar 14 2012, 06:58 AM
Quote Post


SLF Admin
********

Group: Admins
Posts: 1572
Member No.: 2
Joined: 8-April 11









GCC is an important package with several dependencies (as Andrew pointed out). If you REALLY need GCC 4.7 you might want to consider using the latest version of Fedora (either on a seperate system or on a virtual machine) since SL6 isn't intended as a system with "bleeding edge" software.


--------------------
What is SL? - Forum Rules - Info on 3rd Party Repos

Desktop: ASUS P5QPL-AM, Intel Dual-Core E6500, 4GB DDR2, ASUS GeForce GT 430 1GB, SL6.5 x86_64
Laptop: ASUS X58L, Intel Dual-Core T3200, 3GB DDR2, Intel GMA X3100, RHEL6.5 x86_64
Test box: Intel S5000PSL, 2x Intel Xeon E5310, 8GB ECC DDR2 FB-DIMM, ASUS GeForce GT 220 1GB, SL6.5 x86_64
PM
^
wearetheborg
 Posted: Mar 14 2012, 06:48 PM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 352
Member No.: 18
Joined: 11-April 11









Thanks Redman and AndrewSerk for the research.

I think I will use a virtual machine for gcc. It is the only bleeding edge software that I need to be bleeding edge.


--------------------
PM
^
Tom
 Posted: Mar 29 2012, 11:13 AM
Quote Post


SLF Newbie


Group: Members
Posts: 1
Member No.: 1414
Joined: 29-March 12









QUOTE (wearetheborg @ Mar 14 2012, 06:48 PM)
Thanks Redman and AndrewSerk for the research.

I think I will use a virtual machine for gcc. It is the only bleeding edge software that I need to be bleeding edge.



Hi,

yesterday I compiled GCC 4.7 without problems. My system is SL 6.1 (x86_64)

Just read the instructions on gcc.gnu.org (in the right corner).
Everything you need (required packages) is described. Because I installed SL as a Software Development Workstation, I only had to add 3 packages.

The only confusing/ambigous thing in the instructions is that you should NOT compile within objdir.

I created a directory "temp"; within temp I uncompressed GCC, which creates a folder "gcc-4.7.0".

Now DON´T cd into "gcc-4.7.0", just stay in "temp" and enter "gcc-4.7.0/configure" !

After "make" and "make install" it copies everything AND installs v4.7 as the DEFAULT compiler.

I run the testsuite (It took half a night) and about 99% was successful.

It would of course be fantastic to always have the latest GCC as a native package from SL (and not Fedora etc.).

Hope this helps,
Tom
PM
^
wearetheborg
 Posted: Apr 3 2012, 10:44 PM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 352
Member No.: 18
Joined: 11-April 11









QUOTE (Tom @ Mar 29 2012, 06:13 AM)

yesterday I compiled GCC 4.7 without problems. My system is SL 6.1 (x86_64)

Just read the instructions on gcc.gnu.org (in the right corner).
Everything you need (required packages) is described. Because I installed SL as a Software Development Workstation, I only had to add 3 packages.

The only confusing/ambigous thing in the instructions is that you should NOT compile within objdir.

I created a directory "temp"; within temp I uncompressed GCC, which creates a folder "gcc-4.7.0".

Now DON´T cd into "gcc-4.7.0", just stay in "temp"  and enter "gcc-4.7.0/configure" !

After "make" and "make install" it copies everything AND installs v4.7 as the DEFAULT compiler.

I run the testsuite (It took half a night) and about 99% was successful.

It would of course be fantastic to always have the latest GCC as a native package from SL (and not Fedora etc.).

Hope this helps,
Tom


Thanks Tom, that helps a lot and thank you again for the great news!

BTW, why cant you cd into the directory and configure from there?
I assume configure has a prefix= option so that I can install gcc into my local home directory and not require root privileges?


--------------------
PM
^
zxq9
 Posted: Apr 4 2012, 02:36 PM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 376
Member No.: 611
Joined: 5-August 11









On a related note, I am considering packaging a few languages and utilities more current than the standard SL/TUV batch, including:

Python 3 (whatever version its at when I do it... 3.3 or 3.4)
Guile 2 (v2.0.5) - the Scheme interpreter for everything
gcl v2.6.7 - Common Lisp over gcc
gcc 4.7.0
gdc or gcd or whatever the D compiler over gcc winds up being called (if it actually winds up getting pushed, that is)

gcc is being a strong "maybe" as I may not hop on it unless its really needed by the other packages, and of course the status of D is totally up in the air because, well, its D. I know C++ Version Uber just came out of standardization (well, sort of, almost there anyway) and its got garbage collection (O.o) but I just don't spend much time in C++ these days, much more in lisp and Python and so these packages are important to me.

My scheme (haha, just noticed that's a pun) is to install them with calling names that do not conflict with the system standard, similar to how Python3 is handled in Fedora (where you explicitely call or hashbang "python3" or "/usr/bin/python3" to get that version, where plain old "python" gives you 2.6 or 2.7). Hopefully this will alleviate some of the Python3/Guile2/total-lack-of-gcl issues. If the gcc thing works out, then that would be cool -- though gcc is definitely a lower priority until the big libraries like boost and Qt start requiring them.

Oh, also, I'm almost back in action on the forums.
PMEmail PosterUsers Website
^
wearetheborg
 Posted: Apr 4 2012, 05:08 PM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 352
Member No.: 18
Joined: 11-April 11









QUOTE (zxq9 @ Apr 4 2012, 09:36 AM)
I know C++ Version Uber just came out of standardization (well, sort of, almost there anyway)


It was standardized almost a year go (8 months to be exact).


I was able to compile MIT-scheme without any hassle on my ubuntu box


--------------------
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll