scientificlinuxforum.org QR code
Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> SL6.0 slapd upgrade woes
zzxtty
 Posted: Feb 24 2012, 11:03 AM
Quote Post


SLF Newbie


Group: Members
Posts: 7
Member No.: 322
Joined: 21-June 11









Our two ldap servers automatically upgraded the openldap packages last night and slapd fell flat on it's face. After some poking around I found slapd reporting this error:

Program version 4.7 doesn't match environment version 4.8

This is a version missmatch on the bdb backend database. I ran a yum downgrade:

yum downgrade openldap-clients openldap-servers openldap

And was able to get the server running again.

Here is what was upgraded:

Feb 24 05:59:32 Updated: glibc-common-2.12-1.47.el6_2.5.x86_64
Feb 24 05:59:36 Updated: glibc-2.12-1.47.el6_2.5.x86_64
Feb 24 05:59:36 Updated: openldap-2.4.23-15.el6.x86_64
Feb 24 05:59:36 Updated: openssl-1.0.0-20.el6_2.1.x86_64
Feb 24 05:59:37 Updated: libcurl-7.19.7-26.el6_1.2.x86_64
Feb 24 05:59:37 Updated: cracklib-2.8.16-4.el6.x86_64
Feb 24 05:59:37 Updated: glibc-headers-2.12-1.47.el6_2.5.x86_64
Feb 24 05:59:38 Updated: selinux-policy-3.7.19-126.el6_2.6.noarch
Feb 24 06:00:04 Updated: selinux-policy-targeted-3.7.19-126.el6_2.6.noarch
Feb 24 06:00:04 Updated: glibc-devel-2.12-1.47.el6_2.5.x86_64
Feb 24 06:00:05 Updated: cracklib-dicts-2.8.16-4.el6.x86_64
Feb 24 06:00:05 Updated: curl-7.19.7-26.el6_1.2.x86_64
Feb 24 06:00:05 Updated: mysql-libs-5.1.61-1.el6_2.1.x86_64
Feb 24 06:00:05 Updated: openssl-perl-1.0.0-20.el6_2.1.x86_64
Feb 24 06:00:08 Updated: openldap-servers-2.4.23-15.el6.x86_64
Feb 24 06:00:09 Updated: openldap-clients-2.4.23-15.el6.x86_64
Feb 24 06:00:09 Updated: libxml2-2.7.6-4.el6_2.1.x86_64

When i first spotted the problem I did a "yum upgrade" and reboot:
Feb 24 09:27:13 Updated: kernel-firmware-2.6.32-220.4.1.el6.noarch
Feb 24 09:27:20 Installed: kernel-2.6.32-220.4.1.el6.x86_64
Feb 24 09:27:29 Installed: kernel-devel-2.6.32-220.4.1.el6.x86_64
Feb 24 09:27:30 Updated: kernel-headers-2.6.32-220.4.1.el6.x86_64

This is the backout:
Feb 24 10:21:12 Installed: openldap-2.4.19-15.el6_0.2.x86_64
Feb 24 10:21:15 Installed: openldap-servers-2.4.19-15.el6_0.2.x86_64
Feb 24 10:21:15 Installed: openldap-clients-2.4.19-15.el6_0.2.x86_64

It looks like the older version of openldap-servers was using a newer verison of the db library, however the only version of db installed is db4 4.7.25, and that was never upgraded.
PMEmail Poster
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll