Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Vlc 1.1.13 audio no good
U308
 Posted: Jan 29 2012, 10:22 AM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 484
Member No.: 32
Joined: 11-April 11









Today after having installed several updates including latest kernel and vlc 1.1.13 (from repoforge), I noticed that this version of vlc has serious audio problems.
Has anyone also noticed this ? (64 bit OS).
I see that vlc 2.0 rc1 is out http://www.ghacks.net/2012/01/18/get-ready-for-vlc-media-player-2-0/
PM
^
U308
 Posted: Feb 3 2012, 11:32 AM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 484
Member No.: 32
Joined: 11-April 11









Strange, after I reinstalled libvdpau, which vlc 1.1.13 pulled in during install, the audio problem is now gone, but starting vlc from terminal I still get the same output as shown below.

VLC media player 1.1.13 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x222a120] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Blocked: call to setlocale(6, "")
Warning: call to srand(1328353344)
Warning: call to rand()
Blocked: call to setlocale(6, "")

(process:2887): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
Blocked: call to setlocale(6, "")
Warning: call to rand()
Warning: call to rand()
Warning: call to rand()
Warning: call to rand()

Of course I don't know why a reinstall of libvdpau would 'fix' the audio. BTW this is the first
time I have had trouble with vlc and also the first time libvdpau was drawn in as a dependency ??
PM
^
AndrewSerk
 Posted: Feb 3 2012, 07:07 PM
Quote Post


SLF Moderator
*****

Group: Moderators
Posts: 480
Member No.: 54
Joined: 14-April 11









Hi U308,

Thank you for posting your findings as I am sure people will find the info useful.

Andrew

This post has been edited by AndrewSerk: Feb 3 2012, 07:08 PM
PM
^
U308
 Posted: Feb 11 2012, 01:54 PM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 484
Member No.: 32
Joined: 11-April 11









Unfortunately the audio problem is back. I decided to downgrade vlc to version 1.1.11 which has no problems. As 1.1.13 was a security update, http://www.h-online.com/security/news/item/VLC-Media-Player-1-1-13-fixes-security-vulnerability-1399831.html
I deleted the two libty_ files from the vlc plugin folder as advised.
PM
^
synflag
 Posted: Feb 11 2012, 09:17 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 21
Member No.: 1281
Joined: 11-February 12









The sound bug, is related with pulseaudio, adding tsched=0 in /etc/pulse/default.pa is solved, but affect other thing in the system. The bug is with HDA intel cards. I asked in bugzilla and lennart (creator of pulseaudio), answered me, that alsa clock for intel HDA is bugged and is crappy, so, pulseaudio use timer, but if the timer in alsa is bugged (and it is), the bug is not pulseaudio, the bug is ALSA, and workaround is tsched=0 for pulseadio.
I test in older PC with a VIA souncard and the bug is no present.

Reference: http://fedorasolved.org/Members/fenris02/pulseaudio-fixes-and-workarounds

su -c "nano -w /etc/pulse/default.pa"
load-module module-udev-detect tsched=0


--------------------
AMD Phenom x4 945 3.0Ghz - 8Gb Ram DDR3-1600 GSKILL RIPJAWS - 2 HDD 500GB WD SATAII - Thermaltake Toughpower 700 - Thermaltake V9 Black - LG LED 19" // Windows 7 Ultimate x86_64 (for games only), Fedora 16 x86_64
-------------------------------------------------------------------------------------------------------------------------------
Lenovo Thinkpad T400 Intel P8600 - 500GB SATAII - 4GB DDR3-1066 // SL6.2, Windows 7 Ultimate x86_64 (games and security test)
PMUsers Website
^
U308
 Posted: Feb 12 2012, 08:08 AM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 484
Member No.: 32
Joined: 11-April 11









QUOTE (synflag @ Feb 11 2012, 11:17 PM)
The sound bug, is related with pulseaudio, adding tsched=0 in /etc/pulse/default.pa is solved, but affect other thing in the system. The bug is with HDA intel cards. I asked in bugzilla and lennart (creator of pulseaudio), answered me, that alsa clock for intel HDA is bugged and is crappy, so, pulseaudio use timer, but if the timer in alsa is bugged (and it is), the bug is not pulseaudio, the bug is ALSA, and workaround is tsched=0 for pulseadio.
I test in older PC with a VIA soundard and the bug is no present.


Thank you very much synflag, I will check later. I have Intel HDA.
PM
^
U308
 Posted: Feb 12 2012, 12:25 PM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 484
Member No.: 32
Joined: 11-April 11









QUOTE (synflag @ Feb 11 2012, 11:17 PM)
The sound bug, is related with pulseaudio, adding tsched=0 in /etc/pulse/default.pa is solved, but affect other thing in the system. The bug is with HDA intel cards. I asked in bugzilla and lennart (creator of pulseaudio), answered me, that alsa clock for intel HDA is bugged and is crappy, so, pulseaudio use timer, but if the timer in alsa is bugged (and it is), the bug is not pulseaudio, the bug is ALSA, and workaround is tsched=0 for pulseadio.
I test in older PC with a VIA souncard and the bug is no present.

Reference: http://fedorasolved.org/Members/fenris02/pulseaudio-fixes-and-workarounds

su -c "nano -w /etc/pulse/default.pa"
load-module module-udev-detect tsched=0


Hah, looks like it's fixed. Had to reboot. Thanks again for your help - much appreciated.

PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll