Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> could not start startkde at remote server
yellowhat
 Posted: Jan 17 2012, 04:33 AM
Quote Post


SLF Member
***

Group: Members
Posts: 76
Member No.: 707
Joined: 18-August 11









My box is scienific linux 6.1 x86, and remote server is centos 5.1 x86.

I connected with remote server through ssh, and execute "startkde", then I got these messages.


QUOTE
[remote-server@remote-server ~]$ startkde
xsetroot:  unable to open display ''
xset:  unable to open display ""
xset:  unable to open display ""
xsetroot:  unable to open display ''
startkde: Starting up...
ksplash: cannot connect to X server
kdeinit: Aborting. $DISPLAY is not set.
Warning: connect() failed: : No such file or directory
ksmserver: cannot connect to X server
ERROR: Couldn't attach to DCOP server!
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
startkde: Done.


Please let me know how to resolve this problem.

Thanks in advance.
PM
^
AndrewSerk
 Posted: Jan 19 2012, 04:54 PM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 518
Member No.: 54
Joined: 14-April 11









Hello Yellowhat,
I believe you have to startx first then startkde with a command like:

CODE
startx /usr/bin/startkde


Hope this helps
PM
^
joutlan
 Posted: Jan 20 2012, 02:27 AM
Quote Post


SLF Founder
********

Group: Admins
Posts: 1109
Member No.: 1
Joined: 8-April 11









QUOTE (AndrewSerk @ Jan 19 2012, 12:54 PM)
Hello Yellowhat,
I believe you have to startx first then startkde with a command like:

CODE
startx /usr/bin/startkde


Hope this helps


That looks right to me also. Long live Konqui !! laugh.gif


--------------------
DΞLL Precision M6700: 17 inch NB//i7-quad w/USB 3.0, 16.0GB, Quadro K5000M 2.0GB DDR3, RGBLED //W8P64/Scientific Linux 6.4 x64
DΞLL Vostro 3350 Nirvana: 13 inch NB w/ IntelSSD// W8Px64 (Work;Games)
Nexus 4 //Android
PMEmail PosterUsers WebsiteIntegrity Messenger IM
^
yellowhat
 Posted: Jan 27 2012, 07:52 AM
Quote Post


SLF Member
***

Group: Members
Posts: 76
Member No.: 707
Joined: 18-August 11









QUOTE (AndrewSerk @ Jan 20 2012, 01:54 AM)
Hello Yellowhat,
I believe you have to startx first then startkde with a command like:

CODE
startx /usr/bin/startkde


Hope this helps


I got this error message.


QUOTE
[root@remote-server X11]# startX
-bash: startX: command not found
[root@remote-server X11]# startx
xauth:  creating new authority file /root/.serverauth.19813


X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.el5 i686 Red Hat, Inc.
Current Operating System: Linux remote-server 2.6.18-238.12.1.el5 #1 SMP Tue May 31 13:23:01 EDT 2011 i686
Build Date: 20 April 2011
Build ID: xorg-x11-server 1.1.1-48.76.el5_6.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 27 16:51:28 2012
(==) Using config file: "/etc/X11/xorg.conf"
(WW) ATI(0): Failed to set up write-combining range (0xf6000000,0x800000)
(WW) ATI(0): Failed to set up write-combining range (0xf6000000,0x800000)
FATAL: Module mach64 not found.
[drm] failed to load kernel module "mach64"
(EE) ATI(0): [dri] DRIScreenInit Failed
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Multiple symbols for level 1/group 1 on key <I5F>
>                  Using XF86Sleep, ignoring XF86Standby
> Warning:          Symbol map for key <I5F> redefined
>                  Using last definition for conflicting fields
Errors from xkbcomp are not fatal to the X server
localuser:root being added to access control list
There isn't profile of 'root'.
Smart Common Input Method 1.4.4

Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Starting SCIM as daemon ...
SCIM has been successfully launched.
SESSION_MANAGER=local/remote-server:/tmp/.ICE-unix/19851
Passkey agent registration failed: Passkey agent already exists

** (nm-applet:19951): WARNING **: <WARN>  applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service as it is already taken.  Return: 3


** (eggcups:19926): WARNING **: IPP request failed with status 1030

** (eggcups:19926): WARNING **: IPP request failed with status 1030
Initializing nautilus-open-terminal extension
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
PM
^
AndrewSerk
 Posted: Jan 28 2012, 12:52 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 518
Member No.: 54
Joined: 14-April 11









Hi yellowhat,

Just to clarify: Are you wanting to run the x session remotely, with the kde desktop on your monitor or just start kde on the remote server and remote server monitor?
PM
^
yellowhat
 Posted: Jan 28 2012, 03:57 AM
Quote Post


SLF Member
***

Group: Members
Posts: 76
Member No.: 707
Joined: 18-August 11









I want to to run the x session remotely, with the kde desktop on your monitor.
PM
^
AndrewSerk
 Posted: Jan 28 2012, 04:18 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 518
Member No.: 54
Joined: 14-April 11









QUOTE (yellowhat @ Jan 27 2012, 10:57 PM)
I want to to run the x session remotely, with the kde desktop on your monitor.


On my monitor?? dry.gif It sounds like you want/need Xnest " xorg-x11-server-Xnest". I just did this from SL 6.2 on a SL5.1 remote box.
CODE
$ ssh -Y sluser@192.168.xxx.xxx
Last login: Sat Jan 28 04:12:49 2012 from 192.168.xxx.xxx
[sluser@slinux ~]$su -c 'yum install kdebase xorg-x11-server-Xnest -y'
[sluser@slinux ~]$ rpm -q xorg-x11-server-Xnest
xorg-x11-server-Xnest-1.1.1-48.76.el5_7.5.i386
[sluser@slinux ~]$ startx /usr/bin/startkde -- /usr/bin/Xnest :3 &



And this gave me a window on my monitor, with a kde x session inside the window, from the remote server.

Is this what you needed?

This post has been edited by AndrewSerk: Jan 28 2012, 04:24 AM
PM
^
helikaon
 Posted: Jan 28 2012, 03:51 PM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 575
Member No.: 4
Joined: 8-April 11









QUOTE (yellowhat @ Jan 17 2012, 04:33 AM)
My box is scienific linux 6.1 x86, and remote server is centos 5.1 x86.

I connected with remote server through ssh, and execute "startkde", then I got these messages.
....how to resolve this problem.

Thanks in advance.


Hi yellow.
i have one important question, that i havent seen answered here (or i overlooked it, in this case, i'm sorry), anyway:

1. on your remote box, do you have there X server running? does the remote box (centos) boot to runlevel 5?

If i presume above Question is 'Yes' then follows another:

2. do you have there the VNC server running? you need VNC server running there and then you have to use SSH connection to tunnel the connection to VNC server, so the line is secure, you need to have SSH server on the CentOS configured to forward X connections


Also, if you would NOT want to run whole KDE, you e.g. just need to configure printer remotely and you want to do it by 'gui tool clicking', then use:
CODE

ssh -X user@server
after you connect, you'd run e.g.
system-config-printer


hope this helps

cheers,


--------------------
PMEmail Poster
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll