Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Marvell Yukon network chipset, For Asus Crosshair IV Formula mobo
teslastrike
 Posted: Dec 13 2011, 03:09 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 24
Member No.: 831
Joined: 12-September 11









I used to run CentOS 5, my network did not work right away when i installed that operationg system, so what i had to do is just download kmod-sk98lin package for RHEL5, install it, then enter manuall my network MAC address in the network settings, and it worked perfectly.


Now i installed SL6.1, for that i downloaded RHEL6 version of kmod-ak98lin package, installed it, entered again manually MAC address of my network card in network connection preferences, but...it did not work.

That is really strange. what could be the reason? any suggestions?

To give you more information, here is output of ifconfig -a command:
CODE

eth0      Link encap:Ethernet  HWaddr 20:CF:20:2B:02:32  
         BROADCAST MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
         Interrupt:51 Memory:fcdfc000-0

lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:20 errors:0 dropped:0 overruns:0 frame:0
         TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:1200 (1.1 KiB)  TX bytes:1200 (1.1 KiB)



First i tried with this package:
kmod-sk98lin-10.85.9.3-1.el6.elrepo.x86_64.rpm

It did not work, then i found a newer package:
kmod-sk98lin-10.88.3.3-1.el6.elrepo.x86_64.rpm

Did not work as well, aybe i need some different package or some other step to perform? Any ideas appreciated. thanks.
PM
^
helikaon
 Posted: Dec 13 2011, 07:14 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 617
Member No.: 4
Joined: 8-April 11









QUOTE (teslastrike @ Dec 13 2011, 03:09 AM)
I used to run CentOS 5, my network did not work right away when i installed that operationg system, so what i had to do is just download kmod-sk98lin package for RHEL5, install it, then enter manuall my network MAC address in the network settings, and it worked perfectly.


Now i installed SL6.1, for that i downloaded RHEL6 version of kmod-ak98lin package, installed it, entered again manually MAC address of my network card in network connection preferences, but...it did not work.

That is really strange. what could be the reason? any suggestions?

To give you more information, here is output of ifconfig -a command:
CODE

eth0      Link encap:Ethernet  HWaddr 20:CF:20:2B:02:32  
         BROADCAST MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
         Interrupt:51 Memory:fcdfc000-0

lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:20 errors:0 dropped:0 overruns:0 frame:0
         TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:1200 (1.1 KiB)  TX bytes:1200 (1.1 KiB)



First i tried with this package:
kmod-sk98lin-10.85.9.3-1.el6.elrepo.x86_64.rpm

It did not work, then i found a newer package:
kmod-sk98lin-10.88.3.3-1.el6.elrepo.x86_64.rpm

Did not work as well, aybe i need some different package or some other step to perform? Any ideas appreciated. thanks.


Hi there,
i dont think the driver being problem (at least looks like, since you have already the eth0 available)

But problem is, that the 'ifconfig' doesnt report your 'eth0' having IP address.

check file (you can post it here):

/etc/sysconfig/network-scripts/ifcfg-eth0

and there you should see either:
- dhcp
or
- static IP address (+gateway etc ...)
configured ....


check also

/etc/resolv.conf
if you have DNS server stated there (if not dhcp add stated) ...


cheers,



--------------------
PMEmail Poster
^
teslastrike
 Posted: Dec 13 2011, 07:44 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 24
Member No.: 831
Joined: 12-September 11









Hello, well there is no: /etc/sysconfig/network-scripts/ifcfg-eth0 file
and there is no: /etc/resolv.conf file

Just in case, here is content of /etc/sysconfig/network-scripts/ifcfg-lo file:
CODE

DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback


Any other thoughts?
PM
^
helikaon
 Posted: Dec 13 2011, 10:53 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 617
Member No.: 4
Joined: 8-April 11









Hi,
then create it, e.g. this one controlled by the dhcp:

# cat ifcfg-eth0
CODE


DEVICE=eth0
NM_CONTROLLED=yes
ONBOOT=yes
HWADDR=00:1e:37:23:4c:87
TYPE=Ethernet
BOOTPROTO=dhcp
DEFROUTE=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"
DNS1=192.168.0.1
USERCTL=no
PEERDNS=yes


ofc, change the HWADDR maching your adapter (you can see it in 'ifconfig' you posted)


this one e.g. of static:
CODE

DEVICE=eth0
TYPE=Ethernet
ONBOOT=yes
BOOTPROTO=none
IPADDR=192.168.0.100
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
DNS1=192.168.0.2
HWADDR=00:0F:22:71:0A:53
USERCTL=no


this is e.g. of /etc/resolv.conf:
CODE

search example.com
nameserver 192.168.0.5
nameserver 192.168.0.6


cheers,

This post has been edited by helikaon: Dec 13 2011, 10:56 AM


--------------------
PMEmail Poster
^
teslastrike
 Posted: Dec 13 2011, 03:19 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 24
Member No.: 831
Joined: 12-September 11









well i created those two files, for eth0 controlled by dhcp too, changed HWaddr, rebooted, nothing worked.

So as you said it now looks like driver installed just OK, its just a system for some reason cannot pick it up and use it?

Any other ideas where could be the reason?
PM
^
teslastrike
 Posted: Dec 13 2011, 04:18 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 24
Member No.: 831
Joined: 12-September 11









Just in case here are my outputs for the following commands, it might give some more info:

output of lspci | grep -i eth
CODE

03:00.0 Ethernet controller: Marvell Technology Group Ltd. Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB] (rev 11)


output of dmesg | grep -i eth
CODE
ACPI Error (psparse-0537): Method parse/execution failed [\] (Node ffffffff81f08530), AE_ALREADY_EXISTS
ACPI: Marking method \___ as Serialized because of AE_ALREADY_EXISTS error
ACPI Error (psparse-0537): Method parse/execution failed [\] (Node ffffffff81f08530), AE_NOT_FOUND
eth0: Generic Marvell Yukon chipset Ethernet device


well! now it seems that for eth0 the generic Marvell Yukon installed instead of the right one? could that be a problem or it does not matter?
PM
^
teslastrike
 Posted: Dec 13 2011, 04:56 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 24
Member No.: 831
Joined: 12-September 11









Ok i also tried to do the following: i downloaded driver installation pakcage from Marvell.com, i downloaded kernel source, and started the driver installation script which recompiled kernel and installed appropriate driver after removing a driver which was already installed, here is an output after running install.sh for sk98lin driver:

CODE

Disconnect alternative devices:  (done)                              [   OK   ]
Unload alternative driver (done)                                     [   OK   ]
Create tmp dir (/tmp/Sk98IfjVjIilFbOUNcHMMoeWR)                      [   OK   ]
Check user id (0)                                                    [   OK   ]
Check kernel version (2.6.32-131.0.15.el6.x86_64)                    [   OK   ]
Check kernel symbol file (/proc/kallsyms)                            [   OK   ]
Check kernel type (SMP)                                              [   OK   ]
Check number of CPUs (6)                                             [   OK   ]
Check architecture (found)                                           [   OK   ]
Set architecture (x86_64)                                            [   OK   ]
Check compiler (/usr/bin/gcc)                                        [   OK   ]
Check mcmodel flags (kernel)                                         [   OK   ]
Check module support (/sbin/insmod)                                  [   OK   ]
Check make (/usr/bin/make)                                           [   OK   ]
Check kernel gcc version (4.4.5) (Kernel:4.4.5 == gcc:4.4.5)         [   OK   ]
Check sk98lin driver availability (loaded)                           [   OK   ]
Disconnect devices: eth0  (done)                                     [   OK   ]
Remove driver (done)                                                 [   OK   ]
Check kernel header files (/lib/modules/2.6.32-131.0.15.el6.x86_64/so[   OK   ]
Check sources for .config file (/lib/modules/2.6.32-131.0.15.el6.x86_64/source/.config)                                                              [   OK   ]
Copy and check .config file (done)                                   [   OK   ]
Check the mem address space (lowmem)                                 [   OK   ]
Change IOMMU (enabled)                                               [   OK   ]
Create new .config file (done)                                       [   OK   ]
Execute: make oldconfig (done)                                       [   OK   ]
Check modpost availability (available)                               [   OK   ]
Unpack the sources (done)                                            [   OK   ]
Check firmware availability (done)                                   [   OK   ]
Check kernel header version (Kernel:2.6.32 == Header:2.6.32)         [   OK   ]
Check kernel functions (Changed: nothing)                            [   OK   ]
Compile the kernel (done)                                            [   OK   ]
Copy driver man page into /usr/share/man/man4/ (done)                [   OK   ]
Check the driver (done)                                              [   OK   ]
Create kernel modules driver directory (done)                        [   OK   ]
Delete old driver (done)                                             [   OK   ]
Copying driver (done)                                                [   OK   ]
Make dependency (done)                                               [   OK   ]
Delete temp directories (done)                                       [   OK   ]
All done. Driver installed and loaded.
To load the module manually, proceed as follows:
     Enter "modprobe sk98lin"

                                                    Have fun...


As you see everything went right, it even told me to have fun, with what i have problems.

I reboot..and nothing works again. So what could be the problem?

I'm afraid that i'll have to revert to my older distro if this thing is not going to work out, im not quite sure where else to look at?
PM
^
teslastrike
 Posted: Dec 13 2011, 05:59 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 24
Member No.: 831
Joined: 12-September 11









well ok, here is what else i had to do after successful installation of driver:

in terminal run system-config-network, and just configure it as dhcp and pretty much leave things as they are, then reboot, and then it worked!

Thank you! Im glad it worked out since i almost got working most of my important stuff for SL.
PM
^
northd_tech
 Posted: Dec 13 2011, 09:10 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 20
Member No.: 1098
Joined: 7-December 11









It might be good to note what driver or kernel modules that you have installed. Often/usually a kernel update wil 'break' wireless/networking and you might need to recompile modules and/or blacklist others after that.

This command should tell what modules are currently loaded:

CODE
lsmod


It might be worth keeping a record of the working configuration in case it quits in the future (I often put some comments in /etc/modules.d/blacklist.conf file where the blacklisting usually takes place). /etc/rc.d/rc.local should be where modules are loaded at boot time.
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll