Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Touchpad configuration
swirlythingy
 Posted: Oct 27 2011, 01:10 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 20
Member No.: 961
Joined: 23-October 11









Having solved my hibernate problem, can anyone help me with my somewhat less fatal but considerably more annoying problem with my Asus K52F's touchpad?

It's configured to perform a number of different mouse-related tasks, depending on gesture. Moving one finger moves the pointer. Tapping one finger does the equivalent of a left-click. Moving two fingers at once simulates a scroll wheel. Tapping two fingers simulates a middle-click.

My problem is that the technology seems insufficiently advanced to tell the difference between moving the pointer a short way and clicking! This is intensely irritating in a number of situations (and downright dangerous when I try to play Minesweeper), so is there any way of customising its behaviour?

The 'mouse preferences' window doesn't seem to have any touchpad-specific options, and the laptop's hardware manual is less than helpful, advising me that settings to change behaviour may be found beneath the Windows Control Panel. For preference, I want to change it to the following:

Turn off tap-to-generate-left-click altogether. I have a button for that.

Turn off double-tap-to-generate-middle-click too. I find it useful, but not useful enough to put up with Firefox discarding the current page and loading a new one from my history half the times I try to scroll the window.

Change the Microsoft 'menu' key on the keyboard to generate middle clicks instead of right clicks, as I have a right button but no middle button and I'll still want to use middle clicks occasionally.
PMEmail Poster
^
helikaon
 Posted: Oct 27 2011, 06:05 PM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 557
Member No.: 4
Joined: 8-April 11









QUOTE (swirlythingy @ Oct 27 2011, 01:10 PM)
Having solved my hibernate problem, can anyone help me with my somewhat less fatal but considerably more annoying problem with my Asus K52F's touchpad?

It's configured to perform a number of different mouse-related tasks, depending on gesture.  Moving one finger moves the pointer.  Tapping one finger does the equivalent of a left-click.  Moving two fingers at once simulates a scroll wheel.  Tapping two fingers simulates a middle-click.

My problem is that the technology seems insufficiently advanced to tell the difference between moving the pointer a short way and clicking!  This is intensely irritating in a number of situations (and downright dangerous when I try to play Minesweeper), so is there any way of customising its behaviour?

The 'mouse preferences' window doesn't seem to have any touchpad-specific options, and the laptop's hardware manual is less than helpful, advising me that settings to change behaviour may be found beneath the Windows Control Panel.  For preference, I want to change it to the following:

Turn off tap-to-generate-left-click altogether.  I have a button for that.

Turn off double-tap-to-generate-middle-click too.  I find it useful, but not useful enough to put up with Firefox discarding the current page and loading a new one from my history half the times I try to scroll the window.

Change the Microsoft 'menu' key on the keyboard to generate middle clicks instead of right clicks, as I have a right button but no middle button and I'll still want to use middle clicks occasionally.


1st:
Please read this article from here forums:

xmodmap remap mouse and keyboard keys

Basically, you need to disable the 'touchpad button' you need to find which number it is and then remap it to nonexisting number.
At least in theory, i dont use touchpad at all, but trackpoint...


2nd
way (more subtle):
if you have touchpad from synaptic, or compatible, you can use the:

xorg-x11-drv-synaptics-1.2.1-5.el6.x86_64 package (if not installed, install it)

and

/usr/bin/synclient -help
/usr/bin/synclient -l (list current setting for touchpad)
man synclient (read how to tune up the values for touchpad 'buttons')

NOTE:
if you make changes with the synclient and it works, then you need the synclient -l output save to xorg.conf file
since the xorg.conf is not created by default, you need to create it yourself (if you get to this point and dont know howto do it, ask) and put there input like this e.g:
CODE

Section "InputDevice"
    Driver      "synaptics"
    Identifier  "Mouse2"  #<------Note*
    Option      "Device"        "/dev/psaux"
    Option      "Protocol"      "auto-dev"
    Option      "LeftEdge"      "1900"
    Option      "RightEdge"     "5400"
    Option      "TopEdge"       "1900"
    Option      "BottomEdge"    "4000"
    Option      "FingerLow"     "25"
    Option      "FingerHigh"    "30"
    Option      "MaxTapTime"    "180"
    Option      "MaxTapMove"    "220"
    Option      "VertScrollDelta" "100"
    Option      "MinSpeed"       "0.02"
    Option      "MaxSpeed"       "0.18"
    Option      "AccelFactor"    "0.0010"
    Option      "SHMConfig"      "on"
    Option      "Repeater"       "/dev/ps2mouse"
EndSection



This all might seam not that easy (and it's not for beginner) but this is driver modification, which isn't easy anytime...

cheers,

This post has been edited by helikaon: Oct 27 2011, 07:01 PM


--------------------
PMEmail Poster
^
helikaon
 Posted: Oct 29 2011, 08:24 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 557
Member No.: 4
Joined: 8-April 11









Hi there,
any progress with your touchpad?

cheers,


--------------------
PMEmail Poster
^
swirlythingy
 Posted: Oct 31 2011, 10:37 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 20
Member No.: 961
Joined: 23-October 11









Sorry for delayed response - I got distracted and forgot to check the forums!
QUOTE (helikaon @ Oct 27 2011, 06:05 PM)
xmodmap remap mouse and keyboard keys

Basically, you need to disable the 'touchpad button' you need to find which number it is and then remap it to nonexisting number.

I investigated that, and I realised the list of numbers didn't mean much without knowing which ones which functions of my touchpad were producing.

Fortunately, I discovered xev elsewhere, and this informed me that tapping the pad and clicking the left button both produced code 1 - i.e. there was no way to distinguish between the two. Not a promising start!
QUOTE (helikaon @ Oct 27 2011, 06:05 PM)
/usr/bin/synclient -help
/usr/bin/synclient -l (list current setting for touchpad)

$ /usr/bin/synclient -l
Couldn't find synaptics properties. No synaptics driver loaded?

I'm wondering if it's the same problem as this one:

http://ubuntuforums.org/showthread.php?t=1333961

I too have no 'Touchpad' tab in the GNOME mouse configuration window, and my /proc/bus/input/devices contains the following suspiciously similar section, except for the fact that the S: and H: lines end in 6 rather than 9:

I: Bus=0011 Vendor=0002 Product=0005 Version=0063
N: Name="ImPS/2 Logitech Wheel Mouse"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input6
U: Uniq=
H: Handlers=mouse1 event6
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=103

Which leads me to this bug report:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/512192

Where the suggested solution appears to be a kernel patch!!

That's jumping in a bit deep even for me - isn't there any configuration file which can be changed to forcibly override the buggy autodetection? (Or, better still, can't SL fix this 18-month-old bug themselves?)
PMEmail Poster
^
helikaon
 Posted: Nov 2 2011, 06:26 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 557
Member No.: 4
Joined: 8-April 11









Hi there,
did you try the solution suggested on the forum you found and provided link to?

I mean did you try to disable the unwanted feature via the 'xinput' command. This sounds like a possible solution...
CODE

xinput list
xinput list-props (id of the touchpad)
xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" 97 8 0 (to disable it - only change the 97 for the ID you find out ...)




cheers,


--------------------
PMEmail Poster
^
helikaon
 Posted: Nov 2 2011, 06:47 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 557
Member No.: 4
Joined: 8-April 11









Hi,
and another solution (possible) found on redhat bugzilla, where they recommend to add "psmouse.force_elantech=1"
to the kernel command line by editing the "/boot/grub/grub.conf "

The grub menu entries look like this:
title Fedora (2.6.34.3-37.fc13.x86_64)
root (hd0,0)
kernel /vmlinuz-2.6.34.3-37.fc13.x86_64 psmouse.force_elantech=1
initrd /initramfs-2.6.34.3-37.fc13.x86_64.img


It's for Fedora, but it could work for you too. It basically force kernel to load the elantech touchpad driver instead of the ps/2 mouse and as such the OS will properly recognize the device as 'touchpad' and use the synaptic driver for it, which you can configure, as i showed in one of my previous post ...

the link i looked at:
red hat bugzilla elantech touchpad

cheers,

This post has been edited by helikaon: Nov 2 2011, 06:48 AM


--------------------
PMEmail Poster
^
swirlythingy
 Posted: Nov 3 2011, 12:25 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 20
Member No.: 961
Joined: 23-October 11









QUOTE (helikaon @ Nov 2 2011, 06:26 AM)
did you try the solution suggested on the forum you found and provided link to?

I mean did you try to disable the unwanted feature via the 'xinput' command.

The forum was very clear that this would only work above a certain version of Ubuntu. I have no idea how SL version numbers map onto Ubuntu ones, but apparently this is another respect in which SL is far behind:
CODE
xinput
bash: xinput: command not found

As for the force_elantech fix, this too apparently relies on having a certain version of Fedora, although as Fedora is a closer relative than Ubuntu it sounds more hopeful. I'm going to try entering it at the boot menu as suggested (just in case it doesn't work!). Back in a tick...
PMEmail Poster
^
swirlythingy
 Posted: Nov 3 2011, 12:42 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 20
Member No.: 961
Joined: 23-October 11









QUOTE (swirlythingy @ Nov 3 2011, 12:25 AM)
As for the force_elantech fix, this too apparently relies on having a certain version of Fedora, although as Fedora is a closer relative than Ubuntu it sounds more hopeful.  I'm going to try entering it at the boot menu as suggested (just in case it doesn't work!).  Back in a tick...

Bugger! It didn't! http://dl.dropbox.com/u/2835777/BangHead1.gif

A look at grub.conf (which I probably should have done first) tells me why: my kernel version is 2.6.32, and the RedHat Bugzilla says the necessary kernel patch was applied in 2.6.34 (and 2.6.35 is necessary to get it to work without using force_elantech).

I'm running the latest (6.1) version of Scientific Linux available. Any more ideas? Is it possible to upgrade one's kernel outside of the official SL update scheme?
PMEmail Poster
^
helikaon
 Posted: Nov 3 2011, 03:10 AM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 557
Member No.: 4
Joined: 8-April 11









QUOTE (swirlythingy @ Nov 3 2011, 12:25 AM)
QUOTE (helikaon @ Nov 2 2011, 06:26 AM)
did you try the solution suggested on the forum you found and provided link to?

I mean did you try to disable the unwanted feature via the 'xinput' command.

The forum was very clear that this would only work above a certain version of Ubuntu. I have no idea how SL version numbers map onto Ubuntu ones, but apparently this is another respect in which SL is far behind:
CODE
xinput
bash: xinput: command not found

As for the force_elantech fix, this too apparently relies on having a certain version of Fedora, although as Fedora is a closer relative than Ubuntu it sounds more hopeful. I'm going to try entering it at the boot menu as suggested (just in case it doesn't work!). Back in a tick...



Hi,
try to install xinput:

CODE

[lang@sol install]$ yum whatprovides */xinput
                                                                                           
xorg-x11-apps-7.4-10.el6.x86_64 : X.Org X11 applications
Repo        : sl
Matched from:
Filename    : /usr/bin/xinput


yum install xorg-x11-apps-7.4-10.el6.x86_64



and try the xinput approach ...

cheers,



--------------------
PMEmail Poster
^
swirlythingy
 Posted: Nov 3 2011, 10:49 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 20
Member No.: 961
Joined: 23-October 11









QUOTE (helikaon @ Nov 3 2011, 03:10 AM)
and try the xinput approach ...

But that just disables the touchpad altogether. Why would I want to do that? I can't take an external mouse on the train!

I'm sorry, but there really is no way around this: it's a kernel bug, and it's been fixed in a more recent version of the kernel than mine. How can I upgrade to 2.6.35?
PMEmail Poster
^
helikaon
 Posted: Nov 3 2011, 04:36 PM
Quote Post


SLF Moderator
******

Group: Moderators
Posts: 557
Member No.: 4
Joined: 8-April 11









Hi,
i just had thought, we could try to configure it as the 'mouse' device via xinput, xset etc, where is possible to set up mouse speed, speed of click etc.
I understand you frustration, i've been stuck in few myself.
Anyway, if you want to try newer kernel, feel free to have a look in the 'kernel' section in here forums.
compile vanilla kernel to SL 6

have luck

This post has been edited by helikaon: Nov 3 2011, 04:53 PM


--------------------
PMEmail Poster
^
swirlythingy
 Posted: Nov 4 2011, 09:15 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 20
Member No.: 961
Joined: 23-October 11









QUOTE (helikaon @ Nov 3 2011, 04:36 PM)
compile vanilla kernel to SL 6

Eek! So there's no easy upgrade path, then. I don't think I'm quite ready for that kind of thing... do you know if there are any plans to change kernel in a future official SL release? (I mean, presumably it hasn't been 2.6.32 from day one?)

Thanks for trying, anyway. I think, in the meantime, I'm going to have to live with it.
PMEmail Poster
^
swirlythingy
 Posted: Feb 19 2012, 07:26 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 20
Member No.: 961
Joined: 23-October 11









After months and months, I've finally got my hands on the unofficial 2.6.39 kernel update for EL6, and my touchpad is now detected properly! http://th166.photobucket.com/albums/u117/rdshear/Smiley%20Faces/th_smiley-face-thumbs-up.gif

Which brings me back to the reason I originally started this thread - reconfiguring it...

How can I get the touchpad to distinguish between taps on the pad and clicks on the buttons? GNOME only has an "Enable mouse clicks with touchpad" option. Testing with xev, this has the effect that clicking the left button produces code 1, tapping with one finger also produces code 1, clicking the right button produces code 3, and tapping with two fingers also produces code 3. In other words, I now have absolutely no middle button (code 2) at all!

The original state of affairs was slightly preferable to that! Previously, tapping the pad with one finger and clicking the left button both produced 1, clicking the right button produced 3, and tapping with two fingers produced 2. How can I go back to that?

As a temporary workaround, I've used xmodmap to switch buttons 2 and 3, meaning I can still use the menu key as a button 3 equivalent, but surely there must be a proper way?
PMEmail Poster
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll