scientificlinuxforum.org QR code
Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> VLC 2.0 is out!
Zugzwang
 Posted: Feb 20 2012, 11:41 PM
Quote Post


SLF Junior
**

Group: Members
Posts: 32
Member No.: 863
Joined: 23-September 11









VLC 2.0, nicknamed "Twoflower" is out! The best multimedia player just got better smile.gif

Any idea on whether it will be available via RPMForge repo? Or is it better to compile from sources?
PMEmail Poster
^
tux99
 Posted: Feb 21 2012, 01:52 AM
Quote Post


SLF Guru
********

Group: Members
Posts: 1253
Member No.: 224
Joined: 28-May 11









It doesn't look good:

CODE
[packager@SL6-64bit vlc-2.0.0]$ ./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
[...]
checking X11/Xlib.h usability... yes
checking X11/Xlib.h presence... yes
checking for X11/Xlib.h... yes
checking for XCB... no
configure: error: Package requirements (xcb >= 1.6) were not met:

Requested 'xcb >= 1.6' but version of XCB is 1.5


It looks like the version of libxcb included in SL6 is too old for vlc 2.0 sad.gif

Edit: actually I spoke to soon, there is a "--disable-xcb" configure switch! smile.gif

Edit2: Yep, after disabling xcb it builds fine on SL6.2 x64.

If I find the time I make a package for it tomorrow.


--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories)
PM
^
joutlan
 Posted: Feb 21 2012, 02:41 AM
Quote Post


SLF Founder
********

Group: Admins
Posts: 1180
Member No.: 1
Joined: 8-April 11









Nice Tux! biggrin.gif


--------------------
DΞLL Precision M6700: 17 inch NB//i7-quad w/USB 3.0, 16.0GB, Quadro K5000M 2.0GB DDR3, RGBLED //W8P64/Scientific Linux 6.4 x64
DΞLL Vostro 3350 Nirvana: 13 inch NB w/ IntelSSD// W8Px64 (Work;Games)
Nexus 4 //Android
PMEmail PosterUsers WebsiteIntegrity Messenger IM
^
tux99
 Posted: Feb 21 2012, 02:49 AM
Quote Post


SLF Guru
********

Group: Members
Posts: 1253
Member No.: 224
Joined: 28-May 11









Actually after further investigation I found that libxcb is pretty crucial for video output under X, so I'm not sure how usable a build with xcb disabled would be... I will have to look further into this, but now it's bed time for me.


--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories)
PM
^
tux99
 Posted: Feb 21 2012, 11:14 AM
Quote Post


SLF Guru
********

Group: Members
Posts: 1253
Member No.: 224
Joined: 28-May 11









QUOTE (tux99 @ Feb 21 2012, 02:52 AM)
It looks like the version of libxcb included in SL6 is too old for vlc 2.0  sad.gif

If I find the time I make a package for it tomorrow.


Sorry, due to the libxcb version requirement a vlc 2.0 package for SL6 is not as straightforward as I initially thought. I think it should still be doable by including xcb 1.6 statically in vlc, but I don't have enough time to experiment with this today (or anytime soon). sad.gif
Maybe someone else wants to try this?


--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories)
PM
^
U308
 Posted: Feb 21 2012, 01:38 PM
Quote Post


SLF Expert
******

Group: Members
Posts: 508
Member No.: 32
Joined: 11-April 11









Quite a few are not particularly pleased with the sound as per this forum post:-
http://www.wilderssecurity.com/showthread.php?t=318560
So, no tearing rush to have 2.0
Maybe in time repoforge will provide.

Have you tried Umplayer ? http://www.umplayer.com/
It's rather nice. To fix the YouTube issue (to play YT vids) one would need the 0.97 version, as mentioned below.

Are you in the mood, or have some time to package that one for us ? I have the 0.95 version running nicely on SL6.2.

QUOTE
just compiled from the svn in Ubuntu and Fedora. It is a newer version (0.97) and youtube works in both cases. Down load the source with the command here http://www.umplayer.com/download/#source

The instruction is in install.txt.

For generic compile you need only install the qt4 developmental files (read  install.txt) If you encounter any problem try search the smplayer forum, the installation script appears to be totally from smplayer.

PM
^
tux99
 Posted: Feb 21 2012, 03:00 PM
Quote Post


SLF Guru
********

Group: Members
Posts: 1253
Member No.: 224
Joined: 28-May 11









QUOTE (U308 @ Feb 21 2012, 02:38 PM)

Have you tried Umplayer ? http://www.umplayer.com/
It's rather nice. To fix the YouTube issue (to play YT vids) one would need the 0.97 version, as mentioned below.

Are you in the mood, or have some time to package that one for us ? I have the 0.95 version running nicely on SL6.2.


No, I haven't tried Umplayer, isn't it just a front-end for mplayer?

TBH I don't think I have the time to package up Umplayer any time soon, I was thinking of doing vlc 2.0 only because it seemed straight-forward until I found the issue with libxcb.
Isn't watching Youtube videos preferable in a browser? I have never had any need or desire to watch them outside a browser.


--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories)
PM
^
U308
 Posted: Feb 21 2012, 03:32 PM
Quote Post


SLF Expert
******

Group: Members
Posts: 508
Member No.: 32
Joined: 11-April 11









QUOTE (tux99 @ Feb 21 2012, 05:00 PM)
QUOTE (U308 @ Feb 21 2012, 02:38 PM)

Have you tried Umplayer ? http://www.umplayer.com/
It's rather nice. To fix the YouTube issue (to play YT vids) one would need the 0.97 version, as mentioned below.

Are you in the mood, or have some time to package that one for us ? I have the 0.95 version running nicely on SL6.2.


No, I haven't tried Umplayer, isn't it just a front-end for mplayer?

TBH I don't think I have the time to package up Umplayer any time soon, I was thinking of doing vlc 2.0 only because it seemed straight-forward until I found the issue with libxcb.
Isn't watching Youtube videos preferable in a browser? I have never had any need or desire to watch them outside a browser.

Yup, it is a frontend for mplayer, one can record YT and shoutcast. I prefer vlc, but thought I would mention it as an alternative. I love vlc, especially for its ripping/transcoding feature; always a toss-up between Handbrake and vlc for me in that regard.
Anyway you could just download and install the version 0.95 and see whether it says hello to you. wink.gif
PM
^
tux99
 Posted: Feb 23 2012, 06:36 AM
Quote Post


SLF Guru
********

Group: Members
Posts: 1253
Member No.: 224
Joined: 28-May 11









I'm pleased to announce that I have managed to create a working VLC 2.0.0 package for SL/RHEL/Centos 6.2. I still have to tidy it up a bit more and add a few missing optional dependencies, but the hard part (the libxcb problem) is solved and working fine.

Expect a further announcement in the next few days when I upload the package to the repo.


--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories)
PM
^
joutlan
 Posted: Feb 23 2012, 06:43 AM
Quote Post


SLF Founder
********

Group: Admins
Posts: 1180
Member No.: 1
Joined: 8-April 11









QUOTE (tux99 @ Feb 23 2012, 02:36 AM)
I'm pleased to announce that I have managed to create a working VLC 2.0.0 package for SL/RHEL/Centos 6.2. I still have to tidy it up a bit more and add a few missing optional dependencies, but the hard part (the libxcb problem) is solved and working fine.

Expect a further announcement in the next few days when I upload the package to the repo.


I'm sure a few members and admins are pleased too! laugh.gif

Nice Tux!


--------------------
DΞLL Precision M6700: 17 inch NB//i7-quad w/USB 3.0, 16.0GB, Quadro K5000M 2.0GB DDR3, RGBLED //W8P64/Scientific Linux 6.4 x64
DΞLL Vostro 3350 Nirvana: 13 inch NB w/ IntelSSD// W8Px64 (Work;Games)
Nexus 4 //Android
PMEmail PosterUsers WebsiteIntegrity Messenger IM
^
tux99
 Posted: Feb 24 2012, 01:04 AM
Quote Post


SLF Guru
********

Group: Members
Posts: 1253
Member No.: 224
Joined: 28-May 11









I have started a separate thread in the appropriate subforum for my just released VLC 2.0.0 packages:
http://scientificlinuxforum.org/index.php?showtopic=1425


--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories)
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll