Printable Version of Topic
Click here to view this topic in its original format
Scientific Linux Forum.org > Installation and setup support > SL 7.3 after installaton glibc conflict


Posted by: crab Apr 21 2017, 06:17 AM
Hello,
I have installed SL7.3 (x86_64) successfully.
And then I was trying to install root data analysis software
and for dependencies I was trying to install libXft-devel.
During this installation using yum, I faced the following problem,
Please help me to resolve this issue !!!!!!!
=====================================================
QUOTE

# yum install libXft-devel.x86_64
Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package libXft-devel.x86_64 0:2.3.2-2.el7 will be installed
--> Processing Dependency: pkgconfig(fontconfig) for package: libXft-devel-2.3.2-2.el7.x86_64
--> Running transaction check
---> Package fontconfig-devel.x86_64 0:2.10.95-10.el7 will be installed
--> Processing Dependency: pkgconfig(expat) for package: fontconfig-devel-2.10.95-10.el7.x86_64
--> Running transaction check
---> Package expat-devel.x86_64 0:2.1.0-8.el7 will be installed
--> Processing Dependency: expat = 2.1.0-8.el7 for package: expat-devel-2.1.0-8.el7.x86_64
--> Running transaction check
---> Package expat.i686 0:2.1.0-8.el7 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: expat-2.1.0-8.el7.i686
--> Running transaction check
---> Package glibc.i686 0:2.17-157.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-157.el7 for package: glibc-2.17-157.el7.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-157.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-157.el7.i686
--> Running transaction check
---> Package glibc.i686 0:2.17-157.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-157.el7 for package: glibc-2.17-157.el7.i686
---> Package nss-softokn-freebl.i686 0:3.16.2.3-14.4.el7 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.17-157.el7.i686 (sl)
          Requires: glibc-common = 2.17-157.el7
          Installed: glibc-common-2.17-157.el7_3.1.x86_64 (@fastbugs/$releasever)
              glibc-common = 2.17-157.el7_3.1
          Available: glibc-common-2.17-157.el7.x86_64 (sl)
              glibc-common = 2.17-157.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

========================================================================

Thank you.

Posted by: helikaon Apr 25 2017, 08:56 AM

Hi,
the problem seams to be this:

CODE

---> Package expat-devel.x86_64 0:2.1.0-8.el7 will be installed
--> Processing Dependency: expat = 2.1.0-8.el7 for package: expat-devel-2.1.0-8.el7.x86_64
--> Running transaction check
---> Package expat.i686 0:2.1.0-8.el7 will be installed


for some reason the 64bit package expat-devel require 32bit expat and then 32bit expat require 32bit glibc - and this result in conflict with 64bit glibc.

This seams to be something wrong with the 'expat-devel.x86_64 0:2.1.0-8.el7'

Try to upgrade it first - there is newer version of it now. I see:
'expat-devel.x86_64 0:2.1.0-10.el7_3' on my laptop.

try:
CODE

yum update expat-devel

and then run the install again

cheers


Posted by: crab Jun 5 2017, 06:50 AM
Thank you very much.
It worked.
sorry for delayed reply.

Thanks again.

Cheers
Crab

'
Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)