Scientific Linux

  Reply to this topicStart new topicStart Poll

> EeePC & Touchpad - problem NOT Linux, EeePC buttons not working
 Posted: Jun 27 2012, 08:58 PM
Quote Post

SLF Newbie

Group: Members
Posts: 7
Member No.: 1373
Joined: 14-March 12

EeePC & Touchpad - problem NOT Linux

Here is a cautionary tale to help the reader save time, unlike the writer!

If any of your EeePC Touch-Pad (TP) buttons don't work, or work intermittently, then read on. (This might also work for other laptops that use a similar HW configuration)

After a windows XP update to SP3 ruined our EeePC 900 (4GB C: drive) I decided to swap it to Linux.
As SL6.2 is used on another PC this was the obvious choice for the 900. On XP the left button needed more than one click now and again but this did not seem much of a problem.

After installing SL 6.2 every thing worked, Volume, Brightness, Wireless, Sleep, good readable screen, great.
But- - - the left TP key did not work at all. But single tapping, the pad, did emulate a left button click.

Some Googling revealed that lots of laptops have trouble with TP buttons.
One suggested removing the entry for Macintosh mouse see:-


Scientific Linux -> Support -> Laptops / Netbooks / Minibooks / Tablets
Has a post by "helikaon"...
..."on redhat bugzilla, where it is recommended to add "psmouse.force_elantech=1"
to the kernel command line by editing the "/boot/grub/grub.conf "

Tried these, seemed to improve matters a bit - button would sometimes work, but very intermittent. Not really a cure.


I found; Re: Touchpad left-click not working on EeePC 900
Post by fbsduser on Thu Apr 01
"The "macintosh mouse" thing is actually the software that allows you to emulate the middle mouse button using the left and right ones. Despite the name. This software works in all the platforms linux supports."

So, depending on how you wish to set up and use your touch-pad removing the "macintosh mouse" entry may not be a good idea.

Another avenue investigated was newer Kernels. After seeing reports of TP's O.K after Kernel upgrade, tried "Live" versions of Fedora 17 LDXE, Knoppix 6.7.1 and Ultimate Ed. 3.2 all have Kernels later than the last SL6.2 update (2.6.32.) TP did not work properly in any of them!

At this point I decided to reinstall the original Win XP as a check.
Using a WD Passport USB3 external HDD and their free backup program WDAcronis, SL6.2 was imaged and the original XP reinstalled.

Under XP the TP button was awful, intermittent and hardly usable - but better than any of the Linux installs ?
For some reason it had deteriorated between being left unused and the first SL6 install.

A search for EeePC TP hardware problems turned up;-

a.) and

c.) (2 to 4)

Dismantling the EeePC and cleaning the switch (a) resulted in the TP button working fine in SL6.2.

Hope this saves a Linux user some time smile.gif

Plus we can confirm Asus EeePC 900 and SL6.2 are a good combination.
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll