Scientific Linux

  Reply to this topicStart new topicStart Poll

> Yum is not working after python update
 Posted: Sep 28 2016, 02:04 AM
Quote Post

SLF Newbie

Group: Members
Posts: 1
Member No.: 3765
Joined: 28-September 16

Im using a remote machine with scientific linux. I tried to update the python on the machine and now yum and some other python packages are not working (its says that it cant find yum module). After searching online I realised that updating the system python can break some of the system tools and I should not have updated it. Is there a way to reinstall the original python. I already tried to install python 2.6 (which was originally on the system) but that didnt work.
 Posted: Sep 29 2016, 01:09 AM
Quote Post

SLF Moderator

Group: Moderators
Posts: 1278
Member No.: 224
Joined: 28-May 11

The only way I can think of is downloading the original python packages for SL and then using rpm to install them, but it will likely be a dependency nightmare.

My personal SL6 repository, specialized in audio/video software:
(can be used together with EPEL and ELRepo repositories) - repository mirror:
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll