Scientific Linux Forum.org



Pages: (3) 1 2 3  ( Go to first unread post ) Reply to this topicStart new topicStart Poll

> Install the nvidia driver in SL6
cahkit
 Posted: Oct 2 2014, 01:33 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 15
Member No.: 3122
Joined: 10-June 14









After spending another week trying to solve this problem, I'm still nowhere. I'm now ready to try toracat's suggestion to install NVIDIA's own driver.

That involves a step to stop the graphics session. How do I do that?

What is it in SL? gdm? xdm? something else?

- chkconfig --list shows no gdm or xdm items

- System -> Admin -> Services shows no gem or xdm items

- Apps -> System Tools -> System Monitor shows no xdm items; however, it does include 4 gdm related processes: gdm-binary, gdm-session-wor, gdm-simple-slave, gdm-user-switch-applet.

So, I implied that gdm must me the graphics server.

But, none of these commands worked:
- service gdm stop
- service gdm-binary stop
- gdm-stop

Nor the xdm versions of the same commands

And I tried these from the command console (i.e after Ctrl-Alt-F2) as well as from the Gnome/Terminal.

So, how do I stop the graphics server before installing NVIDIA's own driver?
PM
^
burakkucat
 Posted: Oct 2 2014, 01:13 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 207
Member No.: 14
Joined: 10-April 11









QUOTE (cahkit @ Oct 2 2014, 01:33 AM)
After spending another week trying to solve this problem, I'm still nowhere. I'm now ready to try toracat's suggestion to install NVIDIA's own driver.

<snip>

So, how do I stop the graphics server before installing NVIDIA's own driver?

<Ctrl><Alt><Fn2> and log in as root. At the command line prompt, issue a telinit 3 command. Now perform the nVidia propriety driver install.

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
cahkit
 Posted: Oct 2 2014, 05:13 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 15
Member No.: 3122
Joined: 10-June 14









QUOTE (burakkucat @ Oct 2 2014, 05:13 AM)
QUOTE (cahkit @ Oct 2 2014, 01:33 AM)
After spending another week trying to solve this problem, I'm still nowhere. I'm now ready to try toracat's suggestion to install NVIDIA's own driver.

<snip>

So, how do I stop the graphics server before installing NVIDIA's own driver?

<Ctrl><Alt><Fn2> and log in as root. At the command line prompt, issue a telinit 3 command. Now perform the nVidia propriety driver install.


Thank you for this suggestion. Fingers crossed (very scientific), hope this works (I mean installing NVIDIA's own driver).
PM
^
cahkit
 Posted: Oct 2 2014, 10:25 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 15
Member No.: 3122
Joined: 10-June 14









I just tried this. No joy. Here's the session:

[sl6admin@localhost ~]$
[sl6admin@localhost ~]$ cat /var/log/nvidia-installer.log
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Oct 2 11:29:56 2014
installer version: 343.22

PATH: /usr/lib64/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/lib64/alliance/bin:/usr/libexec/sdcc:/root/bin

nvidia-installer command line:
./nvidia-installer

Using: nvidia-installer ncurses user interface
-> Tagging shared libraries with chcon -t textrel_shlib_t.
-> License accepted.
-> Installing NVIDIA driver version 343.22.
ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver, and must be disabled before proceeding. Please consult the NVIDIA driver README and your Linux distribution's documentation for details on how to correctly disable the Nouveau kernel driver.
-> For some distributions, Nouveau can be disabled by adding a file in the modprobe configuration directory. Would you like nvidia-installer to attempt to create this modprobe file for you? (Answer: Yes)
-> One or more modprobe configuration files to disable Nouveau have been written. For some distributions, this may be sufficient to disable Nouveau; other distributions may require modification of the initial ramdisk. Please reboot your system and attempt NVIDIA driver installation again. Note if you later wish to reenable Nouveau, you will need to delete these files: /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.
[sl6admin@localhost ~]$

http://dl.dropbox.com/u/2835777/BangHead1.gif

I give up! I haven't done anything productive for a month. I'm just resigned to using the Linux system with a single display.
PM
^
JohnVV
 Posted: Oct 7 2014, 10:07 PM
Quote Post


SLF Member
***

Group: Members
Posts: 81
Member No.: 1124
Joined: 15-December 11









i have used the .run driver for YEARS
on Cent and SL 6 you need to have the nouveau driver blacklisted and the intred rebuild WITHOUT the nouveau
BEFORE installing the .run driver

now fallowing pot #2 from April 2011 should work
but for the .run , not always

mind you this is for the VERY FIRST time you move from the nouveau to the .run
( the kmod rpm DOSE NOT have this issue )

see the post i did on the ancient 96 driver
http://scientificlinuxforum.org/index.php?showtopic=2258
that has the commands needed to rebuild the boot image
CODE

su -

mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r ).img.backup

dracut -f /boot/initramfs-$(uname -r).img $(uname -r)



1) black list nouveau
reboot
2) rebuild boot image
reboot into int3 AS ROOT !!!! ( text only root login )
3) cd to the NVIDIA.run driver
4) run it
CODE

sh *.run

PM
^
cahkit
 Posted: Oct 8 2014, 04:24 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 15
Member No.: 3122
Joined: 10-June 14









JohnVV:

Thank you for your post. I appreciate your suggestion. I'll explain my perspective. As I said in a previous post on this topic I am not a Linux expert or an expert system admin. I know reasonably enough to run and maintain my systems, that's all. These kludges and fixes that have been suggested here are well and good, but what guarantee is there that they won't lead to some other problem, either now or with a future update. Above all my need is for a reliable, stable OS. I am using Linux, specifically Scientific Linux, because I need to do fluid mechanics/aerodynamics prediction/simulation code development. A lot of that is done with Fortran and external libraries, such as NetCDF. Unix/Linux is the logical environment for this work.

My current setup with the default video driver works perfectly well and is stable, and is what hopefully will be stable with future updates. I'll live with the single display limitation for now, hoping that the problems expressed here will be fixed in the future. My productivity is reduced somewhat but at least I won't spend days and weeks fixing the system instead of developing code. I'll keep watching these posts for news that indicate the issue has finally been resolved in a future update.

This is the sort of thing that is preventing Linux from becoming a more mainstream user (notice, I didn't say server) environment. It will remain marginal as long as these types of issues are not resolved.
PM
^
cahkit
 Posted: Oct 8 2014, 09:42 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 15
Member No.: 3122
Joined: 10-June 14









After posting my last message, I discovered that there is a bug report on this problem at bugzilla.redhat.com. See Bug #1056011:

https://bugzilla.redhat.com/show_bug.cgi?id=1056011

The last message of this post claims that the problem is fixed with

xorg-x11-glamor-0.6.0-5.20140506gitf78901e.el6

I just checked my SL 6.5 setup, which I just updated with all available updates. The installed xorg-x11-glamor is

xorg-x11-glamor-0.5.0-20130401git81aadb8.el6

So, if this is indeed the solution, how do I update to this version of glamor? I searched Yum Extender (search string: xorg-x11-glamor-0.6.0-5.20140506gitf78901e.el6) and it did not find anything. I did not have ELRepo repository installed.
PM
^
tux99
 Posted: Oct 8 2014, 09:50 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1276
Member No.: 224
Joined: 28-May 11









xorg-x11-glamor-0.6.0-5.20140506gitf78901e.el6 is not currently available for SL 6.5 (or even RHEL 6.5).

The bug is still open so Redhat hasn't released a fix yet, your best bet is to try the workaround mentioned in the bug report.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
toracat
 Posted: Oct 9 2014, 08:01 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 303
Member No.: 11
Joined: 10-April 11









I suppose the fixed version will be in EL6.6.

--------------------
ELRepo: repository specializing in hardware support for EL
PMUsers Website
^
cahkit
 Posted: Oct 14 2014, 05:31 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 15
Member No.: 3122
Joined: 10-June 14









QUOTE (toracat @ Oct 9 2014, 12:01 PM)
I suppose the fixed version will be in EL6.6.


See the latest post to the Bugzilla.redhat discussion and its referenced information page

http://rhn.redhat.com/errata/RHBA-2014-1376.html

PM
^
William R
 Posted: Oct 5 2017, 12:22 PM
Quote Post


SLF Newbie


Group: Members
Posts: 2
Member No.: 3932
Joined: 4-October 17









Thanks Redman, worked great for me!
PMEmail Poster
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic OptionsPages: (3) 1 2 3  Reply to this topicStart new topicStart Poll