Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> MATE 1.12 issue with GTK3.8
redman
 Posted: Dec 11 2015, 06:56 AM
Quote Post


Retired SLF Administrator
********

Group: Admins
Posts: 1276
Member No.: 2
Joined: 8-April 11









I have been rebuilding MATE 1.12 for SL7.
After installing it all, it seems to be working nicely.
Except with gthumb. There I see something strange happening.

When I launch gthumb exclusively (so no other programs active), it all works fine.
Only where there are the checkmarks I see a blue square (turning into a checkmark when hovering).

But if there are other windows open (either caja or any other program), the menubar of gthumb seems empty.
When I hover those menuitems, they return, but they show an partially empty menuwindow.

I have made some screenshots to illustrate it:
user posted image user posted image user posted image

I am using gthumb 3.2.8 because any newer version requires wegkitgtk4 and that isn't available from the SL or EPEL repos (and rebuilding it did not go all too well).

So, if any of my fellow rpm-builders might have a clue, feel free to share it laugh.gif

--------------------
"Sometimes the best helping hand you can give is a good, firm push."
PM
^
tux99
 Posted: Dec 11 2015, 10:38 AM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









Sorry, I have no clue, never used MATE (and still use SL6). I think your best bet is to contact the MATE developers on their mailing list or on IRC. http://mate-desktop.org/community/

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
redman
 Posted: Dec 14 2015, 07:01 AM
Quote Post


Retired SLF Administrator
********

Group: Admins
Posts: 1276
Member No.: 2
Joined: 8-April 11









After some digging, I found out the problem is related to GTK3 themes.

MATE 1.12 was built for GTK3.18, where EL7 has GTK3.8.
GTK 3.18 has several theme based changes.
The mate themes that come with MATE 1.12 were designed/rebuilt for GTK3.18

When I installed the themes from MATE 1.10, the problem was gone.
These themes are GTK3.8 based wink.gif

--------------------
"Sometimes the best helping hand you can give is a good, firm push."
PM
^
redman
 Posted: Dec 20 2015, 08:22 AM
Quote Post


Retired SLF Administrator
********

Group: Admins
Posts: 1276
Member No.: 2
Joined: 8-April 11









EPEL has pushed the mate-themes package for MATE 1.12.
After installing that onto a MATE 1.10 system, the same GTK problem appears.
I reinstalled a 1.10 version of the themes and the problem was gone.

--------------------
"Sometimes the best helping hand you can give is a good, firm push."
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll