Printable Version of Topic
Click here to view this topic in its original format
Scientific Linux > New Linux users questions > Nvidia Driver installation fails on SL 7.4 with GTX 1060 Max-Q Design

Posted by: Ikeuchi Feb 10 2018, 02:29 PM
Hi all.
I have a dell gaming laptop 7577 with GTX 1060 Max-Q design 6GB. After successfully installing SL 7.4. I tried to install Nvidia driver but despite so much efforts, I couldn't get it installed properly. I tried the guides according these links:
But none of them works. Problem is after installing nvidia driver, when I did reboot, the screen was stopped on the line "Started Crash recovery kernel arming" or "Stared Gnome Display manager". I tried many many ways searched in different topics/forums to fix it but not succeed. So please show me if you know how to fix it. Thanks in advance.

Posted by: burakkucat Feb 10 2018, 04:45 PM
I am unable to give you explicit instructions but have a few links to documentation which may assist --

Posted by: Kalcifer Feb 10 2018, 09:01 PM
Same thing after update that I have received today. Just black screen and sign Gnome manager on it. I've tried to use grub test_cnfiguration during boot, it showed that nvidia driver was damaged.

Posted by: toracat Feb 10 2018, 11:46 PM
Please remove everything you have installed relating to the nvidia driver and follow the instructions given by burakkucat (start with the nvidia-detect page) to install ELRepo's Nvidia driver. If you have trouble, then provide the details as to what failed. We may be able to help you.

Posted by: Ikeuchi Feb 11 2018, 09:30 AM
Hi toracat, burakkucat, I have tried what you said but nothing changed. "# nvidia-detect" output "kmod-nvidia", so I tried installing kmod-nividia and everrything seemed to be ok and package 390.25 was downloaded and installed automatically. But after rebooting, problem was still there on line" started crash recovery kernel arming". Finally I figured out my laptop is Nvidia Optimus laptop because when I did: lspci | grep -E "VGA|3D", the screen output 2 lines: one was on board integrated graphics card Intel HD 630 and other was GTX 1060 Max-Q. And problem is Nvidia PRIME Synchronization for Optimus will require Linux kernel 4.5+ with DRM-KMS support enabled. SE 7.4 ships with an outdated EOL kernel (3.10 which is 5 years old). So is there a way to install Nvidia driver on Optimus laptop running with Scientific 7.4? I found some ways to do that but none of them supports Scientific Linux. For example bumbleebee package supports Fedora only. Any suggestions?

Posted by: burakkucat Feb 11 2018, 02:46 PM
Please make full use of the hints and links with which you were provided . . . above.

The following two links may be of use --

Posted by: Ikeuchi Feb 11 2018, 06:17 PM
QUOTE (burakkucat @ Feb 11 2018, 02:46 PM)
Please make full use of the hints and links with which you were provided . . . above.

The following two links may be of use --

I have fixed that with using bumblebee. I thought bumblebee supports fedora only, but it also works with SL 7 perfectly. Finally problem has been solved. Thank you all for great help.

Powered by Invision Power Board (
© Invision Power Services (