Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> new linux user finding it difficult to install Abaqus, Abaqus install for new Linux user
alxxx
 Posted: Mar 8 2016, 04:31 PM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 3638
Joined: 8-March 16









I have installed scientific linux on a pc for a user who wants Abaqus, I have zero experience of Linux or Abaqus so it is a very difficult task.
I am now having problems simply getting Abaqus fully installed, the latest error is...
No package libstdc++6 available. What is that and how can I get it?

Regards
PMEmail Poster
^
helikaon
 Posted: Mar 8 2016, 07:37 PM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 833
Member No.: 4
Joined: 8-April 11









Hi,
abaqus is a specialized application used (i think) for CAE/FEM computing (so eg. car crash testing and simulation).
Firstly, you should say which wersion of SL you're trying to install it on - so eg. SL 6.7 ? or SL 7.2 ?

generally speaking how to solve similar sit (my laptop has SL 6.7 ):

CODE

yum list all | grep -i libstdc
compat-libstdc++-33.i686            3.2.3-69.el6                @sl/6.5
libstdc++.i686                      4.4.7-11.el6                @sl
libstdc++.x86_64                    4.4.7-11.el6                @sl
libstdc++-devel.x86_64              4.4.7-11.el6                @sl
compat-libstdc++-296.i686           2.96-144.el6                sl
compat-libstdc++-33.x86_64          3.2.3-69.el6                sl
libstdc++-devel.i686                4.4.7-11.el6                sl
libstdc++-docs.x86_64               4.4.7-11.el6                sl

install needed libstdc package depending on your platform (or requirements of your app) 32bit or 64 bit (or both):
yum install libstdc++.x86_64

then have look which libraries the package provided:
rpm -ql libstdc++.x86_64
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.13


cheers,

--------------------
PMEmail Poster
^
alxxx
 Posted: Mar 9 2016, 10:57 AM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 3638
Joined: 8-March 16









QUOTE (helikaon @ Mar 8 2016, 07:37 PM)
Hi,
abaqus is a specialized application used (i think) for CAE/FEM computing (so eg. car crash testing and simulation).
Firstly, you should say which wersion of SL you're trying to install it on - so eg. SL 6.7 ? or SL 7.2 ?

generally speaking how to solve similar sit (my laptop has SL 6.7 ):

CODE

yum list all | grep -i libstdc
compat-libstdc++-33.i686            3.2.3-69.el6                @sl/6.5
libstdc++.i686                      4.4.7-11.el6                @sl
libstdc++.x86_64                    4.4.7-11.el6                @sl
libstdc++-devel.x86_64              4.4.7-11.el6                @sl
compat-libstdc++-296.i686           2.96-144.el6                sl
compat-libstdc++-33.x86_64          3.2.3-69.el6                sl
libstdc++-devel.i686                4.4.7-11.el6                sl
libstdc++-docs.x86_64               4.4.7-11.el6                sl

install needed libstdc package depending on your platform (or requirements of your app) 32bit or 64 bit (or both):
yum install libstdc++.x86_64

then have look which libraries the package provided:
rpm -ql libstdc++.x86_64
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.13


cheers,


Hello and thank you for your help, I am using Scientific Linux 7.2
I tried the code you suggested and got the following errors when trying to run Abaqus:

[root@localhost Commands]# yum install libstdc++.x86_64
Loaded plugins: langpacks
Package libstdc++-4.8.5-4.el7.x86_64 already installed and latest version
Nothing to do
[root@localhost Commands]# rpm -ql libstdc++.x86_64
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.19
/usr/share/gcc-4.8.2
/usr/share/gcc-4.8.2/python
/usr/share/gcc-4.8.2/python/libstdcxx
/usr/share/gcc-4.8.2/python/libstdcxx/__init__.py
/usr/share/gcc-4.8.2/python/libstdcxx/__init__.pyc
/usr/share/gcc-4.8.2/python/libstdcxx/__init__.pyo
/usr/share/gcc-4.8.2/python/libstdcxx/v6
/usr/share/gcc-4.8.2/python/libstdcxx/v6/__init__.py
/usr/share/gcc-4.8.2/python/libstdcxx/v6/__init__.pyc
/usr/share/gcc-4.8.2/python/libstdcxx/v6/__init__.pyo
/usr/share/gcc-4.8.2/python/libstdcxx/v6/printers.py
/usr/share/gcc-4.8.2/python/libstdcxx/v6/printers.pyc
/usr/share/gcc-4.8.2/python/libstdcxx/v6/printers.pyo
/usr/share/gcc-4.8.5
/usr/share/gdb
/usr/share/gdb/auto-load
/usr/share/gdb/auto-load/usr
/usr/share/gdb/auto-load/usr/lib64
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.19-gdb.py
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.19-gdb.pyc
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.19-gdb.pyo
[root@localhost Commands]# ./abaqus cae -mesa
/root/Desktop/6.13-2/code/bin/ABQcaeK: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
Abaqus Error: Abaqus/CAE Kernel exited with an error.
[root@localhost Commands]#

seems I still have some library issues, I would have liked to have had time to learn basic Linux before attempting this Abaqus install but I have been thrown in at the deep end.

Regards,


PMEmail Poster
^
alxxx
 Posted: Mar 9 2016, 11:23 AM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 3638
Joined: 8-March 16









Hi,

I have found out that scientific linux version 7.2 is not compatible with Abaqus 6... if I use Linux 6... then the libraries will be correct for the older version. re installing to older Linux version.

Regards



QUOTE (alxxx @ Mar 9 2016, 10:57 AM)
QUOTE (helikaon @ Mar 8 2016, 07:37 PM)
Hi,
abaqus is a specialized application used (i think) for CAE/FEM computing (so eg. car crash testing and simulation).
Firstly, you should say which wersion of SL you're trying to install it on - so eg. SL 6.7 ? or SL 7.2 ?

generally speaking how to solve similar sit (my laptop has SL 6.7 ):

CODE

yum list all | grep -i libstdc
compat-libstdc++-33.i686            3.2.3-69.el6                @sl/6.5
libstdc++.i686                      4.4.7-11.el6                @sl
libstdc++.x86_64                    4.4.7-11.el6                @sl
libstdc++-devel.x86_64              4.4.7-11.el6                @sl
compat-libstdc++-296.i686           2.96-144.el6                sl
compat-libstdc++-33.x86_64          3.2.3-69.el6                sl
libstdc++-devel.i686                4.4.7-11.el6                sl
libstdc++-docs.x86_64               4.4.7-11.el6                sl

install needed libstdc package depending on your platform (or requirements of your app) 32bit or 64 bit (or both):
yum install libstdc++.x86_64

then have look which libraries the package provided:
rpm -ql libstdc++.x86_64
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.13


cheers,


Hello and thank you for your help, I am using Scientific Linux 7.2
I tried the code you suggested and got the following errors when trying to run Abaqus:

[root@localhost Commands]# yum install libstdc++.x86_64
Loaded plugins: langpacks
Package libstdc++-4.8.5-4.el7.x86_64 already installed and latest version
Nothing to do
[root@localhost Commands]# rpm -ql libstdc++.x86_64
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.19
/usr/share/gcc-4.8.2
/usr/share/gcc-4.8.2/python
/usr/share/gcc-4.8.2/python/libstdcxx
/usr/share/gcc-4.8.2/python/libstdcxx/__init__.py
/usr/share/gcc-4.8.2/python/libstdcxx/__init__.pyc
/usr/share/gcc-4.8.2/python/libstdcxx/__init__.pyo
/usr/share/gcc-4.8.2/python/libstdcxx/v6
/usr/share/gcc-4.8.2/python/libstdcxx/v6/__init__.py
/usr/share/gcc-4.8.2/python/libstdcxx/v6/__init__.pyc
/usr/share/gcc-4.8.2/python/libstdcxx/v6/__init__.pyo
/usr/share/gcc-4.8.2/python/libstdcxx/v6/printers.py
/usr/share/gcc-4.8.2/python/libstdcxx/v6/printers.pyc
/usr/share/gcc-4.8.2/python/libstdcxx/v6/printers.pyo
/usr/share/gcc-4.8.5
/usr/share/gdb
/usr/share/gdb/auto-load
/usr/share/gdb/auto-load/usr
/usr/share/gdb/auto-load/usr/lib64
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.19-gdb.py
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.19-gdb.pyc
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.19-gdb.pyo
[root@localhost Commands]# ./abaqus cae -mesa
/root/Desktop/6.13-2/code/bin/ABQcaeK: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
Abaqus Error: Abaqus/CAE Kernel exited with an error.
[root@localhost Commands]#

seems I still have some library issues, I would have liked to have had time to learn basic Linux before attempting this Abaqus install but I have been thrown in at the deep end.

Regards,

PMEmail Poster
^
helikaon
 Posted: Mar 9 2016, 04:12 PM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 833
Member No.: 4
Joined: 8-April 11










Ok,
that's a good news! Have a fun with a Linux. smile.gif

cheers

--------------------
PMEmail Poster
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll