Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> OpenVAS and SLES 7, Will not install
sunglant
 Posted: Dec 25 2014, 02:25 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 15
Member No.: 3319
Joined: 25-December 14









Evening all,

I apologize if this is the wrong forum for this posting but I have been attempting to install openvas on SLES 7 for several days now with no avail. I run into one issue after another.

I have followed a colleague who said he had luck using the following instructions on centos 7.
http://www.itzgeek.com/how-tos/linux/centos-how-tos/install-openvas-on-centos-7-rhel-7.html

but when I attempt to install on SLES 7 I keep running into issues. http://dl.dropbox.com/u/2835777/BangHead1.gif

I first receive the following error


Error: Package: 1:nikto-2.1.5-10.el7.noarch (epel)
Requires: perl(LW2)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

then following instructions found on atomicorp forums I pull the package recommended but that leads to another error

error: Failed dependencies:
perl(:MODULE_COMPAT_5.8.8) is needed by perl-libwhisker2-2.5-5.el5.art.noarch

Has anyone successfully installed openvas on SLES 7? if so can someone please point me to a way to resolve my confusion.

This post has been edited by tux99: Jun 3 2016, 07:23 PM
PMEmail Poster
^
Josh Wieder
 Posted: Jul 26 2015, 05:12 PM
Quote Post


SLF Newbie


Group: Members
Posts: 1
Member No.: 3502
Joined: 26-July 15









I realize this is quite an old post, however even now months later the EPEL repositories for all versions of Red Hat Linux v7 (RHEL, CentOS, Scientific) continue to produce the error related here.

It sounds like you have essentially happened on to the fix for the issue; you discovered the missing Perl module that is required (LibWhisker2) as an RPM and attempted to install it. Unfortunately, the error message you provided makes it very much sound like you did not have Perl installed at the time you attempted to install the LibWhisker2 RPM.

For those who don't want to hunt through forums, you can download the LibWhiskers2 RPM here: https://github.com/jwieder/perl-libwhisker2-2.5-8.fc19
PMEmail Poster
^
sunglant
 Posted: Jun 3 2016, 05:30 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 15
Member No.: 3319
Joined: 25-December 14









QUOTE (Josh Wieder @ Jul 26 2015, 12:12 PM)
I realize this is quite an old post, however even now months later the EPEL repositories for all versions of Red Hat Linux v7 (RHEL, CentOS, Scientific) continue to produce the error related here.

It sounds like you have essentially happened on to the fix for the issue; you discovered the missing Perl module that is required (LibWhisker2) as an RPM and attempted to install it. Unfortunately, the error message you provided makes it very much sound like you did not have Perl installed at the time you attempted to install the LibWhisker2 RPM.

For those who don't want to hunt through forums, you can download the LibWhiskers2 RPM here: https://github.com/jwieder/perl-libwhisker2-2.5-8.fc19


actually I didn't I was pulled an other project, and have been unable to return to this project, not to mention the system I was working on died a horrible death, and I ended up in Kuwait for a while, still trying to get situated now that I am back states side.
PMEmail Poster
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll