Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> chkrootkit-0.5 installing error on SL 7.1
ostenerik
 Posted: Dec 29 2015, 05:31 PM
Quote Post


SLF Newbie


Group: Members
Posts: 2
Member No.: 3022
Joined: 16-March 14









Hello

I ran "make sense " for installing and that
gave me an error:

"/usr/bin/ld: cannot find -lc"
"collect2: error: ld returned 1 exit status"
"make: *** [strings-static] Error 1"

I need some help here despite googling around quite a while.

Thanks
PM
^
helikaon
 Posted: Dec 31 2015, 12:56 PM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 836
Member No.: 4
Joined: 8-April 11









QUOTE (ostenerik @ Dec 29 2015, 05:31 PM)
Hello

I ran "make sense " for installing and that
gave me an error:

"/usr/bin/ld:  cannot find -lc"
"collect2: error: ld returned 1 exit status"
"make: *** [strings-static] Error 1"

I need some help here despite googling around quite a while.

Thanks



Hi,
the most probable cause in this case is, that you are missing some shared library file that the linker looks for.
The reason can be twofold:
- the library really is not present on your system
- library is present on your system, but you don't specify library PATH as the compiling option

in your case, i'd try install all 'glibc*' packages.

so eg.
CODE

yum install glibc-static.x86_64 compat-glibc.x86_64 glibc-headers.x86_64 glibc-common.x86_64 glibc.x86_64


cheers :-)

--------------------
PMEmail Poster
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll