Scientific Linux

  Reply to this topicStart new topicStart Poll

> 7.3 KS issue with built-in repos, --cost option not seeming to work
 Posted: Aug 25 2017, 05:49 PM
Quote Post

SLF Newbie

Group: Members
Posts: 3
Member No.: 3815
Joined: 18-January 17

We like to lock our local repositories when we roll to a new version. We do this by syncing a mirror and using it to perform our kickstarts and only using external repos when absolutely necessary. This has worked well all the way up to 6.5. Now that we are upgrading all hosts to 7.3 it seems that if our local repos don't have an update to a package that the built-in repos do have, it is upgrading to that version from the external repos during kickstart.

It would be nice to ignore all built-in repos during kickstart. The only switch that does anything is the --cost option. I am trying this with a value of "1" for my local repos. It is still updating gblic2 and others using the built-in repos.

Is there another option to use during kickstart? Do I need to crack open the stage2 and remove the /etc/anaconda.repos.d stuff?

I'm forced now to keep my mirrors in sync with external repos.
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll