Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> deja-dup 14.2 and duplicity 0.6.21
joka
 Posted: May 14 2013, 10:54 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 172
Member No.: 107
Joined: 28-April 11









I have been using deja-dup since Fedora 11 and later on in SL6 as my favorite backup tool for home directories. deja-dup is more or less a graphical frontend for duplicity and nicely integrated to the GNOME desktop. According to pkgs.org deja-dup was not available in any EL6 3rd party repo. The latest version compatible to GNOME 2.28 is deja-dup-14.2 which is also the version available in Debian Squeeze and Ubuntu 10.04LTS.

I don't know if anyone has installed deja-dup from my repo, but unfortunately the latest upgrade of duplicity to 0.6.21 (from 0.6.18-1) within the EPEL repository has broken compatibility to deja-dup. After the update from May 3, the old version was no more available in the EPEL repository. A "yum history undo" or "yum downgrade duplicity" was not working for me. Therefore I have decided to rebuild and add the old version duplicity-0.6.18-1 to my repo.

UPDATE: I have found a solution how to install deja-dup and a compatible version of duplicity without the need to modify the epel.repo configuration, see post #3.

It is remarkable that the bug reporter of duplicity data corruption bug 922576 has attached a patch for 0.6.18 but the Fedora maintainer has decided to upgrade duplicity to a new version instead of applying the patch, which seems to me quite unusual for EPEL:
QUOTE (Rahul Sundaram 2013-03-18 21:03:59 EDT)

I have reviewed the upstream changelog and I think it is just better to push the latest upstream release to all active branches instead of cherry picking fixes.  I am going to attempt to do that now.

But I have to admit I have missed the chance to post a comment while the duplicity update was in EPEL's testing repo.
I have added the mentioned patch to compat-duplicity0618-0.6.18-2 in my joka-release repo.
PM
^
joka
 Posted: May 16 2013, 08:33 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 172
Member No.: 107
Joined: 28-April 11









I have found a solution thats avoid the need to modify the configuration file /etc/yum.repos.d/epel.repo: I have renamed the old duplicity package to compat-duplicity0618 and declared a conflict with duplicity >= 0.6.20.

Provided you have installed the EPEL and joka-release repos, you can install now deja-dup and a compatible version of duplicity by following commands:

1) You have not yet installed duplicity:
CODE
yum install --enablerepo=epel --enablerepo=joka-release deja-dup

This will install compat-duplicity0618 as dependancy. Afterwards yum will refuse to install duplicity from EPEL.

2) You have already installed duplicity-0.6.21 from EPEL, but want to use deja-dup:
CODE
yum downgrade --enablerepo=epel --enablerepo=joka-release duplicity-0.6.18
yum install --enablerepo=epel --enablerepo=joka-release deja-dup
yum update --enablerepo=joka-release

Without the downgrade to duplicity-0.6.18, yum will refuse to install deja-dup 14.2-2 because of the conflict with duplicity-0.6.21.
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll