Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Auto Login, Autologin with the various session manag
Todd
 Posted: Jun 1 2015, 06:27 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 23
Member No.: 36
Joined: 11-April 11









Autologin:

References: https://wiki.archlinux.org/index.php/LightDM#Enabling_autologin
Note: this reference is missing "autologin-session=true"

http://www.perturb.org/display/812_GDM_AutoLogin.html
http://www.linfo.org/automatic_login.html
http://www.freetechie.com/blog/kubuntuand-kde-4-user-auto-login/


You have three possible Screen Managers (the login thingy):

gdm: gnome
lightdm: lxde, xfce, MATE-Compiz
kdmrc: KDE4

To double check:
$ ps ax | grep -i "lightdm\|gdm\|kdmrc" | grep -v grep



GDM:

It only auto-logs in on first boot, and it must be a non-root user.

edit /etc/gdm/custom.conf:
[daemon]
AutomaticLoginEnable=true
AutomaticLogin=whatever_username
TimedLoginEnable=true

TimedLogin=whatever_username
TimedLoginDelay=0


The autologin doesn't require a reboot to work, just issue the following command:

/etc/init.d/gdm restart



Lightdm:

edit /etc/lightdm/lightdm.conf:

[SeatDefaults]
pam-autologin-service=lightdm-autologin
user-session=xfce # optional
session-wrapper=/etc/lightdm/Xsession # note: change the default
autologin-user=tony
autologin-user-timeout=0
autologin-session=true

Set up LightDM and PAM and autologin

# groupadd autologin
# gpasswd --add tony autologin
# reboot



KDMRC (not verified, use at own risk):

edit /etc/kde4/kdm/kdmrc:

[X-:0-Core]
AutoLoginEnable=true
AutoLoginLocked=false
AutoLoginUser=bkevan
ClientLogFile=.xsession-errors
PMEmail Poster
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll