Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> EPEL conflicts sl-release-100
cipri_tom
 Posted: Jun 11 2014, 04:23 PM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 3123
Joined: 11-June 14









I tried to put the latest EPEL version, but I got the following conflict:

CODE
file /etc/yum.repos.d/epel.repo from install of epel-release-6-8.noarch conflicts with file from package sl-release-100:6.5-3.slc6.x86_64


I am on SL CERN 6, freshly installed.

I am pursuing instalation of Firefox 29 and emacs 24.

Sorry if this is in the wrong thread.

Many thanks!
PM
^
redman
 Posted: Jun 12 2014, 09:39 AM
Quote Post


Retired SLF Administrator
********

Group: Admins
Posts: 1276
Member No.: 2
Joined: 8-April 11









Did you try to install the EPEL repo from their site or by using the config file from the SL© repo?

Try "yum install epel-release".

--------------------
"Sometimes the best helping hand you can give is a good, firm push."
PM
^
cipri_tom
 Posted: Jun 12 2014, 10:01 AM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 3123
Joined: 11-June 14









QUOTE (redman @ Jun 12 2014, 10:39 AM)
Did you try to install the EPEL repo from their site or by using the config file from the SLĀ© repo?

I tried from their website, I think. I downloaded the package

QUOTE (redman @ Jun 12 2014, 10:39 AM)
Try "yum install epel-release".

Yeap, this seems to work. However, I did not complete it as I have been advised by our admin that it will make my system extremely unstable. Can you advise anything related to that? biggrin.gif

Many thanks!
PM
^
patriehecky
 Posted: Jun 12 2014, 02:14 PM
Quote Post


SL Developer
***

Group: Moderators
Posts: 88
Member No.: 837
Joined: 14-September 11









QUOTE (cipri_tom @ Jun 11 2014, 10:23 AM)
I tried to put the latest EPEL version, but I got the following conflict:

CODE
file /etc/yum.repos.d/epel.repo from install of epel-release-6-8.noarch conflicts with file from package sl-release-100:6.5-3.slc6.x86_64


I am on SL CERN 6, freshly installed.

I am pursuing instalation of Firefox 29 and emacs 24.

Sorry if this is in the wrong thread.

Many thanks!


Any reason you are using SLC rather than SL?

Pat

--------------------
Pat Riehecky

Scientific Linux developer
http://www.scientificlinux.org/
The best way to get my attention is over the official lists.
PM
^
cipri_tom
 Posted: Jun 12 2014, 06:42 PM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 3123
Joined: 11-June 14









QUOTE (patriehecky @ Jun 12 2014, 03:14 PM)


Any reason you are using SLC rather than SL?

Pat


Because I am at CERN.... biggrin.gif biggrin.gif biggrin.gif


I managed to install them after all, from source directly.
For firefox it was easy. Just got the relevant file from their website, placed it in my home directory, and replaced the symbolic links
For emacs, the
CODE
configure
took a bit longer, needed to install auxiliary packages for image libraries (they needed the devel headers), but still managed to do it.

Thanks for support. I guess I'll be happy with updating them myself rather than having a repo which my break other stuff.
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll