Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> [SL7 testing] /run/media/muyser/NAME is owned by wrong user
SeeM
 Posted: Dec 9 2015, 03:40 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 16
Member No.: 1301
Joined: 20-February 12









Hi. I'm making a comeback after happy Fedora testing time. smile.gif

During installation I made testowik user. testowik is not my primary user account and it's locked most of the time. I'm Lukasz and have an account named lukasz. When I plug usb drive with encrypted data I have /run/media/lukasz/PAM directory created fine, but:
CODE
[lukasz@localhost ~]$ ls -al /run/media/lukasz/PAM/
ls: cannot open directory /run/media/lukasz/PAM/: Permission denied
[lukasz@localhost ~]$ ls -al /run/media/lukasz/
total 4
drwxr-x---+  3 root     root       60 Dec  9 15:59 .
drwxr-xr-x.  3 root     root       60 Dec  9 15:59 ..
drwx------. 11 testowik testowik 4096 Dec  6 21:48 PAM


It's fine now, after chown -R lukasz.lukasz everything in /run/media/lukasz, but why it was owned by a testowik user? I checked every existing udev rules for testowik string, but there aren't any. I had this issue only with encrypted partitions, every other partition and cd's are fine.

Are you having similar issue? I'm trying to find a connection between, well, anything. I guess it could be the same user ID for original owner of the file and testowik user, but nearly every first user on any RHEL clone have an ID of 1000 and it's the first time i have this problem.
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll