Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> "nmap -sP -PR 192.168.1.1/16", scan aborted | virbr0-interface
McErroneous
 Posted: Nov 4 2015, 04:28 PM
Quote Post


SLF Newbie


Group: Members
Posts: 4
Member No.: 3560
Joined: 4-November 15









Hi, doing an nmap-scan:

nmap -sP -PR 192.168.1.1/16

the scan does not finish , but aborts its work , when coming to interface "virbr0"
http://dl.dropbox.com/u/2835777/BangHead1.gif

Error Message follows:

pcap_open_live(virbr0, 100, 0, 200) FAILED. Reported error: virbr0: That device is not up. Will wait 5 seconds then retry.
pcap_open_live(virbr0, 100, 0, 200) FAILED. Reported error: virbr0: That device is not up. Will wait 25 seconds then retry.
Call to pcap_open_live(virbr0, 100, 0, 200) failed three times. Reported error: virbr0: That device is not up
There are several possible reasons for this, depending on your operating system:
LINUX: If you are getting Socket type not supported, try modprobe af_packet or recompile your kernel with SOCK_PACKET enabled.
*BSD: If you are getting device not configured, you need to recompile your kernel with Berkeley Packet Filter support. If you are getting No such file or directory, try creating the device (eg cd /dev; MAKEDEV <device>; or use mknod).
*WINDOWS: Nmap only supports ethernet interfaces on Windows for most operations because Microsoft disabled raw sockets as of Windows XP SP2. Depending on the reason for this error, it is possible that the --unprivileged command-line argument will help.
SOLARIS: If you are trying to scan localhost or the address of an interface and are getting '/dev/lo0: No such file or directory' or 'lo0: No DLPI device found', complain to Sun. I don't think Solaris can support advanced localhost scans. You can probably use "-PN -sT localhost" though.


QUITTING!

So nmap apparenty does come over a local interface, and encounters some kind of error. and thus does not complet its task.

I am to lazy to report this problem to nmap.org would somebody be so kind as to do it instead ?
blink.gif
it got solved, using :
1. virsh net-list
2. virsh net-destroy

see link:
http://www.cyberciti.biz/faq/linux-kvm-disable-virbr0-nat-interface/
http://th166.photobucket.com/albums/u117/rdshear/Smiley%20Faces/th_smiley-face-thumbs-up.gif http://www.madjacksports.com/forum/images/smilies/facepalm.gif

PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll