Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> No wifi and no kmod package
elias
 Posted: May 23 2014, 08:34 PM
Quote Post


SLF Newbie


Group: Members
Posts: 3
Member No.: 3099
Joined: 23-May 14









Hi, I'm very new to Linux but decided to set up SL6.4 on my laptop because I'm doing a lot of computations. Anyways I have not been able to connect to a wireless network however wired connection works fine.

lspci -nn gives among other things:

CODE

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)


iwconfig gives:
CODE

eth0      no wireless extensions.

lo        no wireless extensions.


I looked at the kmods and there weren't any for 10ec:8179.

This is indeed a similar problem as here: http://scientificlinuxforum.org/index.php?showtopic=2569

and I did try to install kernel-lt without luck I also tried doing what OP. I downloaded those backports packages but I don't know where to run these "make" commands. If I do "make clean" in the same directory as appears when I depompress these packages I get:
QUOTE

/--------------
| Your kernel headers are incomplete/not installed.
| Please install kernel headers, including a .config
| file or use the KLIB/KLIB_BUILD make variables to
| set the kernel to build against, e.g.
|  make KLIB=/lib/modules/3.1.7/
| to compile/install for the installed kernel 3.1.7
| (that isn't currently running.)
\--
make: *** [clean] Error 1



I have no idea what that means. I'm not really sure what to do with those backports packages.

So I'm very lost here, and getting quite desperate because I need to be able to access the internet wirelessly on my laptop. Any advice would be greatly appreciated.
PM
^
toracat
 Posted: May 23 2014, 09:02 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 300
Member No.: 11
Joined: 10-April 11









QUOTE (elias @ May 23 2014, 12:34 PM)

and I did try to install kernel-lt without luck

What exactly was the problem? Maybe we can help if you provide more details.

--------------------
ELRepo: repository specializing in hardware support for EL
PMUsers Website
^
elias
 Posted: May 23 2014, 11:37 PM
Quote Post


SLF Newbie


Group: Members
Posts: 3
Member No.: 3099
Joined: 23-May 14









QUOTE (toracat @ May 23 2014, 09:02 PM)
QUOTE (elias @ May 23 2014, 12:34 PM)

and I did try to install kernel-lt without luck

What exactly was the problem? Maybe we can help if you provide more details.

Thank you for your answer,

Well I followed the instructions and installed it, no problem, then I rebooted but nothing had changed. I don't really have any more details on that. Should I have do something afterwards?
PM
^
elias
 Posted: May 24 2014, 01:43 PM
Quote Post


SLF Newbie


Group: Members
Posts: 3
Member No.: 3099
Joined: 23-May 14









Ok no worries I found this thread: http://scientificlinuxforum.org/index.php?showtopic=2661 ..I don't know how I missed it before. I followed this instructions of burakkucat and now I have wireless connection! So if another newbie finds himself/herself in the same situation as me the instructions in that thread are virtually fool proof. Just note that you might need a different firmware (as I did) than the OP in that thread.

So do this yourself:

QUOTE

[Duo2 ~]$ uname -a
Linux Duo2 2.6.32-431.5.1.el6.x86_64 #1 SMP Fri Jan 10 14:46:43 EST 2014 x86_64 x86_64 x86_64 GNU/Linux
[Duo2 ~]$ rpm -qa kernel\* | sort
kernel-2.6.32-431.5.1.el6.x86_64
kernel-firmware-2.6.32-431.5.1.el6.noarch
kernel-headers-2.6.32-431.5.1.el6.x86_64
kernel-lt-3.10.30-1.el6.elrepo.x86_64
kernel-ml-3.13.3-1.el6.elrepo.x86_64
[Duo2 ~]$ grep -i 050d /lib/modules/*/modules.alias | grep -i 845a
/lib/modules/3.10.30-1.el6.elrepo.x86_64/modules.alias:alias usb:v050Dp845Ad*dc*dsc*dp*ic*isc*ip*in* r8712u
/lib/modules/3.13.3-1.el6.elrepo.x86_64/modules.alias:alias usb:v050Dp845Ad*dc*dsc*dp*ic*isc*ip*in* r8712u
[Duo2 ~]$


Change the 050d into the first 4 characters of your adapter ID (for me it was 10ec) and 845a to the last four (in my case 8179) and this should spit out which firmware you need. Also in my case, when I downloaded the firmware it did not find itself in the the right place somehow. So I had to copy it from my download directory into the correct directory as is described in the thread.
Everything else was the same.

Also, thank you burakkucat if you see this!
PM
^
burakkucat
 Posted: May 24 2014, 04:38 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 193
Member No.: 14
Joined: 10-April 11









QUOTE (elias @ May 24 2014, 01:43 PM)

Also, thank you burakkucat if you see this!

b*cat yawns, stretches, reads through the latest posts at the Scientific Linux forum, sees elias' thanks, blushes and purrs -- You're welcome.

Edited to add the specific details for this issue --

CODE

[Duo2 ~]$ grep -i 10ec /lib/modules/*/modules.alias | grep -i 8179
/lib/modules/3.10.40-1.el6.elrepo.x86_64/modules.alias:alias pci:v000010ECd00008179sv*sd*bc*sc*i* rtl8188ee
/lib/modules/3.14.4-1.el6.elrepo.x86_64/modules.alias:alias pci:v000010ECd00008179sv*sd*bc*sc*i* rtl8188ee
[Duo2 ~]$ find /lib/modules/3.10.40-1.el6.elrepo.x86_64 -name rtl8188ee.ko
/lib/modules/3.10.40-1.el6.elrepo.x86_64/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko
[Duo2 ~]$ modinfo $(find /lib/modules/3.10.40-1.el6.elrepo.x86_64 -name rtl8188ee.ko)
filename:       /lib/modules/3.10.40-1.el6.elrepo.x86_64/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko
firmware:       rtlwifi/rtl8188efw.bin
description:    Realtek 8188E 802.11n PCI wireless
license:        GPL
author:         Larry Finger <Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         zhiyuan_yang <zhiyuan_yang@realsil.com.cn>
srcversion:     AF3FE0A9B63E55FECB5D119
alias:          pci:v000010ECd00008179sv*sd*bc*sc*i*
depends:        rtlwifi,mac80211
intree:         Y
vermagic:       3.10.40-1.el6.elrepo.x86_64 SMP mod_unload modversions
parm:           swenc:Set to 1 for software crypto (default 0)
(bool)
parm:           ips:Set to 0 to not use link power save (default 1)
(bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
(bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
(bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
[Duo2 ~]$ ll /lib/firmware | grep rtlwifi
[Duo2 ~]$

In this case, the firmware required is rtl8188efw.bin and it needs to be placed in the /lib/firmware/rtlwifi/ directory.

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll