Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> network interface bonding, bonding working but strange messages
krachbumm
 Posted: Jan 22 2014, 04:37 PM
Quote Post


SLF Member
***

Group: Members
Posts: 66
Member No.: 1961
Joined: 15-October 12









Hi,

I set up a machine with bonding device. It seems to work, but /var/log/messages is filled with strange entries. I tried balance-tlb, but only got balance-xor working.


CODE
[root@server network-scripts]# tail /var/log/messages
Jan 21 15:44:02 server kernel: bond0: received packet with own address as source address
Jan 21 15:58:48 server kernel: bond0: received packet with own address as source address
Jan 21 16:07:37 server kernel: bond0: received packet with own address as source address
Jan 21 16:16:05 server kernel: bond0: received packet with own address as source address
Jan 21 16:42:43 server kernel: bond0: received packet with own address as source address
Jan 21 17:00:43 server kernel: bond0: received packet with own address as source address
Jan 21 17:09:09 server kernel: bond0: received packet with own address as source address
Jan 21 17:09:09 server kernel: bond0: received packet with own address as source address
Jan 21 17:09:09 server kernel: bond0: received packet with own address as source address
Jan 21 17:09:09 server kernel: bond0: received packet with own address as source address
[root@server network-scripts]# cat ifcfg-bond0
DEVICE=bond0
ONBOOT=yes
BONDING_OPTS="'mode=balance-xor'"
BRIDGE=br0
[root@server network-scripts]# cat ifcfg-eth0
DEVICE=eth0
HWADDR=00:30:48:89:80:A6
ONBOOT=yes
MASTER=bond0
SLAVE=yes
[root@server network-scripts]# cat ifcfg-eth1
DEVICE=eth1
HWADDR=00:30:48:89:80:A7
ONBOOT=yes
MASTER=bond0
SLAVE=yes
[root@server network-scripts]# cat ifcfg-br0
DEVICE=br0
ONBOOT=yes
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.51.160
NETMASK=255.255.255.0
STP=off
DELAY=0



Can you point me in any direction for a solution. Or should I just ignore /var/log/messages on this issue?

I used TUV-docu:
https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/s2-networkscripts-interfaces-chan.html
https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/sec-Using_Channel_Bonding.html

This post has been edited by krachbumm: Jan 28 2014, 08:53 AM
PM
^
krachbumm
 Posted: Jan 28 2014, 08:52 AM
Quote Post


SLF Member
***

Group: Members
Posts: 66
Member No.: 1961
Joined: 15-October 12









I changed mode to balance-rr, no more errors...

CODE
BONDING_OPTS="'mode=balance-rr'"


----


I disabled bonding, because I was unable to figure out how to configure it so that dhcp/icinga/... works for my kvm/qemu vms...

This post has been edited by krachbumm: Apr 17 2014, 02:15 PM
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll