Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Problem installing mplayer/mencoder from Linuxtech repo
datty
 Posted: Jan 23 2015, 12:13 PM
Quote Post


SLF Newbie


Group: Members
Posts: 2
Member No.: 3348
Joined: 23-January 15









Hi,

I'm having problems installing mencoder from the Linuxtech repo. I keep getting the following error:

--> Finished Dependency Resolution
Error: Package: mencoder-1.0.4-3.el6.x86_64 (linuxtech-release)
Requires: libbluray.so.1()(64bit)
Error: Package: mplayer-1.0.4-3.el6.x86_64 (linuxtech-release)
Requires: libbluray.so.1()(64bit)


Does anyone have any ideas how I can resolve this?

Thanks
PM
^
helikaon
 Posted: Jan 23 2015, 04:05 PM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 836
Member No.: 4
Joined: 8-April 11









QUOTE (datty @ Jan 23 2015, 12:13 PM)
Hi,

I'm having problems installing mencoder from the Linuxtech repo. I keep getting the following error:

--> Finished Dependency Resolution
Error: Package: mencoder-1.0.4-3.el6.x86_64 (linuxtech-release)
          Requires: libbluray.so.1()(64bit)
Error: Package: mplayer-1.0.4-3.el6.x86_64 (linuxtech-release)
          Requires: libbluray.so.1()(64bit)


Does anyone have any ideas how I can resolve this?

Thanks


Hi,
try:
CODE

yum --enablerepo=* whatprovides */libbluray.so.1
or (to widen the search)
yum --enablerepo=* whatprovides */libbluray.so
or (to widen even more)
yum --enablerepo=* whatprovides */libbluray


i had no hit, but maybe i dont have the repository list that you have, so you might find it ..


--------------------
PMEmail Poster
^
tux99
 Posted: Jan 24 2015, 02:42 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1276
Member No.: 224
Joined: 28-May 11









Libbluray is in the Linuxtech repo, I have a feeling you are getting this error due to a conflict with some other incompatible repo that you have enabled.

Please post the whole output you get (not just the error) when running 'yum install mplayer', so we can have a look at it.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
datty
 Posted: Jan 27 2015, 09:51 AM
Quote Post


SLF Newbie


Group: Members
Posts: 2
Member No.: 3348
Joined: 23-January 15









Thanks for the responses, I checked the whatprovides and got no hits. I somehow missed the '832 packages excluded due to repository priority protections'. I increased the priority of the linuxtech repo and it all installed correctly. Sorry for the trouble, I'm still trying to get my head around this stuff.

Edit: Meant to say thanks tux99 for making these packages, they definitely fill a huge hole in SL.

Thanks
PM
^
tux99
 Posted: Jan 28 2015, 06:50 AM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1276
Member No.: 224
Joined: 28-May 11









QUOTE (datty @ Jan 27 2015, 10:51 AM)
Edit: Meant to say thanks tux99 for making these packages, they definitely fill a huge hole in SL.


You are welcome! smile.gif

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll