Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> OURLiNK 802.11n
alexus
 Posted: Oct 19 2012, 07:21 PM
Quote Post


SLF Newbie


Group: Members
Posts: 8
Member No.: 1890
Joined: 1-October 12









I got "OURLiNK 802.11n" mini USB wifi adapter for my Raspberry Pi, but I also would like to use it w/ my Scientific Linux 6.1

$ cat /etc/redhat-release
Scientific Linux release 6.1 (Carbon)
$

when I insert dongle into USB port, I'm getting following in my log

CODE
   Oct 18 11:16:28 X kernel: usb 1-4: new high speed USB device number 5 using ehci_hcd
   Oct 18 11:16:28 X kernel: usb 1-4: New USB device found, idVendor=0bda, idProduct=8176
   Oct 18 11:16:28 X kernel: usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
   Oct 18 11:16:28 X kernel: usb 1-4: Product: 802.11n WLAN Adapter
   Oct 18 11:16:28 X kernel: usb 1-4: Manufacturer: Realtek
   Oct 18 11:16:28 X kernel: usb 1-4: SerialNumber: 00e04c000001
   Oct 18 11:16:28 X kernel: usb 1-4: configuration #1 chosen from 1 choice


I added a connection through: System->Preferences->Network Connections->Wireless->Add using Ad-hoc mode, I even did `service network restart`, yet I still don't see SSID from another wireless device.

CODE
$ sudo service network restart
Shutting down interface eth0:  Device state: 3 (disconnected)
                                                          [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  Active connection state: activated
Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/4
                                                          [  OK  ]
$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0F:FE:D7:B3:8D  
         inet addr:192.168.0.221  Bcast:192.168.0.255  Mask:255.255.255.0
         inet6 addr: fe80::20f:feff:fed7:b38d/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:4158 errors:0 dropped:0 overruns:0 frame:0
         TX packets:2869 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:1457504 (1.3 MiB)  TX bytes:785812 (767.3 KiB)
         Interrupt:19 Memory:f3100000-f3120000

lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:76 errors:0 dropped:0 overruns:0 frame:0
         TX packets:76 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:4219 (4.1 KiB)  TX bytes:4219 (4.1 KiB)

$


I'd like to be able to configure NATing on my Linux so that other devices can use that connection to connect to Internet.
PMEmail Poster
^
cuppachan
 Posted: Oct 20 2012, 01:21 PM
Quote Post


SLF Newbie


Group: Members
Posts: 10
Member No.: 1969
Joined: 18-October 12










Hi Alexus ,

Is this device working on the rasberry PI ?

If it is then one option might be to see what module the PI is using.

Try the following

1. Turn the Pi off
2.Insert the OURLiNK 802.11n
3. Turn on the Pi
4. Once fully started - run lsmod from the command line.
5. If it generates a long list you may want to try the following lsmod | grep -i realtek

Then try plugging the donggle into the SL server and run

lsmod | grep -i realtek

Compare and contrast the modules that they are using and then try and hunt down that module .

As RedHat 6 is on kernel version 2.6.x (you can confirm this by doing uname -a from the command line

You are most likely to need a tarball from the following page

http://tinyurl.com/336jh9f

Scroll down to the LINUX driver for kernel 3.x and 2.6.x and 2.4.x section and down load from your nearest location.

Heres the instruction from the readme file of your driver on installing and checking to make sure it had loaded correctly.

This needs to be done as root.

<Quick install with proper kernel settings>
Unpack the tarball :
# tar vjxf r8168-8.aaa.bb.tar.bz2

Change to the directory:
# cd r8168-8.aaa.bb

If you are running the target kernel, then you should be able to do :

# ./autorun.sh (as root or with sudo)

You can check whether the driver is loaded by using following commands.

# lsmod | grep r8168
# ifconfig -a

If there is a device name, ethX, shown on the monitor, the linux
driver is loaded. Then, you can use the following command to activate
the ethX.

Heres a little tutorial on compiling deffinatly worth a read - http://www.tuxfiles.org/linuxhelp/softinstall.html

Hope that helps
PM
^
alexus
 Posted: Apr 20 2013, 04:08 PM
Quote Post


SLF Newbie


Group: Members
Posts: 8
Member No.: 1890
Joined: 1-October 12









I insert adapter into Windows7 it said that it's 8188cu, yet linux says CHIP TYPE: RTL8188C_8192C you telling 8168

it's _SO_ confusing, which one do I need and where to get it and how to install it(
PMEmail Poster
^
toracat
 Posted: Apr 21 2013, 12:10 AM
Quote Post


SLF Geek
****

Group: Members
Posts: 303
Member No.: 11
Joined: 10-April 11









The first thing I need you to do is to follow the instructions in FAQ #4 of ELRepo and provide the Vendor:Device ID pairing of your wireless device.

--------------------
ELRepo: repository specializing in hardware support for EL
PMUsers Website
^
alexus
 Posted: Jun 24 2013, 07:35 PM
Quote Post


SLF Newbie


Group: Members
Posts: 8
Member No.: 1890
Joined: 1-October 12









QUOTE (toracat @ Apr 20 2013, 07:10 PM)
The first thing I need you to do is to follow the instructions in FAQ #4 of ELRepo and provide the Vendor:Device ID pairing of your wireless device.


it appears that I have following: ELRepo : kmod-r8192cu. I'm using SL and it doesn't appear that I have _ANY_ support build-in.
P.S. This is what I'm trying to use: Miniature WiFi (802.11b/g/n) Module: For Raspberry Pi and more ID: 814 - $11.95 : Adafruit Industries, Unique & fun DIY electronics and kits

Please advise.
PMEmail Poster
^
toracat
 Posted: Jun 24 2013, 11:11 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 303
Member No.: 11
Joined: 10-April 11









QUOTE (alexus @ Jun 24 2013, 11:35 AM)

it appears that I have following: ELRepo : kmod-r8192cu. I'm using SL and it doesn't appear that I have _ANY_ support build-in.
P.S. This is what I'm trying to use: Miniature WiFi (802.11b/g/n) Module: For Raspberry Pi and more ID: 814 - $11.95 : Adafruit Industries, Unique & fun DIY electronics and kits

I assume you have identified the driver for your device to be r8192cu based on the vendor:device IDs. Then set up the ELRepo repository by running:

yum install elrepo-release

and install the kmod by:

yum install kmod-r8192cu

Then reboot the system and see if your wireless device is now detected and the driver loaded.


--------------------
ELRepo: repository specializing in hardware support for EL
PMUsers Website
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll