Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Error When Running yum Related to VLC
kenmorgan
 Posted: Jan 6 2017, 07:13 PM
Quote Post


SLF Member
***

Group: Members
Posts: 60
Member No.: 1782
Joined: 8-August 12









I just tried to do an update and received the following message:

CODE

[root@localhost1 kmorgan]# yum upgrade
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Upgrade Process
Loading mirror speeds from cached hostfile
* base: mirror.tzulo.com
* elrepo: ftp.osuosl.org
* epel: ftp.osuosl.org
* extras: mirror.5ninesolutions.com
* updates: mirror.umd.edu
Resolving Dependencies
--> Running transaction check
---> Package ghostscript.i686 0:8.70-21.el6 will be updated
---> Package ghostscript.i686 0:8.70-21.el6_8.1 will be an update
---> Package libdvbpsi.i686 0:0.2.2-2.el6 will be updated
--> Processing Dependency: libdvbpsi.so.7 for package: vlc-2.0.7-10.el6.i686
---> Package libdvbpsi.i686 0:1.2.0-3.el6 will be an update
--> Finished Dependency Resolution
Error: Package: vlc-2.0.7-10.el6.i686 (@linuxtech-release)
          Requires: libdvbpsi.so.7
          Removing: libdvbpsi-0.2.2-2.el6.i686 (@linuxtech-release)
              libdvbpsi.so.7
          Updated By: libdvbpsi-1.2.0-3.el6.i686 (epel)
              Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@localhost1 kmorgan]#


I didn't want to try anything before checking here. Thanks.

Ken

--------------------
Ken
CentOS 6
PMEmail PosterUsers Website
^
tux99
 Posted: Jan 7 2017, 04:21 AM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1276
Member No.: 224
Joined: 28-May 11









It looks like epel now includes a newer libdvbpsi package that is incompatible with the one in Linuxtech.

I'll have a look into it over the weekend to see what the best solution is.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
tux99
 Posted: Jan 8 2017, 02:12 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1276
Member No.: 224
Joined: 28-May 11









Ok I have made a modified libdvbpsi package that should solve the conflict with Epel. It's currently in the Linuxtech-testing repo so you need to run the following:

yum --enablerepo=linuxtech-testing update

Please let me know if it solves your problem.

This post has been edited by tux99: Jan 8 2017, 02:15 PM

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
kenmorgan
 Posted: Jan 8 2017, 07:49 PM
Quote Post


SLF Member
***

Group: Members
Posts: 60
Member No.: 1782
Joined: 8-August 12









Thanks tux! smile.gif It looks like it worked:

CODE

[root@localhost1 kmorgan]# yum --enablerepo=linuxtech-testing upgrade
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Upgrade Process
Loading mirror speeds from cached hostfile
epel/metalink                                            |  15 kB     00:00    
* base: mirror.tzulo.com
* elrepo: ftp.osuosl.org
* epel: ftp.osuosl.org
* extras: centos.sonn.com
* updates: lug.mtu.edu
adobe-linux-i386                                         |  951 B     00:00    
base                                                     | 3.7 kB     00:00    
chromium-el6                                             | 1.9 kB     00:00    
elrepo                                                   | 2.9 kB     00:00    
extras                                                   | 3.3 kB     00:00    
linuxtech-release                                        | 2.6 kB     00:00    
linuxtech-testing                                        | 2.5 kB     00:00    
linuxtech-testing/primary_db                             |  95 kB     00:00    
updates                                                  | 3.4 kB     00:00    
Resolving Dependencies
--> Running transaction check
---> Package ghostscript.i686 0:8.70-21.el6 will be updated
---> Package ghostscript.i686 0:8.70-21.el6_8.1 will be an update
---> Package libdvbpsi.i686 0:0.2.2-2.el6 will be obsoleted
---> Package libdvbpsi7.i686 0:0.2.2-3.el6 will be obsoleting
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package          Arch      Version                Repository              Size
================================================================================
Installing:
libdvbpsi7       i686      0.2.2-3.el6            linuxtech-testing       85 k
    replacing  libdvbpsi.i686 0.2.2-2.el6
Updating:
ghostscript      i686      8.70-21.el6_8.1        updates                4.5 M

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       1 Package(s)

Total download size: 4.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): ghostscript-8.70-21.el6_8.1.i686.rpm              | 4.5 MB     00:46    
(2/2): libdvbpsi7-0.2.2-3.el6.i686.rpm                   |  85 kB     00:01    
--------------------------------------------------------------------------------
Total                                            94 kB/s | 4.5 MB     00:49    
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
 Installing : libdvbpsi7-0.2.2-3.el6.i686                                  1/4
 Updating   : ghostscript-8.70-21.el6_8.1.i686                             2/4
 Erasing    : libdvbpsi-0.2.2-2.el6.i686                                   3/4
 Cleanup    : ghostscript-8.70-21.el6.i686                                 4/4
 Verifying  : ghostscript-8.70-21.el6_8.1.i686                             1/4
 Verifying  : libdvbpsi7-0.2.2-3.el6.i686                                  2/4
 Verifying  : libdvbpsi-0.2.2-2.el6.i686                                   3/4
 Verifying  : ghostscript-8.70-21.el6.i686                                 4/4

Installed:
 libdvbpsi7.i686 0:0.2.2-3.el6                                                

Updated:
 ghostscript.i686 0:8.70-21.el6_8.1                                            

Replaced:
 libdvbpsi.i686 0:0.2.2-2.el6                                                  

Complete!
[root@localhost1 kmorgan]#


--------------------
Ken
CentOS 6
PMEmail PosterUsers Website
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll