Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> ntfs-3g update conflict
tankist02
 Posted: Jun 23 2011, 04:37 AM
Quote Post


SLF Newbie


Group: Members
Posts: 13
Member No.: 301
Joined: 16-June 11









Hi,

I installed SL6 recently (x86_64) and added EPEL repositories. When I ran yum update I got the following error:

CODE

[root@localhost ~]# yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package fuse-sshfs.x86_64 0:2.2-6.el6 set to be updated
---> Package iperf.x86_64 0:2.0.5-1.el6 set to be updated
---> Package livecd-tools.x86_64 1:13.3-1.el6 set to be updated
---> Package ntfsprogs.x86_64 2:2011.4.12-3.el6 set to be updated
--> Processing Dependency: libntfs-3g.so.81()(64bit) for package: 2:ntfsprogs-2011.4.12-3.el6.x86_64
---> Package openvpn.x86_64 0:2.1.4-1.el6 set to be updated
---> Package python-imgcreate.x86_64 1:13.3-1.el6 set to be updated
---> Package testdisk.x86_64 0:6.12-2.el6 set to be updated
--> Running transaction check
---> Package ntfs-3g.x86_64 2:2011.4.12-3.el6 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================
Package                      Arch               Version                        Repository        Size
=======================================================================================================
Installing:
ntfsprogs                    x86_64             2:2011.4.12-3.el6              epel             225 k
    replacing  ntfsprogs.x86_64 1.13.1-1.el6.rf
Updating:
fuse-sshfs                   x86_64             2.2-6.el6                      epel              48 k
iperf                        x86_64             2.0.5-1.el6                    epel              50 k
livecd-tools                 x86_64             1:13.3-1.el6                   epel              51 k
openvpn                      x86_64             2.1.4-1.el6                    epel             365 k
python-imgcreate             x86_64             1:13.3-1.el6                   epel              85 k
testdisk                     x86_64             6.12-2.el6                     epel             357 k
Installing for dependencies:
ntfs-3g                      x86_64             2:2011.4.12-3.el6              epel             247 k

Transaction Summary
=======================================================================================================
Install       2 Package(s)
Upgrade       6 Package(s)

Total size: 1.4 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
 file /usr/bin/ntfs-3g from install of ntfs-3g-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /usr/bin/ntfsmount from install of ntfs-3g-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /sbin/mount.lowntfs-3g from install of ntfs-3g-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /sbin/mount.ntfs from install of ntfs-3g-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /usr/share/man/man8/ntfs-3g.8.gz from install of ntfs-3g-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /usr/share/man/man8/ntfs-3g.8.gz from install of ntfsprogs-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /usr/share/man/man8/ntfs-3g.probe.8.gz from install of ntfs-3g-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /usr/share/man/man8/ntfs-3g.probe.8.gz from install of ntfsprogs-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /usr/share/man/man8/ntfs-3g.secaudit.8.gz from install of ntfs-3g-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /usr/share/man/man8/ntfs-3g.secaudit.8.gz from install of ntfsprogs-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /usr/share/man/man8/ntfs-3g.usermap.8.gz from install of ntfs-3g-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64
 file /usr/share/man/man8/ntfs-3g.usermap.8.gz from install of ntfsprogs-2:2011.4.12-3.el6.x86_64 conflicts with file from package fuse-ntfs-3g-2010.10.2-1.el6.rf.x86_64

Error Summary
-------------


Any help would be greatly appreciated.
PM
^
joutlan
 Posted: Jun 23 2011, 04:40 AM
Quote Post


SLF Inceptor
*******

Group: Admins
Posts: 871
Member No.: 1
Joined: 8-April 11









Ok....I had this...to quickly resolve it:

Turn off all repos except SL repos
Uninstall ntfsprogs
reinstall ntfsprogs

From memory....I uninstall testdisk also. You can reinstall later ...

--------------------
DΞLL Precision M6700: 17 inch NB//i7-quad w/USB 3.0, 16.0GB, Quadro K5000M 2.0GB DDR3, RGBLED //W8P64/Scientific Linux 6.4 x64
DΞLL Vostro 3350 Nirvana: 13 inch NB w/ IntelSSD// W8Px64 (Work;Games)
Nexus 4 //Android
PMEmail PosterUsers Website
^
redman
 Posted: Jun 23 2011, 05:52 AM
Quote Post


Retired SLF Administrator
********

Group: Admins
Posts: 1276
Member No.: 2
Joined: 8-April 11









QUOTE (tankist02 @ Jun 23 2011, 06:37 AM)
I installed SL6 recently (x86_64) and added EPEL repositories.

Looking at the conflicting files, it seems you mixed RPMforge with EPEL. That is causing the problem (they bite each other).
John (joutlan) is right, disable those repos not needed except EPEL.
Reinstall and you should be fine (until the next time you mix repos and need a specific package) sad.gif

--------------------
"Sometimes the best helping hand you can give is a good, firm push."
PM
^
tankist02
 Posted: Jun 24 2011, 04:17 AM
Quote Post


SLF Newbie


Group: Members
Posts: 13
Member No.: 301
Joined: 16-June 11









If I disable EPEL and leave only SL repos I can't install ntfsprogs:

CODE

# yum install ntfsprogs
Loaded plugins: refresh-packagekit, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
No package ntfsprogs available.
Error: Nothing to do


I don't have any other repos except SL and EPEL:

CODE

# ls /etc/yum.repos.d/
epel.repo  epel-testing.repo  sl.repo  sl-updates.repo
PM
^
joutlan
 Posted: Jun 24 2011, 04:24 AM
Quote Post


SLF Inceptor
*******

Group: Admins
Posts: 871
Member No.: 1
Joined: 8-April 11









Strange!! Do you have a RH repo open??? ntfsprogs should install...I just did it blink.gif Have you had RHEL on that machine?

--------------------
DΞLL Precision M6700: 17 inch NB//i7-quad w/USB 3.0, 16.0GB, Quadro K5000M 2.0GB DDR3, RGBLED //W8P64/Scientific Linux 6.4 x64
DΞLL Vostro 3350 Nirvana: 13 inch NB w/ IntelSSD// W8Px64 (Work;Games)
Nexus 4 //Android
PMEmail PosterUsers Website
^
tankist02
 Posted: Jun 25 2011, 12:50 AM
Quote Post


SLF Newbie


Group: Members
Posts: 13
Member No.: 301
Joined: 16-June 11









I probably did something stupid. Please forgive me - it is first time I tried SL. My OpenSource experience is mostly with FreeBSD, Ubuntu and Arch.

First I couldn't find on SL site how to configure to use EPEL repo. So I found some source RPM to do that and probably it was a wrong move.

My questions are:

- Can I salvage the system now, preferably without reinstalling?

- How do I add additional repositories on SL?

Many thanks for help,
Andrew
PM
^
tankist02
 Posted: Jun 25 2011, 05:52 AM
Quote Post


SLF Newbie


Group: Members
Posts: 13
Member No.: 301
Joined: 16-June 11









It looks the following happens: ntfsprogs installs dependency ntfs-3g which conflicts with already installed fuse-ntfs-3g. After removing the latter update process completed successfully.
PM
^
redman
 Posted: Jun 25 2011, 08:35 AM
Quote Post


Retired SLF Administrator
********

Group: Admins
Posts: 1276
Member No.: 2
Joined: 8-April 11









QUOTE (tankist02 @ Jun 25 2011, 02:50 AM)
- Can I salvage the system now, preferably without reinstalling?

It depends on how big the damage is. It might be easier to reinstall.

QUOTE (tankist02 @ Jun 25 2011, 02:50 AM)
- How do I add additional repositories on SL?

You might want to have a look at this thread first.
Depending with repo you want to add it can be installed through yum (because SL has some predefined.
Others you will have to manually and info should be available on their website.

--------------------
"Sometimes the best helping hand you can give is a good, firm push."
PM
^
devwebadmn
 Posted: Jun 10 2017, 11:19 AM
Quote Post


SLF Newbie


Group: Members
Posts: 1
Member No.: 3887
Joined: 10-June 17









SOLUTION:

Thanks to previous commenter I was able to solve this problem quickly.

CODE
yum remove fuse-ntfs-3g


it will ask to remove fuse-ntfs-3g and test-disk. Say yes (it's fine).

Then run yum update and it will work fine.

problem solved in 2 minutes. First 1:50 was spent looking up this solution.
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll