Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Multipath has no listing, multipath + iscsi + virtualbox
warren
 Posted: Jul 14 2013, 08:36 PM
Quote Post


SLF Newbie


Group: Members
Posts: 6
Member No.: 2615
Joined: 14-July 13









I am trying to setup iscsi under virtualbox and it works fine, I can see the iscsi targets and can login and logout.

When I try to see multipath, I get nothing.

CODE

[root@sl01 ~]# multipath -ll
[root@sl01 ~]#


What could be wrong?

Here is my multipath.conf

CODE
defaults {
       find_multipaths                 yes
       user_friendly_names             yes
       udev_dir                        /dev/
       path_selector                   "service-time 0"
       path_checker                    readsector0
       path_grouping_policy            multibus
       no_path_retry                   fail
}

blacklist {
}


I do not have a file /etc/multipath/bindings

iscsiadm show this :

CODE
[root@sl01 ~]# iscsiadm --mode node
172.20.75.74:3260,1 iqn.2013-07.com.thehome:sl03:storage
172.20.75.75:3260,1 iqn.2013-07.com.thehome:sl03:storage
172.20.73.100:3260,1 iqn.2013-07.com.thehome:sl03:storage


Nothing in /var/log/messages :
CODE

Jul 14 16:27:56 sl01 multipathd: --------shut down-------
Jul 14 16:27:56 sl01 multipathd: path checkers start up

Any help and direction would be most helpful.
PM
^
warren
 Posted: Jul 17 2013, 12:37 PM
Quote Post


SLF Newbie


Group: Members
Posts: 6
Member No.: 2615
Joined: 14-July 13









Ok, solved this issue.

1. Had configured the Storage Server wrongly and was not exporting as iscsi.

2. On the client, iscsid was started, iscsi was not started.

once I corrected these 2 things, I ran multipath -v 3 -ll and got all the disks I was supposed to see.

Thanks


Mods edit: please use the default font and color wink.gif
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll