Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Third Party Repo Hades With Yum, Yum Updates broken
sstory
 Posted: Jul 23 2015, 10:45 PM
Quote Post


SLF Newbie


Group: Members
Posts: 2
Member No.: 3501
Joined: 23-July 15









It seems forever that I have been trying to get the packages I want without breaking SL 6.6.
I want to do the basics: Video with any and all Codecs (open source, free or not), audio from the same including MP3. To that end I found I could not install VLC. Rhythmbox won't work for need of one CODEC or another and having added several third party repos, but placing yum-priority in what I hoped would help avoid these issues, has failed me. I can't play my MP3s and I can't update. Please help. How do I get what I want without hosing it all.

The output of yum update is currently
CODE
Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Setting up Update Process
Loading mirror speeds from cached hostfile
* epel: ftp.osuosl.org
* nux-dextop: mirror.li.nux.ro
* sl: ftp2.scientificlinux.org
* sl-security: ftp2.scientificlinux.org
* sl6x: ftp2.scientificlinux.org
* sl6x-security: ftp2.scientificlinux.org
576 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package a52dec.x86_64 0:0.7.4-15.el6.nux will be updated
---> Package a52dec.x86_64 0:0.7.4-18.el7.nux will be an update
---> Package cwiid.x86_64 0:0.6.00-21.20100505gitfadf11e.el6 will be updated
---> Package cwiid.x86_64 0:0.6.00-23.20100505gitfadf11e.el7.nux will be an update
---> Package faad2-libs.x86_64 1:2.7-1.el6.nux will be updated
---> Package faad2-libs.x86_64 1:2.7-5.el7.nux will be an update
---> Package gnome-games-extra.x86_64 1:2.28.2-2.el6 will be obsoleted
---> Package gnome-media-libs.x86_64 0:2.29.91-6.el6 will be obsoleted
--> Processing Dependency: libgnome-media-profiles.so.0()(64bit) for package: sound-juicer-2.28.1-6.el6.x86_64
--> Processing Dependency: libgnome-media-profiles.so.0()(64bit) for package: rhythmbox-0.12.8-1.el6.x86_64
--> Processing Dependency: libgnome-media-profiles.so.0()(64bit) for package: gnome-media-2.29.91-6.el6.x86_64
---> Package lame.x86_64 0:3.99.5-1.el6.nux will be updated
---> Package lame.x86_64 0:3.99.5-2.el7 will be an update
---> Package lame-libs.x86_64 0:3.99.5-1.el6.nux will be updated
---> Package lame-libs.x86_64 0:3.99.5-2.el7 will be an update
---> Package libdca.x86_64 0:0.0.5-5.el6.nux will be updated
---> Package libdca.x86_64 0:0.0.5-7.el7.nux will be an update
---> Package libgnome-media-profiles.x86_64 0:3.0.0-6.el7.nux will be obsoleting
--> Processing Dependency: libgtk-3.so.0()(64bit) for package: libgnome-media-profiles-3.0.0-6.el7.nux.x86_64
--> Processing Dependency: libgdk-3.so.0()(64bit) for package: libgnome-media-profiles-3.0.0-6.el7.nux.x86_64
--> Processing Dependency: libcairo-gobject.so.2()(64bit) for package: libgnome-media-profiles-3.0.0-6.el7.nux.x86_64
---> Package libmad.x86_64 0:0.15.1b-13.el6.nux will be updated
---> Package libmad.x86_64 0:0.15.1b-16.el7.nux will be an update
---> Package libmms.x86_64 0:0.6.2-1.el6.nux will be updated
---> Package libmms.x86_64 0:0.6.4-1.el7.nux will be an update
---> Package libmpeg2.x86_64 0:0.5.1-8.el6.nux will be updated
---> Package libmpeg2.x86_64 0:0.5.1-10.el7.nux will be an update
---> Package librtmp.x86_64 0:2.4-0.3.20110811gitc58cfb3e.el6.nux will be updated
---> Package librtmp.x86_64 0:2.4-2.20131205.gitdc76f0a.el7.nux will be an update
--> Processing Dependency: libgnutls.so.28(GNUTLS_2_12)(64bit) for package: librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64
--> Processing Dependency: libgnutls.so.28(GNUTLS_1_4)(64bit) for package: librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64
--> Processing Dependency: libgnutls.so.28()(64bit) for package: librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64
---> Package live555.x86_64 0:0-0.34.2012.01.25.el6.nux will be updated
---> Package live555.x86_64 0:2013.11.26-1.el7.nux will be an update
---> Package megamario.x86_64 0:1.5-5.el6.nux will be updated
---> Package megamario.x86_64 0:1.5-5.el7.nux will be an update
---> Package simple-scan.x86_64 0:2.32.0.2-1.el6.nux will be updated
---> Package simple-scan.x86_64 0:3.10.0-1.el7.nux will be an update
--> Processing Dependency: libgtk-3.so.0()(64bit) for package: simple-scan-3.10.0-1.el7.nux.x86_64
--> Processing Dependency: libgdk-3.so.0()(64bit) for package: simple-scan-3.10.0-1.el7.nux.x86_64
--> Processing Dependency: libcolordprivate.so.1()(64bit) for package: simple-scan-3.10.0-1.el7.nux.x86_64
--> Processing Dependency: libcolord.so.1()(64bit) for package: simple-scan-3.10.0-1.el7.nux.x86_64
--> Processing Dependency: libcairo-gobject.so.2()(64bit) for package: simple-scan-3.10.0-1.el7.nux.x86_64
---> Package tali.x86_64 0:3.10.2-1.el7.nux will be obsoleting
--> Processing Dependency: libgtk-3.so.0()(64bit) for package: tali-3.10.2-1.el7.nux.x86_64
--> Processing Dependency: libgdk-3.so.0()(64bit) for package: tali-3.10.2-1.el7.nux.x86_64
--> Processing Dependency: libcairo-gobject.so.2()(64bit) for package: tali-3.10.2-1.el7.nux.x86_64
---> Package twolame-libs.x86_64 0:0.3.12-4.el6.nux will be updated
---> Package twolame-libs.x86_64 0:0.3.13-3.el7.nux will be an update
---> Package unrar.x86_64 0:3.9.10-3.el6.nux will be updated
---> Package unrar.x86_64 0:5.0.12-2.el7.nux will be an update
---> Package x264-libs.x86_64 0:0.142-7.20140728gitaf8e768.el6.nux will be updated
---> Package x264-libs.x86_64 0:0.142-7.20140728gitaf8e768.el7.nux will be an update
---> Package xmms.x86_64 1:1.2.11-11.20071117cvs.el6.nux will be updated
---> Package xmms.x86_64 1:1.2.11-19.20071117cvs.el7.nux will be an update
--> Processing Dependency: libm.so.6(GLIBC_2.15)(64bit) for package: 1:xmms-1.2.11-19.20071117cvs.el7.nux.x86_64
---> Package xmms-libs.x86_64 1:1.2.11-11.20071117cvs.el6.nux will be updated
---> Package xmms-libs.x86_64 1:1.2.11-19.20071117cvs.el7.nux will be an update
--> Processing Dependency: libm.so.6(GLIBC_2.15)(64bit) for package: 1:xmms-libs-1.2.11-19.20071117cvs.el7.nux.x86_64
--> Finished Dependency Resolution
Error: Package: sound-juicer-2.28.1-6.el6.x86_64 (@anaconda-ScientificLinux-201401271129.x86_64/6.5)
          Requires: libgnome-media-profiles.so.0()(64bit)
          Removing: gnome-media-libs-2.29.91-6.el6.x86_64 (@anaconda-ScientificLinux-201401271129.x86_64/6.5)
              libgnome-media-profiles.so.0()(64bit)
          Obsoleted By: libgnome-media-profiles-3.0.0-6.el7.nux.x86_64 (nux-dextop)
              Not found
Error: Package: libgnome-media-profiles-3.0.0-6.el7.nux.x86_64 (nux-dextop)
          Requires: libcairo-gobject.so.2()(64bit)
Error: Package: simple-scan-3.10.0-1.el7.nux.x86_64 (nux-dextop)
          Requires: libcolord.so.1()(64bit)
Error: Package: librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64 (nux-dextop)
          Requires: libgnutls.so.28(GNUTLS_2_12)(64bit)
Error: Package: simple-scan-3.10.0-1.el7.nux.x86_64 (nux-dextop)
          Requires: libgdk-3.so.0()(64bit)
Error: Package: librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64 (nux-dextop)
          Requires: libgnutls.so.28(GNUTLS_1_4)(64bit)
Error: Package: simple-scan-3.10.0-1.el7.nux.x86_64 (nux-dextop)
          Requires: libcolordprivate.so.1()(64bit)
Error: Package: 1:xmms-libs-1.2.11-19.20071117cvs.el7.nux.x86_64 (nux-dextop)
          Requires: libm.so.6(GLIBC_2.15)(64bit)
Error: Package: libgnome-media-profiles-3.0.0-6.el7.nux.x86_64 (nux-dextop)
          Requires: libgtk-3.so.0()(64bit)
Error: Package: gnome-media-2.29.91-6.el6.x86_64 (@anaconda-ScientificLinux-201401271129.x86_64/6.5)
          Requires: libgnome-media-profiles.so.0()(64bit)
          Removing: gnome-media-libs-2.29.91-6.el6.x86_64 (@anaconda-ScientificLinux-201401271129.x86_64/6.5)
              libgnome-media-profiles.so.0()(64bit)
          Obsoleted By: libgnome-media-profiles-3.0.0-6.el7.nux.x86_64 (nux-dextop)
              Not found
Error: Package: tali-3.10.2-1.el7.nux.x86_64 (nux-dextop)
          Requires: libcairo-gobject.so.2()(64bit)
Error: Package: librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64 (nux-dextop)
          Requires: libgnutls.so.28()(64bit)
Error: Package: simple-scan-3.10.0-1.el7.nux.x86_64 (nux-dextop)
          Requires: libgtk-3.so.0()(64bit)
Error: Package: rhythmbox-0.12.8-1.el6.x86_64 (@anaconda-ScientificLinux-201401271129.x86_64/6.5)
          Requires: libgnome-media-profiles.so.0()(64bit)
          Removing: gnome-media-libs-2.29.91-6.el6.x86_64 (@anaconda-ScientificLinux-201401271129.x86_64/6.5)
              libgnome-media-profiles.so.0()(64bit)
          Obsoleted By: libgnome-media-profiles-3.0.0-6.el7.nux.x86_64 (nux-dextop)
              Not found
Error: Package: tali-3.10.2-1.el7.nux.x86_64 (nux-dextop)
          Requires: libgtk-3.so.0()(64bit)
Error: Package: tali-3.10.2-1.el7.nux.x86_64 (nux-dextop)
          Requires: libgdk-3.so.0()(64bit)
Error: Package: 1:xmms-1.2.11-19.20071117cvs.el7.nux.x86_64 (nux-dextop)
          Requires: libm.so.6(GLIBC_2.15)(64bit)
Error: Package: libgnome-media-profiles-3.0.0-6.el7.nux.x86_64 (nux-dextop)
          Requires: libgdk-3.so.0()(64bit)
Error: Package: simple-scan-3.10.0-1.el7.nux.x86_64 (nux-dextop)
          Requires: libcairo-gobject.so.2()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


priorities set as follows:
CODE

adobe-linux-x86_64.repo:priority=56
epel.repo:failovermethod=priority
epel.repo:priority=11
epel.repo:failovermethod=priority
epel.repo:priority=11
epel.repo:failovermethod=priority
epel.repo:priority=11
epel-testing.repo:failovermethod=priority
epel-testing.repo:priority=200
epel-testing.repo:failovermethod=priority
epel-testing.repo:priority=200
epel-testing.repo:failovermethod=priority
epel-testing.repo:priority=200
home:DarkPlayer:Pipelight.repo:priority=90
linuxtech.repo:priority=80
linuxtech.repo:priority=80
linuxtech.repo:priority=80
nux-dextop.repo:priority=20
nux-dextop.repo:priority=20
oracle-linux.repo:priority=50
sl6x.repo:priority=1
sl6x.repo:priority=1
sl6x.repo:priority=1
sl-other.repo:priority=1
sl-other.repo:priority=1
sl-other.repo:priority=1
sl-other.repo:priority=1
sl-other.repo:priority=1
sl.repo:priority=1
sl.repo:priority=1
sl.repo:priority=1


I have no idea how to resolve. I have been working with Linux at work for a few years, with help. I have switched from Windoze to Linux within the last year or so and found it challenging for this single reason.

TIA,

Shane


PM
^
tux99
 Posted: Aug 15 2015, 08:43 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









It looks to me like you have an issue with the nux repo, maybe post the above error output on the nux forum: https://forums.nux.ro/

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
sstory
 Posted: Aug 18 2015, 12:33 PM
Quote Post


SLF Newbie


Group: Members
Posts: 2
Member No.: 3501
Joined: 23-July 15









QUOTE (tux99 @ Aug 15 2015, 02:43 PM)
It looks to me like you have an issue with the nux repo, maybe post the above error output on the nux forum: https://forums.nux.ro/


Thanks for your reply. Believe it or not, I have it resolved. Someone noticed that somehow I was getting EL7, even though I am running EL6. No wonder I had trouble.
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll