Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> SL7 default repos 404
Masemo1234
 Posted: May 1 2018, 10:20 AM
Quote Post


SLF Newbie


Group: Members
Posts: 3
Member No.: 4011
Joined: 1-May 18









Hello,
I just switched from OpenSUSE to SL7. When i tried installing software with yum, every default repo returns a 404 Error.
I have internet connection and tried fixing my DNS config and adding a 3rd party repo but it didn't change a thing. I'm really stuck here and the only poster having a similar problem was running SL on a VM. This is what yum returns when i try to install anything:

CODE
sudo yum install chromium
[sudo] Passwort für marius:
Geladene Plugins: langpacks
http://mirror.rackspace.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
This generally happens when your clien is unable to communicate with the repo server.

Please verify your connection works as expected.


http://elrepo.org/linux/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.osuosl.org/pub/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirrors.coreix.net/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirror.imt-systems.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://www.jules.fm/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.ines.lug.ro/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://elrepo.reloumirrors.net/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirrors.coreix.net/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://repos.mia.lax-noc.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://repos.dfw.lax-noc.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://repos.ord.lax-noc.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://repos.lax-noc.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://repos.lax-noc.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirrors.ircam.fr/pub/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirror.ventraip.net.au/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirror.ventraip.net.au/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.nluug.nl/os/Linux/distr/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.colocall.net/pub/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirrors.leadhosts.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirrors.xservers.ro/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.cc.uoc.gr/mirrors/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://elrepo.mirrors.arminco.com/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirrors.netix.net/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirrors.thzhost.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.ne.jp/Linux/RPMS/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://reflector.westga.edu/repos/ELRepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.yz.yamagata-u.ac.jp/pub/linux/RPMS/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://fedora.is/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.utexas.edu/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirror.cedia.org.ec/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ord.mirror.rackspace.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://dfw.mirror.rackspace.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirror.uta.edu.ec/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://hkg.mirror.rackspace.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://lon.mirror.rackspace.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://iad.mirror.rackspace.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://syd.mirror.rackspace.com/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://muug.ca/mirror/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.icm.edu.pl/pub/Linux/distributions/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://elrepo.0m3n.net/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 502 - Bad Gateway
Anderer Spiegelserver wird versucht.
https://mirrors.tuna.tsinghua.edu.cn/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTPS Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://mirror.koddos.net/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://ftp.e-utp.net/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 14] HTTP Error 404 - Not Found
Anderer Spiegelserver wird versucht.
http://elrepo.mirror.angkasa.id/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: [Errno 12] Timeout on http://elrepo.mirror.angkasa.id/elrepo/elrepo/el7/x86_64/repodata/repomd.xml.asc: (28, 'Connection timed out after 30000 milliseconds')
Anderer Spiegelserver wird versucht.
...
...
...


When I try to open the linnks with a browser it also 404s. How do I fix this. is there a way to fix my repo list to sync with the most recent release default?
Thanks in advance
Masemo
PM
^
burakkucat
 Posted: May 1 2018, 02:52 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 233
Member No.: 14
Joined: 10-April 11









Please try a simple test. From the command line become "root" --

sudo su -

Next, issue the following two lines and see what response is obtained --

yum clean all
yum repolist


Are you absolutely sure that you have a working connection to the Internet? From the command line are you able to --

ping -c 5 8.8.8.8

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
Masemo1234
 Posted: May 1 2018, 03:11 PM
Quote Post


SLF Newbie


Group: Members
Posts: 3
Member No.: 4011
Joined: 1-May 18









QUOTE (burakkucat @ May 1 2018, 03:52 PM)
Please try a simple test. From the command line become "root" --

sudo su -


when i got into su shell I encountered the following error(how can root not have permissions to read or write in yum directory?)
I don't want to change any permissions that would make something integral like gpg keys insecure:
CODE

id f69eb105ed0e5484feb2dbef232c8e76b1d399bb
reason:         os.py:157:makedirs:OSError: [Errno 13] Keine Berechtigung: '/var/lib/yum/repos/x86_64/7/sl/gpgdir-ro'
time:           Di 01 Mai 2018 12:25:53 CEST
cmdline:        /usr/bin/python /usr/bin/yum repolist
package:        yum-3.4.3-154.el7
uid:            1000 (marius)
count:          1
Directory:      /var/spool/abrt/Python-2018-05-01-12:25:53-3888


QUOTE (burakkucat @ May 1 2018, 03:52 PM)

Next, issue the following two lines and see what response is obtained --

yum clean all


this returned
CODE

Geladene Plugins: langpacks
Quellen werden aufgeräumt:elrepo
                       : ftp.scientificlinux.org_linux_scientific_7x_repos_x86_64_repodata_
                       : repos sl sl-extras sl-fastbugs sl-security
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned data from disabled or removed repos



QUOTE (burakkucat @ May 1 2018, 03:52 PM)


yum repolist


Still returns 404 for all repos +
CODE

sl-security/x86_64                                       | 2.9 kB     00:00    
Repo-ID                                                            Repo-N Status
elrepo                                                             ELRepo     0
ftp.scientificlinux.org_linux_scientific_7x_repos_x86_64_repodata_ added      0
repos/x86_64                                                       Scient     0
sl/x86_64                                                          Scient 9.718
sl-extras/x86_64                                                   Scient     0
sl-fastbugs/x86_64                                                 Scient     0
sl-security/x86_64                                                 Scient     0
repolist: 9.718


QUOTE (burakkucat @ May 1 2018, 03:52 PM)

Are you absolutely sure that you have a working connection to the Internet? From the command line are you able to --

ping -c 5 8.8.8.8


CODE
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=60 time=28.6 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=60 time=26.7 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=60 time=24.9 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=60 time=25.0 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=60 time=24.4 ms

--- 8.8.8.8 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 24.469/25.979/28.605/1.536 ms


Looks OK to me

Edit: This is my resolv.conf file:

CODE

# Generated by NetworkManager
search fritz.box
nameserver 8.8.8.8


PM
^
burakkucat
 Posted: May 1 2018, 03:51 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 233
Member No.: 14
Joined: 10-April 11









I am not sure about the contents of your /etc/resolv.conf file. Please try commenting out the "search fritz.box" line --

# Generated by NetworkManager
#search fritz.box
nameserver 8.8.8.8

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
Masemo1234
 Posted: May 1 2018, 03:54 PM
Quote Post


SLF Newbie


Group: Members
Posts: 3
Member No.: 4011
Joined: 1-May 18









QUOTE (burakkucat @ May 1 2018, 04:51 PM)
I am not sure about the contents of your /etc/resolv.conf file. Please try commenting out the "search fritz.box" line --

# Generated by NetworkManager
#search fritz.box
nameserver 8.8.8.8


Done that, the problem is still the same.
Thank you for helping me with this
PM
^
burakkucat
 Posted: May 1 2018, 04:02 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 233
Member No.: 14
Joined: 10-April 11









What you are experiencing is not normal for Scientific Linux. sad.gif You have a working connection to the Internet yet something stopping access to named repositories.

To gain a larger audience and so that the Scientific Linux developers will see the problem, I think it would be best if you describe your current problem by posting to the scientific-linux-users mailing list. For details how to join that mailing list, please see the information on this page.

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll