Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> NetworkManager and the nmcli command return error in SL7, After update NetworkManager not work
dcaron
 Posted: Feb 1 2016, 05:12 PM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 1673
Joined: 10-July 12









Hi,

I just made a yum update on my SL7.0 but, after reboot, NetworkManager (or nmcli) is no more working.

# systemctl status NetworkManager
‚óŹ NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
Active: failed (Result: start-limit) since lun. 2016-02-01 15:40:43 CET; 2h 20min ago
Process: 3825 ExecStart=/usr/sbin/NetworkManager --no-daemon (code=exited, status=127)
Main PID: 3825 (code=exited, status=127)


Then I tried the command:
# /usr/sbin/NetworkManager
/usr/sbin/NetworkManager: symbol lookup error: /lib64/libgudev-1.0.so.0: undefined symbol: g_type_class_adjust_p

NetworkManager-1.0.6-27.el7.x86_64
libgudev1-219-19.el7.x86_64

RedHat seems to have a solution but as I do not have RedHat account I cant access to it ...

@seeAlso https://access.redhat.com/solutions/2121661

Thanks for your help!
PM
^
dcaron
 Posted: Feb 1 2016, 05:55 PM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 1673
Joined: 10-July 12









SOLVED!

As SL7.0 was installed, I've just installed yum-conf-sl7x to upgrade to SL7.1

# yum install yum-conf-sl7x
then

# yum clean all
# yum update
...
# /sbin/shutdown -r now

Yepp!!! Everything is OK now! http://dl.dropbox.com/u/2835777/egyptian.gif
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll