Scientific Linux

  Reply to this topicStart new topicStart Poll

> Install nvidia 96 driver
 Posted: Mar 20 2013, 09:09 PM
Quote Post

SLF Member

Group: Members
Posts: 81
Member No.: 1124
Joined: 15-December 11

Well with the sl-security update the .run and the kmod-nvidia-96XX died with xorg1.13
the "" is built for xorg 1.10 and 1.12

so downgrading xorg is needed
however xorg-1.13 added "xorg-x11-drv-modesetting" and this causes a unfixable error in downgrading
-- this can be done with Gnome running --
--- assuming you reinstalled nouveau to get the gui working again --

su -
yum remove xorg-x11-drv-modesetting
yum remove xorg-x11-drv-nouveau
yum --disablerepo=sl-security downgrade xorg\*
gedit /etc/yum.conf

add " exclude=xorg* " to "/etc/yum.conf"
to the file
edit /boot/grub/grub.conf ( or the link /etc/grub.conf )
add to the boot line


i created a small shell script to rebuild the boot image ( i have been doing this a lot and a script solves the TYPOS i make )
-- save as "/boot.image.rebuild .sh ( or a short name " / ")
save to " /"


mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r ).img.backup
dracut -f /boot/initramfs-$(uname -r).img $(uname -r)

reboot into int 3

run the "boot.image.rebuild .sh" script
reboot into int 3
run the
and reboot
and ( ONLY IF you need the mesa"gl.h" and not nvidia's "gl.h"

su -
yum reinstall mesa*
 Posted: Mar 21 2013, 07:02 AM
Quote Post

Retired SLF Administrator

Group: Admins
Posts: 1276
Member No.: 2
Joined: 8-April 11

Thanks for adding this

"Sometimes the best helping hand you can give is a good, firm push."
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll