Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> SL6 Chrome, SL6 Chrome
ddan
 Posted: Jan 21 2016, 01:25 PM
Quote Post


SLF Junior
**

Group: Members
Posts: 31
Member No.: 2273
Joined: 3-February 13









I'm getting an error in updating in chrome. I have had this error for a while, but would really like a new version of chrome.

google-chrome-stable-48.0.2564.82-1.x86_64
requires libstdc++.so.6(GLIBCXX_3.4.15)

Is there any way to get a new version?

ddan

PMEmail Poster
^
helikaon
 Posted: Jan 21 2016, 01:37 PM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 836
Member No.: 4
Joined: 8-April 11









QUOTE (ddan @ Jan 21 2016, 01:25 PM)
I'm getting an error in updating in chrome. I have had this error for a while, but would really like a new version of chrome.

google-chrome-stable-48.0.2564.82-1.x86_64
requires libstdc++.so.6(GLIBCXX_3.4.15)

Is there any way to get a new version?

ddan


Hi there,
looks like you're missing a library, that's part of standart SL repository:

here on my SL 6.7:
CODE

yum whatprovides */libstdc++.so.6

Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* sl: ftp2.scientificlinux.org
* sl-security: ftp2.scientificlinux.org
sl-security/filelists_db                                                                                                             | 3.8 MB     00:16
libstdc++-4.4.7-11.el6.x86_64 : GNU Standard C++ Library
Repo        : sl
Matched from:
Filename    : /usr/lib64/libstdc++.so.6

libstdc++-4.4.7-11.el6.i686 : GNU Standard C++ Library
Repo        : sl
Matched from:
Filename    : /usr/lib/libstdc++.so.6

libstdc++-4.4.7-11.el6.x86_64 : GNU Standard C++ Library
Repo        : installed
Matched from:
Filename    : /usr/lib64/libstdc++.so.6

libstdc++-4.4.7-11.el6.i686 : GNU Standard C++ Library
Repo        : installed
Matched from:
Filename    : /usr/lib/libstdc++.so.6


so if you have 64 bit system simple:
CODE

yum install libstdc++-4.4.7-11.el6.x86_64


should fix it


cheers smile.gif

--------------------
PMEmail Poster
^
ddan
 Posted: Jan 22 2016, 09:06 AM
Quote Post


SLF Junior
**

Group: Members
Posts: 31
Member No.: 2273
Joined: 3-February 13









helikaon thanks for your reply.

I still seem to be having a problem.
[dan@quad ~]$ su -c "yum install libstdc++-4.4.7-11.el6.x86_64"
Password:
Loaded plugins: priorities, protectbase, refresh-packagekit, security
Setting up Install Process
0 packages excluded due to repository protections
No package libstdc++-4.4.7-11.el6.x86_64 available.
Error: Nothing to do
[dan@quad ~]$

But the latest version is installed.
[dan@quad ~]$ su -c "yum install libstdc++"
Password:
Loaded plugins: priorities, protectbase, refresh-packagekit, security
Setting up Install Process
0 packages excluded due to repository protections
Package libstdc++-4.4.7-16.el6.x86_64 already installed and latest version
Nothing to do

[dan@quad ~]$ su -c "yum whatprovides */libstdc++.so.6"
Password:
Loaded plugins: priorities, protectbase, refresh-packagekit, security
0 packages excluded due to repository protections
adobe-linux-i386/filelists | 615 B 00:00
adobe-linux-x86_64/filelists | 620 B 00:00
epel/filelists_db | 8.0 MB 00:06
google-chrome/filelists | 1.6 kB 00:00
rpmfusion-free-updates/filelists_db | 153 kB 00:00
rpmfusion-nonfree-updates/filelists_db | 266 kB 00:00
sl6x-security/filelists_db | 1.2 MB 00:14
libstdc++-4.4.7-16.el6.i686 : GNU Standard C++ Library
Repo : sl
Matched from:
Filename : /usr/lib/libstdc++.so.6

libstdc++-4.4.7-16.el6.x86_64 : GNU Standard C++ Library
Repo : sl
Matched from:
Filename : /usr/lib64/libstdc++.so.6

libstdc++-4.4.7-16.el6.x86_64 : GNU Standard C++ Library
Repo : sl6x
Matched from:
Filename : /usr/lib64/libstdc++.so.6

libstdc++-4.4.7-16.el6.i686 : GNU Standard C++ Library
Repo : sl6x
Matched from:
Filename : /usr/lib/libstdc++.so.6

libstdc++-4.4.7-16.el6.x86_64 : GNU Standard C++ Library
Repo : installed
Matched from:
Filename : /usr/lib64/libstdc++.so.6

libstdc++-4.4.7-16.el6.i686 : GNU Standard C++ Library
Repo : installed
Matched from:
Filename : /usr/lib/libstdc++.so.6

ddan
PMEmail Poster
^
inittux
 Posted: Jan 23 2016, 12:12 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









Do you have a 32 or 64 bit OS?

uname -a? Try installing the 32 bit version since you already have the 64 bit version installed?

libstdc++-4.4.7-16.el6.i686

--------------------
PM
^
ddan
 Posted: Jan 24 2016, 04:58 AM
Quote Post


SLF Junior
**

Group: Members
Posts: 31
Member No.: 2273
Joined: 3-February 13









Greetings,

I was able to install the latest chrome by following the instructions here:

http://www.tecmint.com/install-google-chrome-on-redhat-centos-fedora-linux/

Dan
PMEmail Poster
^
inittux
 Posted: Jan 24 2016, 09:41 AM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









QUOTE (ddan @ Jan 24 2016, 06:58 AM)
Greetings,

I was able to install the latest chrome by following the instructions here:

http://www.tecmint.com/install-google-chrome-on-redhat-centos-fedora-linux/

Dan


Did you have the google repository enabled before? I also installed mine through the google-chrome repository, not running into any library issues.

--------------------
PM
^
ddan
 Posted: Jan 24 2016, 11:06 AM
Quote Post


SLF Junior
**

Group: Members
Posts: 31
Member No.: 2273
Joined: 3-February 13









inittux I followed the instructions for a 6.x system, which are to download and run a script. This is about the middle of the instructions. According to the article chrome is broken for 6.x systems and it is necessary to download libraries from a later release and run chrome with those libraries.

Do you have a 7.x or a 6.x system?
PMEmail Poster
^
inittux
 Posted: Jan 24 2016, 01:41 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









QUOTE (ddan @ Jan 24 2016, 01:06 PM)
inittux I followed the instructions for a 6.x system, which are to download and run a script.  This is about the middle of the instructions.  According to the article chrome is broken for 6.x systems and it is necessary to download libraries from a later release and run chrome with those libraries.

Do you have a 7.x or a 6.x system?


I was wondering why it wasn't working, but I didn't read the whole article. I see now wink.gif I have google-chrome running fine under my current system which is running on fedora 23.

--------------------
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll