Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> YUM proxy problem
Mumrik
 Posted: Aug 22 2012, 12:40 PM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 1717
Joined: 20-July 12









Hi all,
I have some issue with SL 6.2 YUM proxy:

# yum install -y samba
Loaded plugins: refresh-packagekit, security
http://ftp.scientificlinux.org/linux/scientific/6.2/i386/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 407"
Trying other mirror.
http://ftp1.scientificlinux.org/linux/scientific/6.2/i386/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 407"
Trying other mirror.
http://ftp2.scientificlinux.org/linux/scientific/6.2/i386/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 407"
Trying other mirror.
ftp://ftp.scientificlinux.org/linux/scientific/6.2/i386/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: sl. Please verify its path and try again



And, if it might be useful



# cat /etc/yum.conf
[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=3

# This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
# It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
PM
^
AndrewSerk
 Posted: Aug 22 2012, 01:32 PM
Quote Post


SLF Moderator
*****

Group: Moderators
Posts: 457
Member No.: 54
Joined: 14-April 11









Hi Mumrik,

There is only one thread per issue allowed. I deleted your other 2 identical posts.

Please don't double or triple post.

SLF Moderator

AndrewSerk
PM
^
inittux
 Posted: Aug 22 2012, 02:15 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









Where and how do you have the proxy configured?What kind of proxy is it? I compared my yum.conf to yours and it looks mostly the same. Are you able open a website like google.com or ping a website and get a reply?

--------------------
PM
^
tux99
 Posted: Aug 22 2012, 02:38 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









does ping ftp.scientificlinux.org work?

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
ian
 Posted: Feb 13 2013, 05:27 AM
Quote Post


SLF Newbie


Group: Members
Posts: 2
Member No.: 2291
Joined: 13-February 13









QUOTE (tux99 @ Aug 22 2012, 04:38 PM)
does ping ftp.scientificlinux.org work?

Hi,

Im having the same issue...
It's a squid proxy, with authentication switched on. Normaly this works...

[root@ian etc]# cat /etc/yum.conf
[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=3

proxy_username=myproxyusername
proxy_password=supersecretpwd


but no more...
I can ping ftp.scientificlinux.org and any other site... mellow.gif

PM
^
ian
 Posted: Feb 13 2013, 05:40 AM
Quote Post


SLF Newbie


Group: Members
Posts: 2
Member No.: 2291
Joined: 13-February 13









nevermind I found the problem...
PM
^
helikaon
 Posted: Feb 24 2013, 09:24 AM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 836
Member No.: 4
Joined: 8-April 11









QUOTE (ian @ Feb 13 2013, 05:40 AM)
nevermind I found the problem...


Hi,
just fyi and reference - if you're behind proxy, add those lines to:

/etc/yum.conf

CODE

proxy=http://proxy-url
proxy_username=your-username
proxy_password=your-pw


beware, that the pw is sent in plaintext, so possible security flaw.


--------------------
PMEmail Poster
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll