Scientific Linux Forum.org



Pages: (2) 1 2  ( Go to first unread post ) Reply to this topicStart new topicStart Poll

> Configure wireless in a desktop, Configure the wireless in a desktop
LizardoVP
 Posted: May 17 2016, 03:59 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









Dear all

I have a Pavilion All-in-One PC 23-p110la desktop running SL 6.7 and I want to configure the wireless connection.

I go to System -> Preferences -> Network Connections. Then I click on "Add", select "Wireless" and then "Create". As a result a window opens with the title "Editing wireless connection" requesting information like: SSID, BSSID, device MAC address, cloned MAC address, IPv4 setting, IPv6 settings etc. First of all I dont know if this is the right way to do it. If so, then I dont know where/how to retrieve the information that is needed.

If helpful, here is the result of the following command:
#ifconfig
eth0 Link encap:Ethernet HWaddr 00:25:AB:6A:94:B5
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 cool.gif TX bytes:0 (0.0 cool.gif

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:588 (588.0 cool.gif TX bytes:588 (588.0 cool.gif

virbr0 Link encap:Ethernet HWaddr 52:54:00:C4:35:F9
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:290 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 cool.gif TX bytes:93882 (91.6 KiB)

virbr0-nic Link encap:Ethernet HWaddr 52:54:00:C4:35:F9
inet6 addr: fe80::5054:ff:fec4:35f9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:8361 overruns:0 carrier:0
collisions:0 txqueuelen:500
RX bytes:0 (0.0 cool.gif TX bytes:0 (0.0 cool.gif


Thanks for your help,

Lizardo
PMEmail Poster
^
helikaon
 Posted: May 17 2016, 09:54 AM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 836
Member No.: 4
Joined: 8-April 11










Hi,
first of all, you should be able to see your wifi listed as in your 'ifconfig' command - eg. as "wlan0".
if you dont see it, it means it is not recognized, or is not turned on.

1. check if it is turned on (do you have a hw button on your laptop for that purpose?

2. check, your wi-fi card is recognized by the OS - have a look on the output of
CODE

lspci

command and look for something like eg.:
CODE

03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)


If your wifi is recognized, then check if your network manager is running:
CODE

service NetworkManager status


cheers,

--------------------
PMEmail Poster
^
LizardoVP
 Posted: May 17 2016, 08:20 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









Hi helikaon

Thanks for your help. For the ifconfig command, there is no wlan0 report, only eth0, lo and virbr0.

1. Im working on a desktop, so there is no hw button for the wireless

2. In the output of "lspci" I have

04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)

3. The output of "service NetworkManager status" is:

NetworkManager (pid 2516) is running...

So seems the network controller is recognized and seems to be in good helth. So, what else should I to to configure it?

Thanks!

Lizardo
PMEmail Poster
^
inittux
 Posted: May 19 2016, 05:34 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









When you click on your network manager icon are there any wireless networks available? I recently installed my laptop without a gui, and then installed MATE afterwards. I wasn't able to see any networks or connect to any either. I ended up finding and installing NetworkManager-wifi. I can't remember though if I was able or not able to see my wireless network interface.

--------------------
PM
^
LizardoVP
 Posted: May 20 2016, 02:26 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









Hi inittux

No, there are no wireless networks available when I open the network manager icon.
What is MATE? Do you think I should install it? In which repository is it?
Same for NetworkManager-wifi: what is it?

Kind regards,

Lizardo
PMEmail Poster
^
inittux
 Posted: May 20 2016, 04:36 AM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









QUOTE (LizardoVP @ May 20 2016, 03:26 AM)
Hi inittux

No, there are no wireless networks available when I open the network manager icon.
What is MATE? Do you think I should install it? In which repository is it?
Same for NetworkManager-wifi: what is it?

Kind regards,

Lizardo


I was wrong about that NetworkManager-wifi, ignore that I said it wink.gif. MATE is a DE(Desktop Environment), which you already have installed. You do see the device when you do lspci, but not showing up under ifconfig, so sounds like a driver issue then.

Check this post
Which is also explained in that post of how they resolved it.

Read this post first about third party repos. Then you need to install a third paryt repo, elrepo for Scientific LInux 6.
See instructions here.
But basically find your device and install the right kernel module.
Like explain here.
So like the example says there on the elrepo site do the following

CODE

[user@elrepo]$ /sbin/lspci | grep -i Ethernet
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

[user@elrepo]$ /sbin/lspci -n | grep '04:00.0'
04:00.0 0200: 10ec:8168 (rev 01)


Then after that it's just:

yum install kmod-r8168 (matching your device and vendor id from the lscpi outputs form the elrepo deviceid list.)

[Moderator edited to correct two minor formatting typos.]

This post has been edited by burakkucat: May 20 2016, 12:36 PM

--------------------
PM
^
LizardoVP
 Posted: May 21 2016, 04:02 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









Hi

I got the following:

/sbin/lspci | grep -i Network
04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)

/sbin/lspci -n | grep '04:00.0'
04:00.0 0280: 10ec:8179 (rev 01)

However, I couldnt find 10ec:8179 in http://elrepo.org/tiki/DeviceIDs.

In this forum http://scientificlinuxforum.org/index.php?showtopic=2569 i can read the advice from burakkucat saying I should download and install the kernel-lt package. So I did with the command:

yum install kernel-lt.x86_64

However, after rebooting my computer, my wireless is still not working.
In the previously cited forum Cicciograna says he solved the issue by installing the backports. So i did it by installing everything from the output of:

yum search backports

but it still doesnt work.

What do you think? Do you have any clue on where I can find the drivers of 10ec:8179?

Kind regards!
PMEmail Poster
^
inittux
 Posted: May 21 2016, 08:38 AM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









I pointed you to that post because that one had a link to this one. I could have linked straight to there but it was late or early so I probably wasn't fully awake when posting it. The point was to show you how to look for the vendor and device id's.

Yes according to that the driver for your wireless card should be in the kernel-ml.

Is that kernel actually installed? Can you run the command in the terminal?

CODE

rpm -qa | grep ^kernel

--------------------
PM
^
burakkucat
 Posted: May 21 2016, 02:45 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 200
Member No.: 14
Joined: 10-April 11









Upon checking for the Vendor:Device ID pairing of 10ec:8179, I see that both of the default distributed kernels (for SL6 and for SL7) should support the wireless device.

[Duo2 ~]$ grep -i 10ec /lib/modules/*/modules.alias | grep -i 8179
/lib/modules/2.6.32-642.el6.x86_64/modules.alias:alias pci:v000010ECd00008179sv*sd*bc*sc*i* rtl8188ee
[Duo2 ~]$

[Duo1 ~]$ grep -i 10ec /lib/modules/*/modules.alias | grep -i 8179
/mnt/lib/modules/3.10.0-327.18.2.el7.x86_64/modules.alias:alias pci:v000010ECd00008179sv*sd*bc*sc*i* rtl8188ee
[Duo1 ~]$

(Please note that the two systems upon which I performed my checks, Duo1 and Duo2, are both fully up to date RHEL7 and RHEL6 systems, respectively. That should not be relevant, as the Scientific Linux kernels will be identical to those of RHEL.)

We can see, above, that the relevant kernel module rtl8188ee and it is, indeed, available --

[Duo2 ~]$ find /lib/modules -type f -name rtl8188ee.ko
/lib/modules/2.6.32-642.el6.x86_64/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko
[Duo2 ~]$

[Duo1 ~]$ find /lib/modules -type f -name rtl8188ee.ko
/lib/modules/3.10.0-327.18.2.el7.x86_64/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko
[Duo1 ~]$

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
inittux
 Posted: May 21 2016, 03:01 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









QUOTE (burakkucat @ May 21 2016, 03:45 PM)
Upon checking for the Vendor:Device ID pairing of 10ec:8179, I see that both of the default distributed kernels (for SL6 and for SL7) should support the wireless device.

[Duo2 ~]$ grep -i 10ec /lib/modules/*/modules.alias | grep -i 8179
/lib/modules/2.6.32-642.el6.x86_64/modules.alias:alias pci:v000010ECd00008179sv*sd*bc*sc*i* rtl8188ee
[Duo2 ~]$

[Duo1 ~]$ grep -i 10ec /lib/modules/*/modules.alias | grep -i 8179
/mnt/lib/modules/3.10.0-327.18.2.el7.x86_64/modules.alias:alias pci:v000010ECd00008179sv*sd*bc*sc*i* rtl8188ee
[Duo1 ~]$

(Please note that the two systems upon which I performed my checks, Duo1 and Duo2, are both fully up to date RHEL7 and RHEL6 systems, respectively. That should not be relevant, as the Scientific Linux kernels will be identical to those of RHEL.)

We can see, above, that the relevant kernel module rtl8188ee and it is, indeed, available --

[Duo2 ~]$ find /lib/modules -type f -name rtl8188ee.ko
/lib/modules/2.6.32-642.el6.x86_64/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko
[Duo2 ~]$

[Duo1 ~]$ find /lib/modules -type f -name rtl8188ee.ko
/lib/modules/3.10.0-327.18.2.el7.x86_64/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko
[Duo1 ~]$


Good one! Didn't 'think to check the default kernel first http://th166.photobucket.com/albums/u117/rdshear/Smiley%20Faces/th_smiley-face-thumbs-up.gif

--------------------
PM
^
LizardoVP
 Posted: May 21 2016, 11:17 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









Hi all

Thanks for your replies. However I must confess Im quite confused. First of all let me tell you Im newbie on linux so I dont understand everything you guys say.
Anyway, I repited the steps burakkucat performed and here is the output:

[Lizardo@LizardoUNACH ~]$ grep -i 10ec /lib/modules/*/modules.alias | grep -i 8179
/lib/modules/3.10.101-1.el6.elrepo.x86_64/modules.alias:alias pci:v000010ECd00008179sv*sd*bc*sc*i* rtl8188ee
[Lizardo@LizardoUNACH ~]$ find /lib/modules -type f -name rtl8188ee.ko
/lib/modules/3.10.101-1.el6.elrepo.x86_64/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko

I dont know if this means I have already installed the required drivers. In the forum http://scientificlinuxforum.org/index.php?showtopic=2661 you suggest to check if the driver is selected and loaded using lsmod and modeprobe, so here is what I get:

[Lizardo@LizardoUNACH ~]$ lsmod | grep rtl8188ee
[Lizardo@LizardoUNACH ~]$ modprobe rtl8188ee
FATAL: Module rtl8188ee not found.

Concerning the advice from inittux, here it is:

[Lizardo@LizardoUNACH ~]$ rpm -qa | grep ^kernel
kernel-firmware-2.6.32-573.26.1.el6.noarch
kernel-2.6.32-573.22.1.el6.x86_64
kernel-2.6.32-573.el6.x86_64
kernel-headers-2.6.32-573.26.1.el6.x86_64
kernel-devel-2.6.32-573.26.1.el6.x86_64
kernel-devel-2.6.32-573.el6.x86_64
kernel-lt-3.10.101-1.el6.elrepo.x86_64
kernel-devel-2.6.32-573.22.1.el6.x86_64
kernel-doc-2.6.32-573.26.1.el6.noarch
kernel-abi-whitelists-2.6.32-573.26.1.el6.noarch


I honestly dont know if Im doing correct or not sad.gif
I will be absent for one week, I will check your new replies next sunday.

Thank you very much!
PMEmail Poster
^
burakkucat
 Posted: May 22 2016, 02:54 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 200
Member No.: 14
Joined: 10-April 11









Seeing the list of kernel related packages that you have on your laptop allows me to say that the rtl8188ee driver has only become supported in the base kernel of Scientific Linux 6.8 . . . which has not yet been released. Once SL 6.8 is built & released and you have the new kernel installed, the wireless sub-system should "just work".

It looks, to me, as if you were not running the ELRepo Project's kernel-lt when you attempted to modprobe the rtl8818ee driver. The output returned by a uname -r will identify which kernel has been booted and is currently running.

You will also need to have super-user privileges to execute the modprobe command.

I'm sure that if I'm not about, inittux will be able to assist you. smile.gif

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
inittux
 Posted: May 23 2016, 05:26 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









QUOTE (burakkucat @ May 22 2016, 03:54 PM)


I'm sure that if I'm not about, inittux will be able to assist you.  smile.gif

http://th166.photobucket.com/albums/u117/rdshear/Smiley%20Faces/th_smiley-face-thumbs-up.gif biggrin.gif Will try wink.gif

--------------------
PM
^
LizardoVP
 Posted: May 29 2016, 10:20 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









Hi all

As promised, Im back biggrin.gif
Well, I tried the command uname -r and I got:

2.6.32-573.26.1.el6.x86_64

I also repeated the modprobe rtl8188ee command as root and got the same output as before.

I dont know if Im getting closer to the solution sad.gif

Thanks for your help,

Lizardo
PMEmail Poster
^
inittux
 Posted: May 30 2016, 03:53 AM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









QUOTE (LizardoVP @ May 29 2016, 11:20 PM)
Hi all

As promised, Im back  biggrin.gif
Well, I tried the command uname -r and I got:

2.6.32-573.26.1.el6.x86_64

I also repeated the modprobe rtl8188ee command as root and got the same output as before.

I dont know if Im getting closer to the solution  sad.gif

Thanks for your help,

Lizardo


That's the default redhat kernel you're booting in, when you boot your machine you should have an option in the grub menu with the following entry:

kernel-lt-3.10.101-1.el6.elrepo.x86_64

If it's not selected you can use the up/down key and then press enter to select it and boot into it.

--------------------
PM
^
LizardoVP
 Posted: May 31 2016, 01:35 AM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









Hi inittux

Great, I did as you said. Now the output of uname -r is
3.10.101-1.el6.elrepo.x86_64

and the command modprobe rtl8188ee does not complain, it seems it is working.

So now it seems im really improving biggrin.gif

What would be next?

Lizardo
PMEmail Poster
^
inittux
 Posted: May 31 2016, 08:02 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









QUOTE (LizardoVP @ May 31 2016, 02:35 AM)
Hi inittux

Great, I did as you said. Now the output of uname -r is
3.10.101-1.el6.elrepo.x86_64

and the command   modprobe rtl8188ee  does not complain, it seems it is working.

So now it seems im really improving  biggrin.gif

What would be next?

Lizardo


If you click on network manager icon you should now see wireless network in your range and you can connect to one and enter the passphrase to connect. Might also be smart to set your default boot kernel to be booting up into elrepo kernel. Will have too look that up for you on my test machine, not running SL6 on any of my current machines. Something with editing /boot/grub/grub.cfg.

--------------------
PM
^
LizardoVP
 Posted: May 31 2016, 11:30 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









Hi

Sorry, but in my network connections there is still only the wired option. It doesnt detect any wireless. If in that same window I click on the "add" button, then select "wireless" and then "create" then a new window called "Editing wireless connection 1" opens, requesting information about SSID, MODE, BSSID, etc.

What am I doing wrong? http://www.madjacksports.com/forum/images/smilies/facepalm.gif

Kind regards,

Lizardo
PMEmail Poster
^
inittux
 Posted: Jun 1 2016, 07:52 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









Seems like the module is loaded now you aren't getting any errors, but not necesarry to that at every reboot since when you boot into that kernel the module loads automatically. Check if the module is loaded, if it is loaded wireless connections should show up in your network manager.

lsmod | grep 8179

or

lsmod | grep -i rtl8188ee

Is it an internel or external wireless card, if external can you see if it is on/activated?

--------------------
PM
^
LizardoVP
 Posted: Jun 2 2016, 10:30 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









It is an internal wireless card. Here is the results of the commands:

[root@LizardoUNACH Lizardo]# lsmod | grep 8179
[root@LizardoUNACH Lizardo]# lsmod | grep -i rtl8188ee
rtl8188ee 95457 0
rtlwifi 89349 1 rtl8188ee
mac80211 594916 2 rtl8188ee,rtlwifi

Although I honestly dont understand the meaning of the output.

Kind regards,

Lizardo
PMEmail Poster
^
inittux
 Posted: Jun 6 2016, 12:19 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









QUOTE (LizardoVP @ Jun 2 2016, 11:30 PM)
It is an internal wireless card. Here is the results of the commands:

[root@LizardoUNACH Lizardo]# lsmod | grep 8179
[root@LizardoUNACH Lizardo]# lsmod | grep -i rtl8188ee
rtl8188ee              95457  0
rtlwifi                89349  1 rtl8188ee
mac80211              594916  2 rtl8188ee,rtlwifi

Although I honestly dont understand the meaning of the output.

Kind regards,

Lizardo


Those were to check if the kernel driver modules for wireless were loaded. Will have to get back to you later on that. Can't think of anything right now.

--------------------
PM
^
helikaon
 Posted: Jun 6 2016, 01:46 PM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 836
Member No.: 4
Joined: 8-April 11










Hi,
just a question - the modules are loaded now - as you see them listed via 'lsmod' command - and do you see network interface eg wlan0 in the output of the 'ifconfig' command?

--------------------
PMEmail Poster
^
LizardoVP
 Posted: Jun 6 2016, 11:15 PM
Quote Post


SLF Rookie
*

Group: Members
Posts: 18
Member No.: 3691
Joined: 17-May 16









Hi Elikaon

No, I cant see any wlan0 in the ifconfig. In the output of this command I only have eth0, virbr0 and lo. Why could it be so? http://dl.dropbox.com/u/2835777/BangHead1.gif

Thanks for your help,

Lizardo
PMEmail Poster
^
inittux
 Posted: Jun 7 2016, 09:18 AM
Quote Post


SLF Geek
****

Group: Members
Posts: 280
Member No.: 953
Joined: 20-October 11









Was the wireless interface working before, under the previous OS you had installed? You can try creating a live usb to boot from with one of the following fedora spins. A liveusb is a way of booting into a OS without having to install so you can see what you think etc.Then boot from the live usb to check if you see a wirelesss interface via ifconfig and/or if you see any wireless connections via network manager. That way we'll know at least if the wireless interface is still working.

--------------------
PM
^
helikaon
 Posted: Jun 7 2016, 11:12 AM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 836
Member No.: 4
Joined: 8-April 11









QUOTE (LizardoVP @ Jun 6 2016, 11:15 PM)
Hi Elikaon

No, I cant see any wlan0 in the ifconfig. In the output of this command I only have eth0, virbr0 and lo. Why could it be so?   http://dl.dropbox.com/u/2835777/BangHead1.gif

Thanks for your help,

Lizardo


Hmm this is really weird,

it looks like the wifi card is still not visible to the system and only visible network interface is the standard network card you have on your PC.

please have a look at and post here output of (and post) :
CODE

lspci | grep -i network

you should see there both of your network cards wifi and standard wired NIC, because the "eth0" is standard network interface relying linked to standard network card

post/look on output of:
CODE

iw list


If you still dont see the wifi card, please check output of following commands - and try to look for the name of your wifi card or any suspicios errors
CODE

dmesg
dmesg | more (more will display only one page at a time)


just out of interest, please post here output:
CODE

cat /etc/sysconfig/network-scripts/ifcfg-eth0


to see config of your standard ether card


cheers
dmesg

--------------------
PMEmail Poster
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic OptionsPages: (2) 1 2  Reply to this topicStart new topicStart Poll