Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> SL6.8 failed GUI-boot after upgrade to Firefox-45, Boot hangs just before display of LOGIN
Xstack
 Posted: Jan 10 2017, 12:20 AM
Quote Post


SLF Junior
**

Group: Members
Posts: 39
Member No.: 91
Joined: 23-April 11









My bank has forced me out of the SL6.1 cave that has serviced my i686 well for many years (but with no better than Firefox-10). Do not have an x64 for SL7!

I cloned the SL6.1 partition, then updated the CLONE to SL6.8 and all went swimmingly (except for needing --skip-broken over ImageMagick & kipi-plugins .. removing some gstreamer stuff for that, but no loss as I do not use Xine anyway! Oh yes, also had to pre-replace old redhat-lsb pkg).

GUI-rebooted successfully into SL6.8 several times.

Then installed Firefox-45 which had a whole lot of dependencies, but nonetheless seemed to go fine, and I even used it a bit.

However, after I shut down I could not not reboot into SL6.8 again... (boots to SL6.1 partition are fine). The boot messages for 6.8 look ok ... the final one as far as I can detect something about loading the CIM server? All happens a bit too fast and PAUSE/BREAK no work. But boot output disappears and cursor goes to top left corner of screen, blinks once or twice, then stalls and screen remains blank.

It may be that the system thinks it has presented me with a LOGIN-FORM and is waiting for a response (as this is what would then occur on 6.1), but the 6.8 display stays blank.

Any clues or suggestions as to how to proceed appreciated as I have been head down/ bum up in the cave for a long time now.
PMEmail Poster
^
Xstack
 Posted: Jan 11 2017, 10:54 PM
Quote Post


SLF Junior
**

Group: Members
Posts: 39
Member No.: 91
Joined: 23-April 11









Yes, a technically hard issue I appreciate.
I could go about a solution differently with simple answers to a few simple questions.

(1) Anyone successfully running FF-45 under SL6?
(2) Anyone successfully running FF-45 under SL-6.8?
(3) Anyone successfully running FF-45 under SL-6.7?
.... etc ... you get the picture.
PMEmail Poster
^
Xstack
 Posted: Jan 12 2017, 09:07 PM
Quote Post


SLF Junior
**

Group: Members
Posts: 39
Member No.: 91
Joined: 23-April 11









Ah, I had forgotten about them, but now see my posts reporting similar failed update attempts in 2014 and 2015 that never found an answer. FF45 REQUIRES GTK2-2.4, and that seems to be the step that breaks the REBOOT process (when otherwise apparently running ok!). My cave dwelling in 6.1 has after all been less by choice than by being snookered!
PMEmail Poster
^
burakkucat
 Posted: Jan 13 2017, 02:42 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 207
Member No.: 14
Joined: 10-April 11









If it will be of any help to you, I am currently using the distribution version of Firefox (Firefox ESR 45.6.0) on RHEL 6.8

Scientific Linux 6.8 will have an identical version of Firefox (ESR 45.6.0) in their distribution.

[Duo2 ~]$ rpm -q redhat-release-server firefox
redhat-release-server-6Server-6.8.0.5.el6.x86_64
firefox-45.6.0-1.el6_8.x86_64

[Duo2 ~]$

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
Xstack
 Posted: Jan 14 2017, 10:09 PM
Quote Post


SLF Junior
**

Group: Members
Posts: 39
Member No.: 91
Joined: 23-April 11









Ta .. useful to know, although it is 64-bit, which seems to have received more thorough attention.
PMEmail Poster
^
Xstack
 Posted: Feb 28 2017, 03:23 AM
Quote Post


SLF Junior
**

Group: Members
Posts: 39
Member No.: 91
Joined: 23-April 11









For the sake of anyone else facing the 'reboot blackscreen instead of greeter' issue after a version upgrade I will just report that I did eventually get SL6.1 upgraded to SL6.8 version.

Unfortunately it took so many moves I have no clue as to the critical one. But in the end it made no difference which driver was used (nouveau or nvidia), no special flags like 'nomodeset' to the grub boot stanza are now needed, but generating a brand new initramfs file manually seems to have been critical in achieving success.

However, dual screens only seem to work in Gnome, not 'bugged' KDE4 video rendering. That may save someone some pain.
PMEmail Poster
^
monsee
 Posted: Mar 6 2017, 10:51 AM
Quote Post


SLF Member
***

Group: Members
Posts: 57
Member No.: 539
Joined: 27-July 11









I'm using Scientific Linux 6.8 32-bit and have Firefox 45.7.0 installed. All my System is updated and I have no problems at all.
PM
^
burakkucat
 Posted: Mar 6 2017, 02:52 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 207
Member No.: 14
Joined: 10-April 11









QUOTE (monsee @ Mar 6 2017, 10:51 AM)
All my System is updated and I have no problems at all.

That's good to know. smile.gif

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
Xstack
 Posted: Apr 1 2017, 06:01 PM
Quote Post


SLF Junior
**

Group: Members
Posts: 39
Member No.: 91
Joined: 23-April 11









QUOTE (monsee @ Mar 6 2017, 10:51 PM)
I'm using Scientific Linux 6.8 32-bit and have Firefox 45.7.0 installed. All my System is updated and I have no problems at all.


Yes, same here. The BIG THING was getting 6.1 up to 6.8 so that many hundreds of working Perl modules did not need re-installed (the updated versions of which sometimes refused to re-install under a fresh 6.8 directly!). All mostly good now, including a working legacy Google Chrome from 6.1 & many others too. Firefox was only indirectly related to the issues.
PMEmail Poster
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll