Scientific Linux Forum.org



Pages: (5) « First ... 3 4 5  ( Go to first unread post ) Reply to this topicStart new topicStart Poll

> VLC 2 for SL6 / RHEL6 / Centos 6
+X^N
 Posted: Jun 17 2014, 04:16 PM
Quote Post


SLF Member
***

Group: Members
Posts: 130
Member No.: 2581
Joined: 27-June 13









tux99 ,
thanks for continuing to 'publish' your multimedia packages.
.
This [SL 6.5 x96_64] is an install that has not had any MultiMedia packages installed.
- am using yum plugin protect on SL
- all 'other' repos are dis-abled
.
.
I desire to use your repo for VLC 2.0.7-10 x86_64 ,
- will enable linuxtech-release temporarily
- will disable yum protect for the SL temporarily
.
Given that :
QUOTE
tux99  Posted: Feb 23 2012, 08:06 PM
libvpx (replaces older libvpx from RHEL6 / Centos6 / SL6)

? What are the implications to the default OS player Totem ?
..
?Also , do you still recommend :
QUOTE
tux99 Posted: May 15 2013, 11:32 AM
QUOTE (tux99 @ May 15 2013, 11:32 AM)
QUOTE (redman @ May 15 2013, 05:08 PM)
QUOTE (tux99 @ May 15 2013, 03:30 PM)
Try installing the newer libdvdread from linuxtech-backports to see if that makes a difference (please note this will replace the official libdvdread from SL, that's why it's in backports, but in my experience it doesn't cause any problems).

That did it. After installing, without disabling SELinux, Cars 2 played.

Great, I'm glad we found the fix so quickly! http://th166.photobucket.com/albums/u117/rdshear/Smiley%20Faces/th_smiley-face-thumbs-up.gif

?
{I always wanted to do that that that )}

--------------------
DELL Precision 470 Workstation Xeon 3.2GHz (x2) , 2GB ECC ram ;
DELL UltraSharp 2007WFPb (L) ips monitor
Dual boot :1st installed: WinXPPro & then SL6.4 x86_64 - via 2 'everything' DVD s { GRUB going into the SL6.4 partition } ;
Updated to 6.5 via DVD s

& Steelcase vintage / old-school stenographers seat (made in Grand Rapids , MI , USA)
PMUsers Website
^
tux99
 Posted: Jun 18 2014, 12:05 AM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1276
Member No.: 224
Joined: 28-May 11









QUOTE (+X^N @ Jun 17 2014, 05:16 PM)
What are the implications to the default OS player Totem ?

Totem uses gstreamer as decoding back-end and the gstreamer-plugins-bad package will be replaced by the equivalent linuxtech package that supports far more codecs (including libvpx 1.0) than the SL6 version, so it's only an improvement.

QUOTE
Also , do you still recommend :

Yes, it works fine for me, if you have problems with it you can always remove it and put the default libdvdread package back, it's only one package, not dozens of dependencies, so it's easy to do.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
+X^N
 Posted: Jun 18 2014, 05:37 PM
Quote Post


SLF Member
***

Group: Members
Posts: 130
Member No.: 2581
Joined: 27-June 13









Thanks tux99 ,
Overall vlc works well for mp3 -s : user posted image
...
A non-reproducable error shows once - in - a - while playing an mp3.
It said someting about loading the latest ALSA.
.
But I clicked-too-fast ,
and did not write down the mesage.
..
Will post more , if it becomes an issue.
.
I have not tested on flac yet ;
- nor any videos.
.
I enabled vlc as a plugin for FireFox ;
but it is a a separate window.
? How do I open in a tab ?
...
Best regards,
Bill

--------------------
DELL Precision 470 Workstation Xeon 3.2GHz (x2) , 2GB ECC ram ;
DELL UltraSharp 2007WFPb (L) ips monitor
Dual boot :1st installed: WinXPPro & then SL6.4 x86_64 - via 2 'everything' DVD s { GRUB going into the SL6.4 partition } ;
Updated to 6.5 via DVD s

& Steelcase vintage / old-school stenographers seat (made in Grand Rapids , MI , USA)
PMUsers Website
^
tux99
 Posted: Jun 19 2014, 10:29 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1276
Member No.: 224
Joined: 28-May 11









QUOTE (+X^N @ Jun 18 2014, 06:37 PM)

Overall vlc works well for mp3 -s
A non-reproducable error shows once - in - a - while playing an mp3.
It said someting about loading the latest ALSA.
But I clicked-too-fast ,
and did not write down the mesage.
Will post more , if it becomes an issue.

Ok, yes please post the complete error message when you get it again.
That said it might be worth doing a web search with the error message first, it could well be a vlc problem rather than a problem specific to the linuxtech vlc package.

I have never used vlc for music/audio files myself, I use audacious for that which IMHO is much better suited for audio files.

QUOTE

I enabled vlc as a plugin for FireFox ;
but it is a a separate window.
? How do I open in a tab ?

How did you "enable vlc as a plugin for FireFox"?

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
+X^N
 Posted: Jun 20 2014, 12:23 AM
Quote Post


SLF Member
***

Group: Members
Posts: 130
Member No.: 2581
Joined: 27-June 13









tux99,
QUOTE
I use audacious for that which IMHO is much better suited for audio files.

I might look into that.
.
In the mean-time :
QUOTE
How did you "enable vlc as a plugin for FireFox"?

The VLC 'just showed up' in FireFox after installing from the LinuxTech repo :
- Installed VLC v. 2.0.7-10 ; devel & plugin-jack
.
When 'clicking on' an mp3 in a website after installing VLC ,
FireFox opened up Totem in a separate window ;
Totem 'asked' for codecs.
.
I looked in FF > Edit > Preferences > Applications
Content type "MP3 Audio" _ had _ Action "Use VLC Multimedia Plugin (compatable Totem 2.28.6) (in FF)".
..
So , I added VLC manually.
Now, FF opens VLC in a separate window & plays mp3.
.
Haven't played any movies on her system yet (nor installed the optional libdvdread you discussed w/ redman earlier).
.
This is on my g.f.'s system , so , I am trying to have her use SL , so , we can save dollars by avoiding Winds.
...
-On my system , FF plays an mp3 in a tab.
- loaded - by - manual -download
- from PUIAS
- VLC 1.2 & moz-plugin , etc
- way back when ... Jun 29 2013 "SL 6.4 default Totem (Movie Player) with libdvdcss Still won't play DVD, fresh install of SL 6.4 x86_64"
.
I didn't see any explicit moz-plugin-vlc in LinuxTech.
So , again -- to make my g.f. 'happy' ,
I would like to enable VLC to 'stay inside' FF.
...
Best regards,
Bill

--------------------
DELL Precision 470 Workstation Xeon 3.2GHz (x2) , 2GB ECC ram ;
DELL UltraSharp 2007WFPb (L) ips monitor
Dual boot :1st installed: WinXPPro & then SL6.4 x86_64 - via 2 'everything' DVD s { GRUB going into the SL6.4 partition } ;
Updated to 6.5 via DVD s

& Steelcase vintage / old-school stenographers seat (made in Grand Rapids , MI , USA)
PMUsers Website
^
tux99
 Posted: Jun 20 2014, 12:44 AM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1276
Member No.: 224
Joined: 28-May 11









QUOTE (+X^N @ Jun 20 2014, 01:23 AM)

When 'clicking on' an mp3 in a website after installing VLC ,
FireFox opened up Totem in a separate window ;
Totem 'asked' for codecs.

to enable totem to play mp3s install the various additional gstreamer-plugin packages (there are a few and I don't know of the top of my head which one adds the mp3 support).
QUOTE

I looked in FF > Edit > Preferences > Applications
Content type  "MP3 Audio"  _ had _ Action  "Use VLC Multimedia Plugin (compatable Totem 2.28.6) (in FF)".
..
So , I added VLC manually.

Ah, ok that's not the same as a FF plugin.
If you want to use vlc as a plugin rather than the default totem then you need to install the npapi-vlc package. I didn't package it as I'm happy with the totem plugin in FF (with all gstreamer -plugins for full codec support) so you won't find it in the linuxtech repo, but the one in the rpmfusion repo should work. Don't mix rpmfusion with linuxtech as the two repos overlap and conflict with each other, but you shouldn't have problems with the npapi-vlc package.
just install it directly with:
CODE
yum install  http://download1.rpmfusion.org/free/el/updates/6/x86_64/npapi-vlc-2.0.0-1.el6.x86_64.rpm

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic OptionsPages: (5) « First ... 3 4 5  Reply to this topicStart new topicStart Poll