Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> handbrake from Linuxtex breaks upgrade 6.5->6.6
joka
 Posted: Nov 14 2014, 07:00 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 172
Member No.: 107
Joined: 28-April 11









The depedencies of the handbrake RPM 0.98 from Linuxtex are no more compatible with SL/CentOS 6.6 because of the updated webkit packages. I had to remove handbrake to get the upgrade to SL 6.6 running:

CODE
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-431.20.3.el6 will be erased
---> Package kernel-devel.x86_64 0:2.6.32-431.20.3.el6 will be erased
---> Package webkitgtk.x86_64 0:1.2.6-5.el6 will be updated
--> Processing Dependency: libwebkit-1.0.so.2()(64bit) for package: handbrake-gui-0.9.8-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: handbrake-gui-0.9.8-1.el6.x86_64 (@linuxtech-testing/6.3)
          Requires: libwebkit-1.0.so.2()(64bit)
          Removing: webkitgtk-1.2.6-5.el6.x86_64 (@sl/6.5)
              libwebkit-1.0.so.2()(64bit)
          Updated By: webkitgtk-1.4.3-8.el6.x86_64 (sl)
              Not found
You could try using --skip-broken to work around the problem


@tux99: it would be nice if you have time to rebuild handbrake RPMs for EL 6.6.
PM
^
tux99
 Posted: Nov 15 2014, 07:31 AM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









Thanks for reporting the problem, I should be able to rebuild the package over the weekend (today or tomorrow).

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
tux99
 Posted: Nov 16 2014, 01:07 AM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









Hmmm, this looks like a regression/bug introduced by Red Hat in 6.6:

These are the 'provides' of the webkitgtk package from SL 6.5:
CODE
$ rpm -q --provides -p webkitgtk-1.2.6-5.el6.i686.rpm
WebKit-gtk = 1.2.6-5.el6
libwebkit-1.0.so.2
webkitgtk = 1.2.6-5.el6
webkitgtk(x86-32) = 1.2.6-5.el6


And these the one from SL 6.6:
CODE
$ rpm -q --provides -p webkitgtk-1.4.3-8.el6.i686.rpm
WebKit-gtk = 1.4.3-8.el6
libwebkitgtk-1.0.so.0
webkitgtk = 1.4.3-8.el6
webkitgtk(x86-32) = 1.4.3-8.el6


Red Hat broke the dependencies by replacing 'libwebkit-1.0.so.2' with 'libwebkitgtk-1.0.so.0' in the package 'provides' list. The actual old and new version of the library are ABI and API compatible according to a check I did with 'abi-compliance-checker', so this appears to be purely a packaging bug, not an actual library incompatibility.

This kind of simple and very easy to spot breakage (even with automated tools) is not what I would expect from Red Hat in a stable enterprise distro. QA seems to be slipping... dry.gif

Anyway, the only practical solution for me is to rebuild the Handbrake package, waiting for Red Hat to acknowledge and fix this bug would take way too long especially since libwebkit is a library used by GUI apps which Red Hat notoriously treats with low priority.


I will have to rebuild the 'Handbrake' and the 'Miro' packages as these are the only two packages in Linuxtech repos requiring libwebkit.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
joka
 Posted: Nov 16 2014, 01:39 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 172
Member No.: 107
Joined: 28-April 11









Thanks for info.
gnucash from EPEL is my package requiring libwebkit.

Apparently the EPEL mainainer of gnucash had the same problem. gnucash--2.4.15 was rebuilt at 21 Okt 2014.

gnucash changelog:
CODE
* Di Okt 21 2014 Bill Nottingha, <notting@splat.cc> - 2.4.15-4
- rebuild for webkitgtk bump (#1155078)

* Mi Jan 22 2014 Bill Nottingham <notting@redhat.com> - 2.4.15-3
- fix now-obsolete qbanking requirement (#1056425)
...

PM
^
tux99
 Posted: Nov 16 2014, 08:09 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









The good news is that Handbrake 0.9.9 now builds on EL 6.6 due to the updated gtk libs! http://th166.photobucket.com/albums/u117/rdshear/Smiley%20Faces/th_smiley-face-thumbs-up.gif

I have built Handbrake 0.9.9 packages now, they are in testing but I have not had the time to test the packages properly yet so use with caution. wink.gif

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
tux99
 Posted: Nov 24 2014, 09:55 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









Looks like we weren't the only ones having issues due to the webkitgtk package breaking backward compatibility by changing the 'Provides':
https://bugzilla.redhat.com/show_bug.cgi?id=1152849

As a consequence Redhat has just updated the webkitgtk package re-adding the 'Provides' of the previous webkitgtk package so now even the old handbrake packages will no longer trigger dependency issues in 6.6.

QUOTE
Previously, the wrong provides were preventing successful upgrades of the
operating system
. As a consequence, running the "yum update" command produced an
error. In addition, the error message prompted the user to use the
"--skip-broken" option to work around the problem, which, however, led to a
different update path. This update provides the correct backwards-compatible
symbolic links for the webkitgtk packages
, and "yum update" now successfully
updates the system. (BZ#1162701)

https://rhn.redhat.com/errata/RHBA-2014-1883.html


So the title of this thread is wrong, it was the Redhat webkitgtk packages that were breaking upgrade from 6.5 to 6.6, not the Linuxtech handbrake packages. wink.gif

The only good thing that came out of all this is that now we have handbrake 0.9.9 packages thanks to the gtk library update in 6.6. http://th166.photobucket.com/albums/u117/rdshear/Smiley%20Faces/th_smiley-face-thumbs-up.gif

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll