Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Important notice for all Linuxtech repo users, please read
tux99
 Posted: Jun 3 2013, 05:08 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1277
Member No.: 224
Joined: 28-May 11









Since the packaged versions of the FFmpeg and X264 libraries in the linuxtech repos were getting rather old and the latest version of VLC (and some other packages) requires newer versions of FFMpeg and X264 I have packaged up brand new versions of FFmpeg (1.1.5) and X264 (130).

The problem is that especially FFmpeg is a dependency of many other packages so I couldn't just update it as the newer version isn't ABI compatible with the old version.

Therefore I have created an updated package of the old versions of FFmpeg and X264 and a new package of the latest version that can be installed alongside each other.

Basically the updates will happen as follows:

the old ffmpeg-libs 0.6.5 package will be updated to the latest 0.6.x version (0.6.6):
ffmpeg-libs-0.6.5 -> ffmpeg-libs_0.6-0.6.6

If you also have the ffmpeg executables and/or the development package installed, then these will be updated to the new release 1.1.5:
ffmpeg-0.6.5 -> ffmpeg-1.1.5
ffmpeg-libs-devel-0.6.5 -> ffmpeg-libs-devel-1.1.5
these two will also install the latest ffmpeg libraries as a dependency: ffmpeg-libs_1.1-1.1.5


Similarly with x264:
libx264-0.115-0.20110510 -> libx264_115-0.115-0.20110722

x264-0.115-0.20110510 -> x264-0.130-0.20130531
libx264-devel-0.115-0.20110510 -> libx264-devel-0.130-0.20130531
new dependency: libx264_130-0.130-0.20130531


Basically all these updates should happen smoothly without any problems, I have tested them on a my SL6.4 and Centos 6.4 PCs without seeing any issues.

The reason I'm posting this notice is to make you aware of this and in case you experience any update issues related to the ffmpeg or x264 packages please post the details of you problem here (including the error output from yum).

I will be putting these updates in 'linuxtech-testing' later tonight and then move them to 'linuxtech-release in a week or two if I don't get any reports of problems.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
toracat
 Posted: Jun 3 2013, 05:14 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 303
Member No.: 11
Joined: 10-April 11









Thanks. Just what I needed. smile.gif I will report back if I find any issues.

--------------------
ELRepo: repository specializing in hardware support for EL
PMUsers Website
^
tux99
 Posted: Jun 3 2013, 06:20 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1277
Member No.: 224
Joined: 28-May 11









Ok, the new packages are all in 'linuxtech-testing' now, if anyone wants to try the update already and then report back here if it worked fine or not, then run the following command as root (this assumes you already have the old ffmpeg and x264 packages installed from the linuxtech repo, for example as dependencies for VLC from linuxtech):

yum --enablerepo=linuxtech-testing update

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
joka
 Posted: Jun 4 2013, 06:32 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 172
Member No.: 107
Joined: 28-April 11









QUOTE (tux99 @ Jun 3 2013, 07:20 PM)
Ok, the new packages are all in 'linuxtech-testing' now, if anyone wants to try the update already and then report back here if it worked fine or not, then run the following command as root (this assumes you already have the old ffmpeg and x264 packages installed from the linuxtech repo, for example as dependencies for VLC from linuxtech):

yum --enablerepo=linuxtech-testing update


The udpdate has worked for me without isses.
I have tested VLC and Totem with Flash and MP4 videos, and VLC with DVB-T on my 32-bit EeePC 901 netbook.

CODE
================================================================================
Package           Arch     Version                   Repository           Size
================================================================================
Installing:
ffmpeg-libs_0.6   x86_64   0.6.6-3.el6               linuxtech-testing   2.6 M
    replacing  ffmpeg-libs.x86_64 0.6.5-2.el6
libx264_115       x86_64   0.115-0.20110722.2.el6    linuxtech-testing   301 k
    replacing  libx264.x86_64 0.115-0.20110510.1.el6
Updating:
libva             x86_64   1.0.16-3.el6              linuxtech-testing    55 k

Transaction Summary
================================================================================
Install       2 Package(s)
Upgrade       1 Package(s)

PM
^
tux99
 Posted: Jun 4 2013, 07:05 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1277
Member No.: 224
Joined: 28-May 11









QUOTE (joka @ Jun 4 2013, 07:32 PM)
The udpdate has worked for me without isses.
I have tested VLC and Totem with Flash and MP4 videos, and VLC with DVB-T on my 32-bit EeePC 901 netbook.


Thanks for the feedback.

I have actually found one bug with the new ffmpeg-1.1.5 packages, the devel package can't be installed due to bad dependency (it's looking for ffmpeg-libs = 1.1.5, but it should be looking for ffmpeg-libs_1.1 = 1.1.5), I will have to fix that. http://www.madjacksports.com/forum/images/smilies/facepalm.gif

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
tux99
 Posted: Jun 5 2013, 10:00 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1277
Member No.: 224
Joined: 28-May 11









Ok, the dependency bug in the ffmpeg-libs-devel-1.1.5 package is fixed now.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
tux99
 Posted: Jun 15 2013, 12:16 AM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1277
Member No.: 224
Joined: 28-May 11









I have moved all updated ffmpeg and x264 packages to the release repo now, if anyone notices an yum update problems with these packages please let me know.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
ssettlemyre
 Posted: Aug 20 2013, 05:52 PM
Quote Post


SLF Newbie


Group: Members
Posts: 1
Member No.: 2680
Joined: 20-August 13









I added the linuxtech.repo file with release, testing and backports entries, but still get dependency errors when installing ffmpeg2theora

...
--> Finished Dependency Resolution
Error: Package: libva-1.0.16-3.el6.x86_64 (linuxtech)
Requires: libdrm.so.2()(64bit)
Error: Package: ffmpeg-libs_0.6-0.6.6-3.el6.x86_64 (linuxtech)
Requires: libtheoradec.so.1(libtheoradec_1.0)(64bit)
Error: Package: ffmpeg2theora-0.27-2.el6.x86_64 (linuxtech)
Requires: libtheoradec.so.1()(64bit)
Error: Package: ffmpeg-libs_0.6-0.6.6-3.el6.x86_64 (linuxtech)
Requires: libdc1394.so.22()(64bit)
Error: Package: ffmpeg2theora-0.27-2.el6.x86_64 (linuxtech)
Requires: libtheoraenc.so.1(libtheoraenc_1.0)(64bit)
Error: Package: ffmpeg2theora-0.27-2.el6.x86_64 (linuxtech)
Requires: libtheoraenc.so.1()(64bit)
Error: Package: libffado-2.1.0-0.8.20120325.svn2088.el6.x86_64 (linuxtech)
Requires: libiec61883.so.0()(64bit)
Error: Package: libffado-2.1.0-0.8.20120325.svn2088.el6.x86_64 (linuxtech)
Requires: libraw1394.so.11()(64bit)
Error: Package: libsndfile-1.0.17-1.el5.rf.x86_64 (rpmforge)
Requires: libFLAC.so.7()(64bit)
Error: Package: ffmpeg-libs_0.6-0.6.6-3.el6.x86_64 (linuxtech)
Requires: libtheoraenc.so.1(libtheoraenc_1.0)(64bit)
Error: Package: ffmpeg-libs_0.6-0.6.6-3.el6.x86_64 (linuxtech)
Requires: libtheoraenc.so.1()(64bit)
Error: Package: libva-1.0.16-3.el6.x86_64 (linuxtech)
Requires: mesa-dri-drivers
Error: Package: ffmpeg2theora-0.27-2.el6.x86_64 (linuxtech)
Requires: libtheoradec.so.1(libtheoradec_1.0)(64bit)
Error: Package: ffmpeg-libs_0.6-0.6.6-3.el6.x86_64 (linuxtech)
Requires: libtheoradec.so.1()(64bit)
PM
^
tux99
 Posted: Aug 20 2013, 10:56 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1277
Member No.: 224
Joined: 28-May 11









It looks like you are mixing the Linuxtech repo with RPMforge. Although RPMforge and Linuxtech can function together in many cases, this combination is not recommended, the only combination I test and support is Linuxtech with Elrepo and Epel (and only the main/release repos, not 'testing' or other secondary repos).

Also you should never keep the 'testing' and 'backports' repo enabled, only enable them temporarily (with yum -enablerepo=... ) when you specifically need to install something from these repos.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll