Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> Avidemux for SL 6 / Centos 6 / RHEL 6, Graphical video editing and transcoding
tux99
 Posted: May 2 2013, 02:01 AM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









Avidemux 2.5.6 is now available in the linuxtech-testing repo.


description:
Avidemux is a free video editor designed for simple cutting, filtering and encoding tasks. It supports many file types, including AVI, DVD compatible MPEG files, MP4 and ASF, using a variety of codecs. Tasks can be automated using projects, job queue and powerful scripting capabilities.


You can choose between the QT4 GUI version or the GTK GUI version, or install them both if you want. wink.gif


official web site:
http://avidemux.sourceforge.net/


Quick install instructions:
1) install the linuxtech.repo config file if you don't have it already:
su - root
cd /etc/yum.repos.d/
wget http://pkgrepo.linuxtech.net/el6/release/linuxtech.repo

2) install Avidemux:
yum --enablerepo=linuxtech-testing install avidemux-gtk (GTK GUI version)
and/or
yum --enablerepo=linuxtech-testing install avidemux-qt (QT GUI version)


Avidemux was so far only available for EL6 in the Russian NauLinux School repo, their package is based on the ATrpms source package while I chose to base the Linuxtech packages on the Fedora RPM Fusion source package and I have enabled a few additional plugins.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
U308
 Posted: May 21 2013, 03:54 PM
Quote Post


SLF Advocate
*****

Group: Members
Posts: 472
Member No.: 32
Joined: 11-April 11









Good that you saw fit to package avidemux, tux99 smile.gif
I still have 2.5.4 (from atrpms), works perfectly, but now I have the chance to remove it and thus reduce the atrpms packages on my system. The priorities have protected me well so far and atrpms repo is disabled.
Any reason why 2.5.6 is still in testing ? Will download and install shortly.

Regards
PM
^
toracat
 Posted: May 21 2013, 04:53 PM
Quote Post


SLF Geek
****

Group: Members
Posts: 302
Member No.: 11
Joined: 10-April 11









Thanks for offering avidemux, tux99. Seems like version 2.6.4 is stable now. Do you know if this builds on EL6? Or would it require packages newer than what is in EL6?

--------------------
ELRepo: repository specializing in hardware support for EL
PMUsers Website
^
tux99
 Posted: May 21 2013, 06:14 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









QUOTE (toracat @ May 21 2013, 05:53 PM)
Thanks for offering avidemux, tux99. Seems like version 2.6.4 is stable now. Do you know if this builds on EL6? Or would it require packages newer than what is in EL6?


Thanks for the heads up with regards to 2.6.4 being considered stable.
I built 2.5.6 because at the time that was the recommended stable version, I haven't tried to built 2.6.x at all so it might well be possible that it builds. I might give it a go soon when I have the time for it.

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
tux99
 Posted: May 21 2013, 06:16 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









QUOTE (U308 @ May 21 2013, 04:54 PM)
Any reason why 2.5.6 is still in testing ?  Will download and install shortly.


No particular reason other than laziness and lack of time to move it to release. wink.gif
In fact 'testing' is full of packages that I need to move to 'release'... sad.gif

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
tux99
 Posted: May 21 2013, 10:56 PM
Quote Post


SLF Moderator
********

Group: Moderators
Posts: 1273
Member No.: 224
Joined: 28-May 11









QUOTE (tux99 @ May 21 2013, 07:14 PM)
QUOTE (toracat @ May 21 2013, 05:53 PM)
Thanks for offering avidemux, tux99. Seems like version 2.6.4 is stable now. Do you know if this builds on EL6? Or would it require packages newer than what is in EL6?


Thanks for the heads up with regards to 2.6.4 being considered stable.
I built 2.5.6 because at the time that was the recommended stable version, I haven't tried to built 2.6.x at all


Ok, according to this page:
http://www.avidemux.org/admWiki/doku.php?id=versions:main
the whole 2.6 branch is experimental and in fact the only major distro that ships 2.6.x packages is Fedora:
http://pkgs.org/search/?keyword=avidemux&search_on=name&distro=0
So I'm not quite sure if replacing 2.5.6 with 2.6.4 is a good idea, does anyone know more about this and/or has already tried 2.6.x?

--------------------
My personal SL6 repository, specialized in audio/video software: http://pkgrepo.linuxtech.net/el6/
(can be used together with EPEL and ELRepo repositories) - repository mirror: http://linuxsoft.cern.ch/linuxtech/el6/
PM
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll