Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> HP Elitebook 8560p - Does not suspend on lid close
rickyjones
 Posted: Feb 28 2014, 03:25 PM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 2803
Joined: 8-November 13









Hi,

I have an HP Elitebook 8560p laptop running SL6.4 (Updates installed now reports 6.5). Suspend works if I select the option from the System -> Shut Down menu. However I'd like it to suspend when I close the lid.

In the Power Management Preferences program I have it configured to suspend when the laptop lid is closed. However when I close the laptop lid the screen simply turns off. If I have a second monitor connected then the display is shifted to the second monitor.

Again, if I manually suspend it works just fine. This behavior was working in Fedora 20 with a much newer kernel and other features of course. I have a gut feeling that an event isn't being recorded properly, or something isn't being triggered. I just don't know what that trigger would be or even where to begin looking.

[richard@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.32-431.5.1.el6.x86_64 #1 SMP Tue Feb 11 13:30:01 CST 2014 x86_64 x86_64 x86_64 GNU/Linux


Any help would be greatly appreciated. Google has been extremely unhelpful in this regard as most results are related to disabling the suspend feature.

Thank you,
Richard
PM
^
burakkucat
 Posted: Feb 28 2014, 09:56 PM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 196
Member No.: 14
Joined: 10-April 11









QUOTE (rickyjones @ Feb 28 2014, 03:25 PM)
<snip>
This behavior was working in Fedora 20 with a much newer kernel and other features of course. I have a gut feeling that an event isn't being recorded properly, or something isn't being triggered.
<snip>

It would be a simple four-part test to see if the SL kernel is responsible for the problem:

(1) yum install elrepo-release
(2) yum --enablerepo elrepo-kernel install kernel-lt
(3) Re-boot the system, ensuring that kernel-lt is selected from the Grub menu.
(4) Check for system suspension upon lid closure.

wink.gif

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
rickyjones
 Posted: Feb 28 2014, 11:28 PM
Quote Post


SLF Newbie


Group: Members
Posts: 5
Member No.: 2803
Joined: 8-November 13









QUOTE (burakkucat @ Feb 28 2014, 04:56 PM)
QUOTE (rickyjones @ Feb 28 2014, 03:25 PM)
<snip>
This behavior was working in Fedora 20 with a much newer kernel and other features of course. I have a gut feeling that an event isn't being recorded properly, or something isn't being triggered.
<snip>

It would be a simple four-part test to see if the SL kernel is responsible for the problem:

(1) yum install elrepo-release
(2) yum --enablerepo elrepo-kernel install kernel-lt
(3) Re-boot the system, ensuring that kernel-lt is selected from the Grub menu.
(4) Check for system suspension upon lid closure.

wink.gif


Thanks! I will give that a try as soon as I can this weekend. I currently have RPMForge enabled, I believe. I saw a warning that this does not play well with ELRepo. Is that correct? How should I go about disabling one? I assume that kernel-lt is an updated kernel? One thing that I'm trying to avoid is too many changes in the kernel as it seems to drastically effect VMware Workstation. Could you elaborate on kernel-lt?

Thank you so much!

-Richard
PM
^
burakkucat
 Posted: Mar 1 2014, 12:19 AM
Quote Post


SLF Administrator
****

Group: Admins
Posts: 196
Member No.: 14
Joined: 10-April 11









QUOTE

I currently have RPMForge enabled, I believe. I saw a warning that this does not play well with ELRepo. Is that correct?

No, that is not correct. I suspect you have mistaken the ELRepo Project for Fedora's EPEL.

I am just suggesting that you perform a test with kernel-lt, to determine if the problem originates with the distributed Scientific Linux kernel or not . . . Once you have finished testing, it is simple to revert:

(1) Re-boot the system, ensuring that the distro kernel is selected from the Grub menu.
(2) yum remove kernel-lt

QUOTE

Could you elaborate on kernel-lt?

I would prefer to direct you to the kernel-lt wiki page, which provides all the information. smile.gif

--------------------
user posted image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.
PMUsers Website
^
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll