Scientific Linux Forum.org



  Reply to this topicStart new topicStart Poll

> About NIS server on SL 7.2, installing NIS server on SL 7.2
c00jsw00
 Posted: Apr 20 2016, 07:46 AM
Quote Post


SLF Newbie


Group: Members
Posts: 1
Member No.: 3675
Joined: 20-April 16









Dear All,
I used the reference "http://www.server-world.info/en/note?os=CentOS_7&p=nis" to install
my NIS server. But the error message occur. Could you tell me how to overcome the issue?
Thanks
Phil

error:
------------------------------------------------------
root@c40 ycyuan]# /usr/lib64/yp/ypinit -m

At this point, we have to construct a list of the hosts which will run NIS
servers. c40.pharm.kmu.edu.tw is in the list of NIS server hosts. Please continue to add
the names for the other hosts, one per line. When you are done with the
list, type a <control D>.
next host to add: c40.pharm.kmu.edu.tw
next host to add:
The current list of NIS servers looks like this:

c40.pharm.kmu.edu.tw

Is this correct? [y/n: y] y
We need a few minutes to build the databases...
Building /var/yp/KMU_GPU_CLUSTER/ypservers...
Running /var/yp/Makefile...
gmake[1]: Entering directory `/var/yp/KMU_GPU_CLUSTER'
Updating passwd.byname...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating passwd.byuid...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating group.byname...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating group.bygid...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating hosts.byname...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating hosts.byaddr...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating rpc.byname...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating rpc.bynumber...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating services.byname...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating services.byservicename...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating netid.byname...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating protocols.bynumber...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating protocols.byname...
failed to send 'clear' to local ypserv: RPC: Program not registeredUpdating mail.aliases...
failed to send 'clear' to local ypserv: RPC: Program not registeredgmake[1]: Leaving directory `/var/yp/KMU_GPU_CLUSTER'

c40.pharm.kmu.edu.tw has been set up as a NIS master server.

Now you can run ypinit -s c40.pharm.kmu.edu.tw on all slave server.
PMEmail Poster
^
helikaon
 Posted: Apr 20 2016, 01:16 PM
Quote Post


SLF Administrator
*******

Group: Admins
Posts: 836
Member No.: 4
Joined: 8-April 11









Hi,
i haven't used YP for years, but i'd check:

- if you server has properly set hostname in /etc/hosts
- if your server is running? if not, start it and run command again
- check firewall settings

cheers

--------------------
PMEmail Poster
^
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll